Video's with subs play short using Mencoder as well as ffmpeg

For help and support with Linux-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Tonne M
Posts: 29
Joined: Sat Jul 18, 2015 6:29 am

Video's with subs play short using Mencoder as well as ffmpeg

Post by Tonne M » Tue Feb 19, 2019 6:42 am

Hi,

For some years I have been using UMS. Recently I made a clean install of Mint 19.1.
Installed UMS 7.8.0, watched some video's which didn't need transcoding. Perfect.

Today however, I tried to play a file with subtitles.
Both ffmpeg and Mencoder show the same weird behavior which I am unable to solve as it seems.

I start the video and it plays just fine. Subs are perfect, sound and video too.
But then, after about a minute or so, sound disappears, video freezes and then the tv screen goes black.
After some 20 seconds, the whole things picks up where it went wrong and plays just fine for a minute or so.
Only to repeat that same behavior time after time.

I tried to increase as well as decrease the buffersize and some other settings but to no avail.

Mind you, VLC does not exhibit this behavior. However, VLC shows all subs at once. In this case, English (twice) and Dutch.
Pretty messy on the tv...

Not sure if this is Linux specific but it might be.
My Java is version 10 b.t.w.
The disk with the video does not spin down either. FWIW.
The log shows no errors either.

I will add a trace as soon as I have the opportunity.

Here is the trace log attached.

First I watched Poirot which has no subtitles. So it ran fine.
Then I tried to play the NCIS file which exhibits the above behavior.
But while it looks as if it plays fine, in that short period playback stopped and started three times.
Attachments
ums_dbg.zip
(311.38 KiB) Downloaded 43 times

Nadahar
Posts: 1439
Joined: Tue Jun 09, 2015 5:57 pm

Re: Video's with subs play short using Mencoder as well as ffmpeg

Post by Nadahar » Sun Aug 11, 2019 12:02 am

desley06 wrote:
Sat Aug 10, 2019 9:28 pm
If you're like me, you noticed this only because the ubuntu packaging changed, and made it look like libav was a rebrand/replace of ffmpeg.

This is because its packager is in the libav camp - in reality libav is a fork that originated in developer drama - some understandable, some justified, but ending in childish fallout all the same.
Unless I'm missing something, you're some years late. Debian (on which Ubuntu, Mint and others are built) switched to Libav as the default back in 2011, but switched back to FFmpeg in 2015. As of today, all the Debian based distros should package FFmpeg by default.

Post Reply