[SOLVED] Error occurred during initialization of VM

For help and support with Linux-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Rude-E
Posts: 2
Joined: Wed Feb 26, 2020 7:48 am

[SOLVED] Error occurred during initialization of VM

Post by Rude-E » Wed Feb 26, 2020 7:56 am

Hello,

I am trying to run UMS on Linux Mint, but I am not getting it to work. I have followed the instructions of the install.txt but I am running into some issues.

The first one is when installing the one of the pre-reqs: vlc-nox. When using the command "sudo apt-get install mediainfo dcraw vlc-nox mplayer mencoder" I get the following:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package vlc-nox is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
vlc-bin:i386 vlc-bin

E: Package 'vlc-nox' has no installation candidate

As I have a functioning VLC Media Player installed, I didn't think this would be an issue. So I continued. When we get to the end and I try to run UMS I enter the following command "./UMS.sh" I then get the following error:

Error occurred during initialization of VM
java/lang/ClassNotFoundException: error in opening JAR file /home/myname/Downloads/ums-9.3.0/linux/jre-x64/lib/rt.jar

A Google search tells me that the java installed is corrupt. But when I delete it and install java again, this message keeps happening. I could use some help here, please. Very new to Linux so apologies if I don't immediately understand your replies.
Last edited by Rude-E on Thu Feb 27, 2020 6:00 am, edited 1 time in total.

Nadahar
Posts: 1867
Joined: Tue Jun 09, 2015 5:57 pm

Re: Error occurred during initialization of VM

Post by Nadahar » Wed Feb 26, 2020 11:03 am

The 9.3.0 release is broken for Linux, this has nothing to do with your Linux knowledge ;)

Rude-E
Posts: 2
Joined: Wed Feb 26, 2020 7:48 am

Re: Error occurred during initialization of VM

Post by Rude-E » Thu Feb 27, 2020 5:58 am

Nadahar wrote:
Wed Feb 26, 2020 11:03 am
The 9.3.0 release is broken for Linux, this has nothing to do with your Linux knowledge ;)
That explains a lot. Got 9.2.0 working like a charm. Thanks!

Post Reply