UMS 7.1.0 won't launch in High Sierra

For help and support with Mac OS X-specific issues
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
M4v3rick2
Posts: 1
Joined: Fri Jul 13, 2018 1:09 am

UMS 7.1.0 won't launch in High Sierra

Post by M4v3rick2 » Fri Jul 13, 2018 2:10 am

Installed latest version of UMS 7.1.0 when launching I get an error message that the app is damaged and to move it to the trash. However if I Control-click on the app icon and press Show Package Contents I can access the UMS (exec) and double-clicking that will launch the app. So can something be done to ensure that double- clicking the apps icon will launch the app rather than the workaround I have discovered. This was also a problem with version 7.0.1 and never addressed.

Nadahar
Posts: 1414
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS 7.1.0 won't launch in High Sierra

Post by Nadahar » Fri Jul 13, 2018 8:56 am

This sounds like one of Apple's "tricks" to force developers to pay them to rent a signature from them. Since UMS is a free project, there are no money to give to Apple. I suspect that they plan to make it impossible to install anything not in the "App Store" in the future, which will simply mean that UMS will no longer be available on macOS.

This is completely out of our hands, and any complaints should go to Apple. I strongly suspect that the only "opinion" Apple will listen to is if people stop buying their products though.

baja2k9
Posts: 1
Joined: Thu Aug 16, 2018 2:27 pm

Re: UMS 7.1.0 won't launch in High Sierra

Post by baja2k9 » Thu Aug 16, 2018 2:33 pm

I have the same problem, but I'm, able run it manually from a terminal:

cd /Volumes/ums-7.2.1-distribution/Universal\ Media\ Server.app/Contents/MacOS/
./UMS &

it display a lot of debugging info, but it works since several older versions

INFO 21:26:09.423 [main] Starting Universal Media Server 7.2.1
INFO 21:26:09.423 [main] Based on PS3 Media Server by shagrath, copyright 2008-2014
INFO 21:26:09.423 [main] http://www.universalmediaserver.com
INFO 21:26:09.423 [main]
INFO 21:26:09.423 [main] Build: 1195c7a29 (2018-07-29)
INFO 21:26:09.423 [main] Java: Java HotSpot(TM) 64-Bit Server VM 1.8.0_121 (64-bit) by Oracle Corporation
INFO 21:26:09.424 [main] OS: Mac OS X 64-bit 10.13.6
INFO 21:26:09.427 [main] Maximum JVM Memory: 1.1 GiB
INFO 21:26:09.432 [main] Language: English (United States)
INFO 21:26:09.432 [main] Encoding: UTF-8
INFO 21:26:09.432 [main]
INFO 21:26:09.540 [main] Working directory: /Volumes/ums-7.2.1-distribution/Universal Media Server.app/Contents/Resource

PhillyGuy
Posts: 1
Joined: Tue Jun 18, 2019 2:45 pm

Re: UMS 7.1.0 won't launch in High Sierra

Post by PhillyGuy » Tue Jun 18, 2019 2:52 pm

I just ran into this also. Was running an old..ok ancient version of UMS. Downloaded the latest one and hit this message. Even Open Package Contents, MACOS folder, terminal program did nothing.
I'm on Sierra...and I know they locked down the 3rd party apps a notch, the "Sys Pref" > Security feature of downloading "anything" is gone (annoying)


Anyway, a quick YouTube search, THIS fixed the problem.
https://www.youtube.com/watch?v=6fqzb4qpgcs

I tend to get slightly intimidated with anything using Terminal, but this was literally a 15 second fix.
Simple code using Terminal - copy & paste which is provided - follow the brief instructions in the video.

I have the 8.1.0 working right now on Sierra.

Nadahar
Posts: 1414
Joined: Tue Jun 09, 2015 5:57 pm

Re: UMS 7.1.0 won't launch in High Sierra

Post by Nadahar » Tue Sep 03, 2019 12:52 am

It seems like the spambots prefer to talk to eachother..? Maybe they "understand" each other better :D

User avatar
mik_s
Moderator
Posts: 53
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: UMS 7.1.0 won't launch in High Sierra

Post by mik_s » Tue Sep 03, 2019 1:00 am

Nadahar wrote:
Tue Sep 03, 2019 12:52 am
It seems like the spambots prefer to talk to eachother..? Maybe they "understand" each other better :D
I thought i got them all from this board, must have missed one :lol:

Post Reply