TSMuxer fails to start

For help and support with Universal Media Server
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
DetectiveKenobi
Posts: 12
Joined: Thu May 06, 2021 6:42 pm

Re: TSMuxer fails to start

Post by DetectiveKenobi »

That's great news. Hopefully it all gets sorted out soon. I have a TCL tv and it seems it ONLY likes playing content thru TSMuxer thru it's media player app when using UMS for some reason. I had to download a different app. So glad I can go back to UMS when all of this is sorted out.
User avatar
SubJunk
Lead Developer
Posts: 3485
Joined: Sun May 27, 2012 4:12 pm

Re: TSMuxer fails to start

Post by SubJunk »

If you want to be able to use tsMuxeR sooner, I think you can just install those dependencies yourself, like:

Code: Select all

brew install freetype
brew install zlib
then it should work
DetectiveKenobi
Posts: 12
Joined: Thu May 06, 2021 6:42 pm

Re: TSMuxer fails to start

Post by DetectiveKenobi »

I installed the new version but I'm still getting that tsmuxer fails to start. Is there something I should do? I already removed it and deleted the app just in case and then reinstalled it but it still does that.
Edit: I'm getting this error.
"Transcoding engine tsMuxeR Video is not available because it failed with exit code 126."

Edit: I upgraded my OS as I'm on Big Sur 11.5.2
ums_dbg_2021-09-06-10-57.zip
(27.2 KiB) Downloaded 4 times
User avatar
SubJunk
Lead Developer
Posts: 3485
Joined: Sun May 27, 2012 4:12 pm

Re: TSMuxer fails to start

Post by SubJunk »

It looks like a permission problem this time, I think I know what went wrong, I'll make you a test build
DetectiveKenobi
Posts: 12
Joined: Thu May 06, 2021 6:42 pm

Re: TSMuxer fails to start

Post by DetectiveKenobi »

Installed over the current install and still gives that error 126 and fails to start. Gonna try to remove the app and reinstall and see if that helps.
DetectiveKenobi
Posts: 12
Joined: Thu May 06, 2021 6:42 pm

Re: TSMuxer fails to start

Post by DetectiveKenobi »

Here's the logs from the newer version you posted.
ums_dbg_2021-09-13-00-35.zip
(27.26 KiB) Downloaded 6 times
User avatar
SubJunk
Lead Developer
Posts: 3485
Joined: Sun May 27, 2012 4:12 pm

Re: TSMuxer fails to start

Post by SubJunk »

Are you able to try the latest tsMuxeR build directly? https://github.com/justdan96/tsMuxer/releases
DetectiveKenobi
Posts: 12
Joined: Thu May 06, 2021 6:42 pm

Re: TSMuxer fails to start

Post by DetectiveKenobi »

Would I just copy that or run it? I have no knowledge of using TSmuxer directly thru mac. Only thru this program.
User avatar
SubJunk
Lead Developer
Posts: 3485
Joined: Sun May 27, 2012 4:12 pm

Re: TSMuxer fails to start

Post by SubJunk »

If you go into your Applications directory and right-click on UMS, and click "Show package contents", you should be able to find tsMuxeR and tsMuxeR-new in a Resources directory and replace it with any version. It's likely the "tsMuxeR-new" one you need to replace, so just rename the file you downloaded too
Post Reply