Version 7.4.0 released

Announcements about Universal Media Server
User avatar
SubJunk
Lead Developer
Posts: 2942
Joined: Sun May 27, 2012 4:12 pm

Re: Version 7.4.0 released

Post by SubJunk » Thu Sep 27, 2018 10:50 am

Glad that is working for you Gaston, sorry for the confusion. We are trying to avoid sharing the whole computer by default, but that is a change for our users who liked that :)

Also just an update for the people experiencing the false-positive from Windows Defender. I have scanned with the latest definitions and it is coming up clean, but I have also opened a ticket with Microsoft about it so they will hopefully be aware of it. Thanks to all who have reported it.

User avatar
SubJunk
Lead Developer
Posts: 2942
Joined: Sun May 27, 2012 4:12 pm

Re: Version 7.4.0 released

Post by SubJunk » Sat Sep 29, 2018 2:45 pm

Microsoft said they fixed the detection. This was their message:
Thank you for your inquiry.

We have reviewed the file and we have removed the detection.

Please try the following steps to clear cached detections and obtain the latest malware definitions.

1. Open command prompt as administrator and change directory to c:\Program Files\Windows Defender
2. Run “MpCmdRun.exe -removedefinitions -dynamicsignatures”

The latest definition is available for download here: https://www.microsoft.com/en-us/wdsi/definitions

Best regards,
Windows Defender Response

turbo78
Posts: 13
Joined: Wed Sep 11, 2013 5:30 am

Re: Version 7.4.0 released

Post by turbo78 » Tue Oct 02, 2018 5:56 am

I use Win10 64bit, and have tried 7.4 standalone.

Before this version I use the version that was not "stand alone".

Now I have a problem, that java process is eating up all the available memory.

I start the program, everything looks OK, I found the server on my TV, play something ok... exit the playing option, watch some TV, and when I go back to the server, when it have to view the contents of a drive I get an error that the TV can not connect to server.

When I look on my PC everything looks ok, but when I go into the task manager it shows that I have no RAM lesft and everything is eaten up by java. I have to end task, it automatically closes the also the UMS.

Then I restart the UMS and everything is working only for a one time play.

Any suggestion? Do you need some log files?

User avatar
SubJunk
Lead Developer
Posts: 2942
Joined: Sun May 27, 2012 4:12 pm

Re: Version 7.4.0 released

Post by SubJunk » Tue Oct 02, 2018 10:19 am

Yes please post logs in the support section

N3phastus
Posts: 21
Joined: Thu Jul 17, 2014 1:20 am

Re: Version 7.4.0 released

Post by N3phastus » Tue Oct 02, 2018 8:43 pm

turbo78 wrote:
Tue Oct 02, 2018 5:56 am
I use Win10 64bit, and have tried 7.4 standalone.

Before this version, I use the version that was not "stand alone".

Now I have a problem, that java process is eating up all the available memory.

I start the program, everything looks OK, I found the server on my TV, play something ok... exit the playing option, watch some TV, and when I go back to the server, when it have to view the contents of a drive I get an error that the TV can not connect to server.

When I look on my PC everything looks ok, but when I go into the task manager it shows that I have no RAM lesft and everything is eaten up by java. I have to end task, it automatically closes the also the UMS.

Then I restart the UMS and everything is working only for a one time play.

Any suggestion? Do you need some log files?
This is happening in all "7" versions , after a couple of hours eats all memory and worse eats your CPU to 100%, that is very serious and can damage your PC !
I'm trying every new versions, but only 6.8 still working solid, it has this issue but it does not happen every day, maybe once a week...

Waiting SubJunk to really look at it :(

cheers

User avatar
SubJunk
Lead Developer
Posts: 2942
Joined: Sun May 27, 2012 4:12 pm

Re: Version 7.4.0 released

Post by SubJunk » Tue Oct 02, 2018 8:52 pm

I wasn't aware of the issue. You said 6.8 has the issue but less often, is there a version that doesn't have the issue at all?

dl0gic
Posts: 1
Joined: Wed Oct 10, 2018 2:54 pm

Re: Version 7.4.0 released

Post by dl0gic » Wed Oct 10, 2018 3:10 pm

Hello,

I hope you all are doing well.
I am running the following:

21:49:16 INFO Build: ebd15aac6 (2018-09-22)
21:49:16 INFO Java: OpenJDK 64-Bit Server VM 1.8.0_181 (64-bit) by Oracle Corporation
21:49:16 INFO OS: Linux 64-bit 4.15.0-36-generic
21:49:16 INFO Maximum JVM Memory: 683 MiB
21:49:16 INFO Language: English (United States)
21:49:16 INFO Encoding: UTF-8

My resolution is at 3840x2160

The GUI is really tiny and hard to read. I have provided a Google Drive link to a screen shot. This is unrelated to this particular version, I have just neglected to mention it until now :-)

https://drive.google.com/file/d/14jsapR ... sp=sharing

User avatar
SubJunk
Lead Developer
Posts: 2942
Joined: Sun May 27, 2012 4:12 pm

Re: Version 7.4.0 released

Post by SubJunk » Wed Oct 10, 2018 7:56 pm

Hmm maybe we should scale it more for that resolution.. We already do that with retina screens but that is a little different.

Post Reply