Versions 7.8.0 and 8.0.0-b1 released

Announcements about Universal Media Server
User avatar
SubJunk
Lead Developer
Posts: 2915
Joined: Sun May 27, 2012 4:12 pm

Versions 7.8.0 and 8.0.0-b1 released

Post by SubJunk » Sat Jan 12, 2019 2:42 pm

General:

We have added a subtitle translator to the web interface and squashed a lot of bugs. Special thanks to the 5 contributing developers in this release, and the language translators on Crowdin. Our community is really thriving!

Version 8 is starting to really mature so we have bumped it from alpha to beta. Please continue to report any bugs you find with it so we can get the stable release out soon.


Download 7.8.0:

From the front page.

Download 8.0.0 BETA 1:

Windows
macOS
Linux

8.0.0-b1 changes since 8.0.0-a2
  • General:
    • Added option to disable FFmpeg GPU acceleration
    • Fixed too much transcoding due to not respecting language priority settings
    • Fixed failure to store audio stream information
    • Fixed failure to start
    • Fixed missing text when adding web content
    • Fixed missing text on the first time language chooser
    • Fixed text clash on the Subtitles settings subtab of the Transcoding settings tab
    • Fixed logspam
    • All changes in 7.8.0
7.8.0 changes since 7.7.1
  • General:
    • Added examples for all binary tools paths in UMS.conf (thanks, Amadeus-!)
    • Added detection of JDK to the Windows installer (thanks, siboXD!)
    • Fixed custom option parsing for ffmpeg_gpu_decoding_acceleration_method (thanks, goncalossilva!)
    • Fixed error when FFmpeg deferred to MEncoder
  • Web interface:
    • Added Subtitle Translator to the menu (thanks, atamariya!)
    • Added new home screen with automatic entry (thanks, Abel Espinosa!)
    • Added player navigation using keys to return to home screen (thanks, Abel Espinosa!)
    • Added new logo icon fully displayed and transparent in web interface browse view (thanks, Abel Espinosa!)
    • Made caption, folder list and play toolbar buttons compliant with material design (thanks, Abel Espinosa!)
    • Fixed audio thumbnails (thanks, Abel Espinosa!)
    • Fixed some buttons not displaying correctly (thanks, Abel Espinosa!)
    • Fixed broken hover effect on Firefox (thanks, Abel Espinosa!)
    • Modified menu icons
  • Languages:
    • Updated translations via Crowdin:
      • French translation updated
      • Icelandic translation updated
      • Japanese translation updated
      • Ukranian translation updated

Compatibility notes:

These releases work on Java 7, 8, and 10+
We recommend using Java 8, and if you do not want to have Java installed, you can use the standalone installers on Windows.
The Windows releases work on Windows Vista onwards.

User avatar
pipin
Posts: 76
Joined: Fri Dec 28, 2012 12:17 am

Re: Versions 7.8.0 and 8.0.0-b1 released

Post by pipin » Sat Jan 12, 2019 9:20 pm

Thanks.

I noticed Installation needed more time to start (20s). Is it because of "Added detection of JDK to the Windows installer" ?
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600

erick diangilis
Posts: 161
Joined: Sun May 22, 2016 8:25 am

Re: Versions 7.8.0 and 8.0.0-b1 released

Post by erick diangilis » Sat Jan 12, 2019 10:56 pm

good way to start the year with new versions thanks subjunk for the releases i'll test the 8.0.0 b1 since i'm using 8.00 alfa on the ps4 pro media player :)

thanks again and keep up with the nice work god bless. :D

boss
Posts: 201
Joined: Thu Jun 30, 2016 1:07 pm

Re: Versions 7.8.0 and 8.0.0-b1 released

Post by boss » Sun Jan 13, 2019 1:20 am

On Gentoo Linux Headless
V8.0.0 b1 has resolved the issue which was in V8.0.0-a2 and reported here:
https://www.universalmediaserver.com/fo ... 10&t=13295

V7.8.0 seems to be working OK on renderers.

Both V7.8.0 and V8.0.0-a2 have the following issue for me in IE11.
IE11 is not HTML5 friendly and previously one could click on the "Flash" button to play. This now does not work.
HTML5 is working in other browsers (Firefox, Opera & Chrome)

EDIT: Flash is now working after rebooting the PC.

boss
Posts: 201
Joined: Thu Jun 30, 2016 1:07 pm

Re: Versions 7.8.0 and 8.0.0-b1 released

Post by boss » Sun Jan 13, 2019 9:46 pm

On Gentoo Linux Headless
I have found that there is a problem with the fast forward controls.
3 arrows fast forward and then push the play button and the movie freezes for some time and then starts.
4 arrows fast forward and the movie freezes totally and needs to be restarted,
Fast rewind does not work at all.

I tested previous versions and the problem was the same starting at V7.7.1. I didn't have V7.7.0 on my server to test so not sure if it is a problem in V7.7.0.
My guess is that it probably would be and the issue is because of something implemented in V7.

I have reverted back to V7.6.2 and the fast forward and fast rewind work fine.

Paradox
Posts: 140
Joined: Tue Dec 17, 2013 5:50 am

Re: Versions 7.8.0 and 8.0.0-b1 released

Post by Paradox » Tue Jan 15, 2019 1:32 pm

BraviaEX.conf file still broken, does not implement FFMPEG fix needed as outlined in this thread and the last few posts and confirmed by myself and at least 2 other users...
https://www.universalmediaserver.com/fo ... 734#p38734
I dunno why i bother anymore :(

erick diangilis
Posts: 161
Joined: Sun May 22, 2016 8:25 am

Re: Versions 7.8.0 and 8.0.0-b1 released

Post by erick diangilis » Mon Jan 21, 2019 1:22 am

i have finished testing the 8 b1 its working ok so far no bugs until now even the persistent pause and playing vídeos on the ps4 media player is gone. :D


can't wait for the final version to be released keep up with the nice work and god bless.

turboguard
Posts: 3
Joined: Sun Nov 25, 2018 12:07 pm

Re: Versions 7.8.0 and 8.0.0-b1 released

Post by turboguard » Fri Jan 25, 2019 8:42 am

erick diangilis wrote:
Mon Jan 21, 2019 1:22 am
i have finished testing the 8 b1 its working ok so far no bugs until now even the persistent pause and playing vídeos on the ps4 media player is gone. :D


can't wait for the final version to be released keep up with the nice work and god bless.
I'm still getting problems playing on my PS4 Pro.
I have to attempt to play a file about 3 times before it actually plays, and it will still "fail to play" if I leave it paused for a bit and try to resume.
I'm about ready to give up hope...

erick diangilis
Posts: 161
Joined: Sun May 22, 2016 8:25 am

Re: Versions 7.8.0 and 8.0.0-b1 released

Post by erick diangilis » Sat Jan 26, 2019 7:20 am

that's interesting cause i had this issue until the last 8 alpha 2 but now its completely vanished and some vídeos that i had to use transcoding they're working now. i have no idea on what just happend maybe i just got Lucky or there is something to do with my ps4 pro model or any configurations on the network or on the console or with my modem or something else entirely or maybe a combination of lots of thing together. i've been watching a few series and movies lately but i had no issues with pausing or anything else for a beta i consider this a miracle.

erick diangilis
Posts: 161
Joined: Sun May 22, 2016 8:25 am

Re: Versions 7.8.0 and 8.0.0-b1 released

Post by erick diangilis » Sun Feb 03, 2019 7:49 am

last week the ps4 media player has been updated to 4.01 with performance improvement in the description to just keep you posted :)

Post Reply