Version 3.1.0 is released

Announcements about Universal Media Server
Auka
Posts: 3
Joined: Sat May 18, 2013 7:54 am

Re: Version 3.1.0 is released

Post by Auka » Wed Nov 20, 2013 6:33 am

Updated from 3.0 to 3.1 and the subtitle wouldn't load on default anymore, even after using the Clean Install option. Everything is set up in the same manner as 3.0 but the subtitle will only load if I play the file manually in the transcode folder. Problem is resolved by reverting to 3.0 thought. ;).

b0ris
Posts: 17
Joined: Sun Oct 27, 2013 5:40 pm

Re: Version 3.1.0 is released

Post by b0ris » Wed Nov 20, 2013 7:56 am

Same problem after install of Channels 2.22 after a completely clean install of UMS (and no actual channels installed):

Code: Select all

11-19 20:17:11  Starting Universal Media Server 3.1.0
11-19 20:17:11  Based on PS3 Media Server by shagrath, copyright 2008-2013
11-19 20:17:11  http://www.universalmediaserver.com
11-19 20:17:11  
11-19 20:17:11  Build: 74263860d (2013-11-18)
11-19 20:17:11  Java: Java HotSpot(TM) 64-Bit Server VM 1.7.0_45 64-bit by Oracle Corporation
11-19 20:17:11  OS: Windows 7 64-bit 6.1
11-19 20:17:11  Encoding: UTF-8
11-19 20:17:11  Memory: 1138 MB
11-19 20:17:11  Language: sv
11-19 20:17:11  
11-19 20:17:11  Working directory: C:\Program Files (x86)\Universal Media Server
11-19 20:17:11  Temp directory: C:\Users\Tobias\AppData\Local\Temp\universalmediaserver
11-19 20:17:11  Logging config file: C:\Program Files (x86)\Universal Media Server\logback.xml
11-19 20:17:11  debug.log: C:\ProgramData\UMS\debug.log
11-19 20:17:11  
11-19 20:17:11  Profile directory: C:\ProgramData\UMS
11-19 20:17:11  Profile directory permissions: rw
11-19 20:17:11  Profile path: C:\ProgramData\UMS\UMS.conf
11-19 20:17:11  Profile permissions: rw
11-19 20:17:11  Profile name: Tobias-Dator
11-19 20:17:11  
11-19 20:17:11  Web conf path: C:\ProgramData\UMS\WEB.conf
11-19 20:17:11  Web conf permissions: rw
11-19 20:17:11  
11-19 20:17:11  Checking shared folder: C:\Users\Tobias\Downloads
11-19 20:17:11  Checking shared folder: E:\TV
11-19 20:17:11  Loading MediaInfo library
11-19 20:17:11  Loaded MediaInfoLib - v0.7.64
11-19 20:17:11  Loading renderer configurations from C:\Program Files (x86)\Universal Media Server\renderers
11-19 20:17:11  Loaded configuration for renderer: AirPlayer
11-19 20:17:11  Loaded configuration for renderer: Android
11-19 20:17:11  Loaded configuration for renderer: KalemSoft Media Player
11-19 20:17:11  Loaded configuration for renderer: Sony Bravia 4500
11-19 20:17:11  Loaded configuration for renderer: Sony Bravia 5500
11-19 20:17:11  Loaded configuration for renderer: Sony Bravia EX
11-19 20:17:11  Loaded configuration for renderer: Sony Bravia EX620
11-19 20:17:11  Loaded configuration for renderer: Sony Bravia HX
11-19 20:17:11  Loaded configuration for renderer: Sony Bravia W6/W8/W9
11-19 20:17:11  Loaded configuration for renderer: DirecTV HR
11-19 20:17:11  Loaded configuration for renderer: D-Link DSM-510
11-19 20:17:11  Loaded configuration for renderer: Freebox HD
11-19 20:17:11  Loaded configuration for renderer: Freecom MusicPal
11-19 20:17:11  Loaded configuration for renderer: iPad / iPhone
11-19 20:17:11  Loaded configuration for renderer: Pioneer Kuro
11-19 20:17:11  Loaded configuration for renderer: LG 42LA644V
11-19 20:17:11  Loaded configuration for renderer: LG Smart TV Upgrader
11-19 20:17:11  Loaded configuration for renderer: Nokia N900
11-19 20:17:11  Loaded configuration for renderer: Netgear NeoTV
11-19 20:17:11  Loaded configuration for renderer: Onkyo TX-NR717
11-19 20:17:11  Loaded configuration for renderer: OPPO BDP-83
11-19 20:17:11  Loaded configuration for renderer: OPPO BDP-93
11-19 20:17:11  Loaded configuration for renderer: Panasonic TV
11-19 20:17:11  Loaded configuration for renderer: Panasonic TX-L32V10E
11-19 20:17:11  Loaded configuration for renderer: Philips Aurea
11-19 20:17:11  Loaded configuration for renderer: Philips TV
11-19 20:17:11  Loaded configuration for renderer: Popcorn Hour
11-19 20:17:11  Loaded configuration for renderer: PlayStation 3
11-19 20:17:11  Loaded configuration for renderer: Realtek
11-19 20:17:11  Loaded configuration for renderer: Samsung SMT-G7400
11-19 20:17:11  Loaded configuration for renderer: Samsung D7000
11-19 20:17:11  Loaded configuration for renderer: Samsung AllShare
11-19 20:17:11  Loaded configuration for renderer: Samsung Mobile
11-19 20:17:11  Loaded configuration for renderer: Samsung WiseLink
11-19 20:17:11  Loaded configuration for renderer: Sharp Aquos
11-19 20:17:11  Loaded configuration for renderer: Showtime 3
11-19 20:17:11  Loaded configuration for renderer: Showtime 4
11-19 20:17:11  Loaded configuration for renderer: Sony SMP-N100
11-19 20:17:11  Loaded configuration for renderer: Sony Blu-ray
11-19 20:17:11  Loaded configuration for renderer: Sony Home Theatre System
11-19 20:17:11  Loaded configuration for renderer: Sony STR-DA5800ES
11-19 20:17:11  Loaded configuration for renderer: Streamium
11-19 20:17:11  Loaded configuration for renderer: Telstra T-Box
11-19 20:17:11  Loaded configuration for renderer: VideoWeb TV
11-19 20:17:11  Loaded configuration for renderer: Vizio Smart TV
11-19 20:17:11  Loaded configuration for renderer: WD TV Live
11-19 20:17:11  Loaded configuration for renderer: WMP
11-19 20:17:11  Loaded configuration for renderer: XBMC
11-19 20:17:11  Loaded configuration for renderer: Xbox 360
11-19 20:17:11  Loaded configuration for renderer: Yamaha RX-A1010
11-19 20:17:11  Loaded configuration for renderer: Yamaha RX-V3900
11-19 20:17:11  Loaded configuration for renderer: Yamaha RX-V671
11-19 20:17:11  Please wait while we check the MPlayer font cache, this can take a minute or so.
11-19 20:17:11  Finished checking the MPlayer font cache.
11-19 20:17:11  VSFilter / DirectVobSub was not found. This can cause problems when trying to play subtitled videos with AviSynth.
11-19 20:17:11  Found VLC version 2.1.0 at: C:\Program Files (x86)\VideoLAN\VLC\vlc.exe
11-19 20:17:11  Searching for plugins in C:\Program Files (x86)\Universal Media Server\plugins
11-19 20:17:11  Found plugin: com.chocolatey.pmsencoder.Plugin
11-19 20:17:11  Found plugin: com.sharkhunter.channel.CH_plugin
11-19 20:17:11  PMSEncoder: initializing PMSEncoder 2.0.0-rc1
11-19 20:17:11  PMSEncoder: log directory: C:\ProgramData\UMS
11-19 20:17:11  PMSEncoder: loading built-in log4j config file: jar:file:/C:/Program%20Files%20(x86)/Universal%20Media%20Server/plugins/pmsencoder-2.0.0-rc1.jar!/log4j_default.xml
11-19 20:17:13  Exception in thread "main" java.lang.VerifyError: (class: com/chocolatey/pmsencoder/PMSEncoder, method: super$4$getAudioBitrateOptions signature: (Lnet/pms/dlna/DLNAResource;Lnet/pms/dlna/DLNAMediaInfo;Lnet/pms/io/OutputParams;)Ljava/util/List;) Illegal use of nonvirtual function call
11-19 20:17:13  	at com.chocolatey.pmsencoder.Plugin.<init>(Plugin.groovy:163)
11-19 20:17:13  	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
11-19 20:17:13  	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
11-19 20:17:13  	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
11-19 20:17:13  	at java.lang.reflect.Constructor.newInstance(Unknown Source)
11-19 20:17:13  	at java.lang.Class.newInstance(Unknown Source)
11-19 20:17:13  	at net.pms.external.ExternalFactory.instantiateEarlyListeners(ExternalFactory.java:418)
11-19 20:17:13  	at net.pms.external.ExternalFactory.lookup(ExternalFactory.java:398)
11-19 20:17:13  	at net.pms.PMS.init(PMS.java:685)
11-19 20:17:13  	at net.pms.PMS.createInstance(PMS.java:1075)
11-19 20:17:13  	at net.pms.PMS.main(PMS.java:1171)
Last edited by b0ris on Thu Nov 21, 2013 4:28 am, edited 2 times in total.

Madoka
Posts: 328
Joined: Fri Jun 01, 2012 12:51 pm

Re: Version 3.1.0 is released

Post by Madoka » Wed Nov 20, 2013 2:28 pm

Auka wrote:Updated from 3.0 to 3.1 and the subtitle wouldn't load on default anymore, even after using the Clean Install option. Everything is set up in the same manner as 3.0 but the subtitle will only load if I play the file manually in the transcode folder. Problem is resolved by reverting to 3.0 thought. ;).
I have the same problem. I have show Engine enabled. So, I usually see Filename [Mencoder] {Subs}, but now I only see Filename {Subs} as if the subtitle transcoding logic changed. It just streams the file over without transcoding the subs in, empty buffer and native codecs shown on the PS3. It's not SB53 as it works fine in 3.0.0. Clean install will not solve the problem. I reverted back to 3.0.0 + SB53, and it works perfectly.

Lorentzen1337
Posts: 1
Joined: Thu Nov 21, 2013 4:59 am

Re: Version 3.1.0 is released

Post by Lorentzen1337 » Thu Nov 21, 2013 5:01 am

Auka wrote:Updated from 3.0 to 3.1 and the subtitle wouldn't load on default anymore, even after using the Clean Install option. Everything is set up in the same manner as 3.0 but the subtitle will only load if I play the file manually in the transcode folder. Problem is resolved by reverting to 3.0 thought. ;).
This happens to me also!

User avatar
SubJunk
Lead Developer
Posts: 2942
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.1.0 is released

Post by SubJunk » Fri Nov 22, 2013 5:40 pm

I've reproduced the subtitle problem, expect 3.1.1 soon to fix it :)

Madoka
Posts: 328
Joined: Fri Jun 01, 2012 12:51 pm

Re: Version 3.1.0 is released

Post by Madoka » Fri Nov 22, 2013 6:09 pm

Thanks, SJ!! Looking forward to it.

Auka
Posts: 3
Joined: Sat May 18, 2013 7:54 am

Re: Version 3.1.0 is released

Post by Auka » Sat Nov 23, 2013 5:08 am

Thanks a bunch!

Post Reply