Page 1 of 2

Version 9.6.1 released

Posted: Sun Jun 14, 2020 8:20 am
by SubJunk
General:

This release improves file support, fixes bugs related to subtitles, improves performance, and more!

We are busy preparing our next beta which improves and extends our metadata, allowing for things like recommendations, genres, ratings from major sources, etc. as well as remote access.

Download:

Windows, macOS and Linux: Our front page or our official mirrors
Docker: docker pull universalmediaserver/ums

Changes since 9.5.0
  • General:
    • Improved compatibility of files containing both supported and unsupported streams
    • Improved support for MP4 and OGA/OGG audio on the web interface
    • Fixed automatic updating on Windows and macOS
    • Fixed renderer control windows not refocusing on Windows when renderer image was clicked
    • Fixed support for external subtitles when using the se syntax in renderer config
    • Fixed not transcoding embedded subtitles when we should
  • Renderers:
    • Updated support for external subtitles on VLC for iOS (thanks, JuanPZ!)
    • Updated support for external subtitles on Panasonic VT60
  • Translation updates via Crowdin:
    • English (British) (5%)
    • Macedonian (0%)
  • Dependency updates:
    • commons-io from 2.6 to 2.7
    • exec-maven-plugin from 1.6.0 to 3.0.0
    • JRE from 8 to 14.0.1
    • maven-project-info-reports-plugin from 3.0.0 to 3.1.0
    • metadata-extractor from 2.13.0 to 2.14.0
    • netty from 3.10.6 to 4.1.50
    • oshi-core from 5.1.0 to 5.1.2
    • rome from 1.12.2 to 1.13.1
Notes:
  • Windows has limited support from XP onwards, but full support is for Windows 7 onwards
  • macOS 10.10+ is fully supported
  • This announcement is for 9.6.0 as well, since we quickly fixed a bug in that with 9.6.1, thanks to Arceliar for reporting it

Re: Version 9.6.1 released

Posted: Sun Jun 14, 2020 5:01 pm
by mik_s
not working for me, couldn't post log on this thread so made a new one
https://www.universalmediaserver.com/fo ... =9&t=14213

Re: Version 9.6.1 released

Posted: Sun Jun 14, 2020 6:58 pm
by pipin
Thanks for the release. Video playing is working for me, but there seems to be a mayor glitch.


when I choose ums as a source at the tv with video, photo or music the content of the first shared folder is shown and I cant navigate one up.

If i choose "all files" everything is working fine with all shared folders shown.

Re: Version 9.6.1 released

Posted: Sun Jun 14, 2020 9:18 pm
by SubJunk
pipin wrote:
Sun Jun 14, 2020 6:58 pm
Thanks for the release. Video playing is working for me, but there seems to be a mayor glitch.


when I choose ums as a source at the tv with video, photo or music the content of the first shared folder is shown and I cant navigate one up.

If i choose "all files" everything is working fine with all shared folders shown.
I don't understand, can you take photos of what you mean? I don't know how your TV displays what we give it, there is huge variation between devices

Re: Version 9.6.1 released

Posted: Sun Jun 14, 2020 10:40 pm
by pipin
SubJunk wrote:
Sun Jun 14, 2020 9:18 pm
pipin wrote:
Sun Jun 14, 2020 6:58 pm
Thanks for the release. Video playing is working for me, but there seems to be a mayor glitch.


when I choose ums as a source at the tv with video, photo or music the content of the first shared folder is shown and I cant navigate one up.

If i choose "all files" everything is working fine with all shared folders shown.
I don't understand, can you take photos of what you mean? I don't know how your TV displays what we give it, there is huge variation between devices
It could be a samsung related issue:

Screenshot of the tv:
https://ibb.co/N6RWm8Y

selecting all works as usual, all other selections show the message "no files found on the connected device" until you select all.

After selecting "all", files are found with the other selections but only for the folder which is the first on the shared content list.

Re: Version 9.6.1 released

Posted: Mon Jun 15, 2020 1:53 am
by JuanPZ
Hi,

I just want to note that you missed the VLC-for-desktop.conf which was actually the file that I mentioned in my post.

Re: Version 9.6.1 released

Posted: Mon Jun 15, 2020 6:37 am
by sake
I updated from 9.5.0 to 9.6.1 and now in every folder I used to see my video files I get: Selected server contains no media content. Please, select another server. :roll:

Re: Version 9.6.1 released

Posted: Mon Jun 15, 2020 8:49 am
by knicknak
Something is wrong with the auto-update, yesterday I was watching something and got a 2006 error, went to my pc to see what the error was and a pop-up was displayed prompting me to update to 9.6.0 - seems like this shouldn't interrupt playback (bug 1).
9.6.0 didn't have any release notes - seems like i shouldn't have been auto-updated to it (bug 2).
I never got an auto-update to 9.6.1 (bug 3)
If I hit "check for updates", it says no updates available. It doesn't find 9.6.1 (bug 4)

Seems like this feature is pretty broken.

PS: Just tried restarting UMS and it now prompts me to auto-update to 9.6.1 - but autoupdate shouldn't need a restart, and "check for updates" shouldn't need a restart.

Re: Version 9.6.1 released

Posted: Mon Jun 15, 2020 5:09 pm
by SubJunk
Pipin and sake, can you please see if this fixes your browsing problems? https://www.universalmediaserver.com/up ... -netty.exe

Re: Version 9.6.1 released

Posted: Mon Jun 15, 2020 7:28 pm
by pipin
SubJunk wrote:
Mon Jun 15, 2020 5:09 pm
Pipin and sake, can you please see if this fixes your browsing problems? https://www.universalmediaserver.com/up ... -netty.exe
Yes, this fixes the problem.

And something positive: with 9.6.1 subtitles which are added later are now played without restarting ums!!! *happy* :D