Version 3.4.0 is released

Announcements about Universal Media Server
SergioBigRed
Posts: 25
Joined: Fri Jun 08, 2012 9:40 am

Re: Version 3.4.0 is released

Post by SergioBigRed » Wed Feb 12, 2014 8:53 am

awschmidt wrote:thanks for the new release, but UMS 3.4.0 can't work with movieinfo anymore.
Error:
02-06 20:07:47 Exception in thread "main" java.lang.NoSuchFieldError: EMPTY_BORDER
02-06 20:07:47 at net.pms.movieinfo.MovieInfo.config(MovieInfo.java:99)
02-06 20:07:47 at net.pms.newgui.PluginTab.appendPlugin(PluginTab.java:420)
02-06 20:07:47 at net.pms.newgui.PluginTab.addPlugins(PluginTab.java:413)
02-06 20:07:47 at net.pms.newgui.LooksFrame.serverReady(LooksFrame.java:568)
02-06 20:07:47 at net.pms.PMS.init(PMS.java:695)
02-06 20:07:47 at net.pms.PMS.createInstance(PMS.java:1018)
02-06 20:07:47 at net.pms.PMS.main(PMS.java:1114)
Same issue for me here, no showing on PS3.

Update from 3.3.0 maintaing the same config file (that I suspect I have since several upgrades...). I had to rollback to UMS 3.3.0 and all work fine.

Gareee
Posts: 71
Joined: Fri Jun 01, 2012 9:12 am

Re: Version 3.4.0 is released

Post by Gareee » Thu Feb 13, 2014 6:28 am

I rolled back to 3.3.0 as well. My stereo does have dts, but apparently I don't have it set up properly to decode it while streaming through the ps3, so I was getting static when I selected a dts file for playback.

3.3.0 did not have the new config setup option, so I did a clean install of 4.4.0 to change that dts setting back, added my nav folders, and then installed 3.3.0 over the top of that to get everything working properly again.

User avatar
SubJunk
Lead Developer
Posts: 2923
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.4.0 is released

Post by SubJunk » Thu Feb 13, 2014 12:29 pm

MovieInfo support is fixed in 3.4.1 which will be released soon (today or tomorrow hopefully)

spkbr
Posts: 8
Joined: Thu Dec 05, 2013 2:22 am

Re: Version 3.4.0 is released

Post by spkbr » Thu Feb 13, 2014 11:25 pm

SergioBigRed wrote:
awschmidt wrote:thanks for the new release, but UMS 3.4.0 can't work with movieinfo anymore.
Error:
02-06 20:07:47 Exception in thread "main" java.lang.NoSuchFieldError: EMPTY_BORDER
02-06 20:07:47 at net.pms.movieinfo.MovieInfo.config(MovieInfo.java:99)
02-06 20:07:47 at net.pms.newgui.PluginTab.appendPlugin(PluginTab.java:420)
02-06 20:07:47 at net.pms.newgui.PluginTab.addPlugins(PluginTab.java:413)
02-06 20:07:47 at net.pms.newgui.LooksFrame.serverReady(LooksFrame.java:568)
02-06 20:07:47 at net.pms.PMS.init(PMS.java:695)
02-06 20:07:47 at net.pms.PMS.createInstance(PMS.java:1018)
02-06 20:07:47 at net.pms.PMS.main(PMS.java:1114)
Same issue for me here, no showing on PS3.

Update from 3.3.0 maintaing the same config file (that I suspect I have since several upgrades...). I had to rollback to UMS 3.3.0 and all work fine.
The same thing happens for LastFMScrobbler plugin. Removing it and the problem is gone. Do you think 3.4.1 will fix it for that too?
02-13 09:23:21 Exception in thread "main" java.lang.NoSuchFieldError: EMPTY_BORDER
02-13 09:23:21 at net.pms.external.LastFMScrobbler.config(LastFMScrobbler.java:140)
02-13 09:23:21 at net.pms.newgui.PluginTab.appendPlugin(PluginTab.java:420)
02-13 09:23:21 at net.pms.newgui.PluginTab.addPlugins(PluginTab.java:413)
02-13 09:23:21 at net.pms.newgui.LooksFrame.serverReady(LooksFrame.java:568)
02-13 09:23:21 at net.pms.PMS.init(PMS.java:695)
02-13 09:23:21 at net.pms.PMS.createInstance(PMS.java:1018)
02-13 09:23:21 at net.pms.PMS.main(PMS.java:1114)
The font cache thing is just perfect now! Thanks a lot SubJunk for listening to our complaints. Great work!

User avatar
SubJunk
Lead Developer
Posts: 2923
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.4.0 is released

Post by SubJunk » Fri Feb 14, 2014 8:35 am

spkbr wrote:The same thing happens for LastFMScrobbler plugin. Removing it and the problem is gone. Do you think 3.4.1 will fix it for that too?
I just checked and yes it fixes that too :)
spkbr wrote:The font cache thing is just perfect now! Thanks a lot SubJunk for listening to our complaints. Great work!
Thanks :) The improvement was a team effort, thanks to skeptical and valib too :)

Gareee
Posts: 71
Joined: Fri Jun 01, 2012 9:12 am

Re: Version 3.4.0 is released

Post by Gareee » Fri Feb 14, 2014 9:56 am

I just got an email notification of a update to UMS.. but it looks like its still 3.4.0, not 3.4.1.

Odd.

spkbr
Posts: 8
Joined: Thu Dec 05, 2013 2:22 am

Re: Version 3.4.0 is released

Post by spkbr » Fri Feb 14, 2014 10:10 am

SubJunk wrote:
spkbr wrote:The font cache thing is just perfect now! Thanks a lot SubJunk for listening to our complaints. Great work!
Thanks :) The improvement was a team effort, thanks to skeptical and valib too :)
Then thank you SubJunk, skeptical and valib! :D :D

Monica Jae
Posts: 48
Joined: Mon Oct 21, 2013 6:11 pm

Re: Version 3.4.0 is released

Post by Monica Jae » Fri Feb 14, 2014 4:14 pm

rollin back to 330

Monica Jae
Posts: 48
Joined: Mon Oct 21, 2013 6:11 pm

Re: Version 3.4.0 is released

Post by Monica Jae » Fri Feb 14, 2014 4:16 pm

ok, where is it?

Monica Jae
Posts: 48
Joined: Mon Oct 21, 2013 6:11 pm

Re: Version 3.4.0 is released

Post by Monica Jae » Fri Feb 14, 2014 4:26 pm

so i see that 3.4.1 is released, yet that isn't reflected on the dl page. i'm at github now and cannot get a working install??.. i know it's source, so... a little help

Post Reply