Version 4.0.0-a1 is released

Announcements about Universal Media Server
User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Version 4.0.0-a1 is released

Post by SharkHunter » Mon Jun 09, 2014 11:15 pm

Change of default encoder was a hot/sensitive issue. Pls note the word default since it's implies that you can change it...
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

Paradox
Posts: 140
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 4.0.0-a1 is released

Post by Paradox » Mon Jun 09, 2014 11:19 pm

SharkHunter wrote:Change of default encoder was a hot/sensitive issue. Pls note the word default since it's implies that you can change it...
Yes i know, i can switch back to Mencoder quite easily, changing to FFmpeg as the default does not bother me in the slightest. The point i was making is that if Mencoder is eventually entirely abandoned which i gather is the goal eventually, then a fix needs to be implemented for certain Sony, Panasonic and probably other devices which have aspect ratio issues. Mencoder had a well documented fix already as i mentioned. FFmpeg until this thread and Valibs superb solution did not.

User avatar
valib
Developer
Posts: 653
Joined: Fri Feb 08, 2013 3:11 am

Re: Version 4.0.0-a1 is released

Post by valib » Mon Jun 09, 2014 11:59 pm

SubJunk we should test this pull request https://github.com/UniversalMediaServer ... r/pull/329

Paradox
Posts: 140
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 4.0.0-a1 is released

Post by Paradox » Tue Jun 10, 2014 2:26 am

While you have got your coding groove on valib :) Even though Mencoder may be scrapped at some point (or i assume that is the long term and reasonable goal) is there any way you can also tweak things see when

Code: Select all

CustomMencoderOptions =-vf softskip,expand=::::1:16/9:2,scale=1283:720 -lavcopts aspect=16/9
is set in the renderer.conf files it obeys the setting for web videos (ie contents of web.conf file).

It appears for a while for some reason that command line and i think any other 'CustomMencoderOptions' you place in a renderer.conf file are totally ignored when playing web video. It only implements the commands for local stored content. No idea why but i think that is another issue that popped up around version 2.5 (ish) and later.

Im assuming though i do not know much about this stuff its something in the source to do with either MEncoderVideo.java or MEncoderWebVideo.java.

Loving your OverrideVideoFilter command thus far for FFmpeg though, it works for local content and web content. Hope if that gets tested more and built in if it works for all devices.

Great work valib

User avatar
valib
Developer
Posts: 653
Joined: Fri Feb 08, 2013 3:11 am

Re: Version 4.0.0-a1 is released

Post by valib » Tue Jun 10, 2014 8:31 am

For the MEncoderWebVideo the 'CustomMencoderOptions' was never implemented. It is done only in the FFmpegWebVideo.

xxx2
Posts: 3
Joined: Tue Jul 16, 2013 7:53 am

Re: Version 4.0.0-a1 is released

Post by xxx2 » Tue Jun 10, 2014 11:23 am

Wii U browser don't open any media at this moment (Unsupported video format. Try install Adobe Flash). I have hope that will change in future ;) Good job guys! I'm looking forward to the next release!

Paradox
Posts: 140
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 4.0.0-a1 is released

Post by Paradox » Tue Jun 10, 2014 1:51 pm

valib wrote:For the MEncoderWebVideo the 'CustomMencoderOptions' was never implemented. It is done only in the FFmpegWebVideo.
Hmm looked into it a little more i may have been confused between Mencoder and PMSEncoder plugin on older versions of UMS and which video engine i was using in older versions of UMS for web content DOH! :oops:

Valib if you want to do a test build package with your fix included im happy to test though i assume you have tried and found it to work with your Panasonic TV already.
xxx2 wrote:Wii U browser don't open any media at this moment (Unsupported video format. Try install Adobe Flash). I have hope that will change in future ;) Good job guys! I'm looking forward to the next release!
Ive not tried the web interface in detail but a few thoughts. The Wii U does not support Adobe flash AFAIK only HTML5 so that could be the problem there.
Its DLNA web interface i believe also only handles .MP4 files. So if UMS is trying to transcode to MPEG2 as default then that could be the issue. Have you tried setting TSMuxer as the default engine in UMS and trying an .MP4 file on the WiiU? That may or may not work. Im also not entirely sure or not if the WiiU may need a renderer conf file. I say not sure because of the way the Wii U uses a web interface for accessing via DLNA. Does UMS recognise when its connected to the wii via the wii U web interface and what does UMS identify it as?

Chyaddo
Posts: 12
Joined: Wed Dec 05, 2012 2:07 am

Re: Version 4.0.0-a1 is released

Post by Chyaddo » Tue Jun 10, 2014 3:51 pm

:D :D :D :D :D
Last edited by Chyaddo on Fri Jun 29, 2018 3:54 pm, edited 1 time in total.

User avatar
SubJunk
Lead Developer
Posts: 2934
Joined: Sun May 27, 2012 4:12 pm

Re: Version 4.0.0-a1 is released

Post by SubJunk » Tue Jun 10, 2014 5:21 pm

Chyaddo wrote:Switching the default back to Mencoder is easy but i am concerned it will become less of a priority now or even eventually abandoned. At this point, FFmpeg just doesn't work acceptably with .ass subtitles...
We will not switch to using FFmpeg as the default engine in a stable release until it's working perfectly with subtitles.

Chyaddo
Posts: 12
Joined: Wed Dec 05, 2012 2:07 am

Re: Version 4.0.0-a1 is released

Post by Chyaddo » Tue Jun 10, 2014 10:59 pm

:D :D :D :D :D
Last edited by Chyaddo on Fri Jun 29, 2018 3:53 pm, edited 1 time in total.

Post Reply