Version 5.0.0 is released

Announcements about Universal Media Server
Paradox
Posts: 140
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 5.0.0 is released

Post by Paradox » Sat Feb 07, 2015 5:41 am

wongnog wrote:Loving the new v5, great work all you devs! For the XboxOne, thumbnails appear much better when the following is commented out in Microsoft-XboxOne.conf:

Code: Select all

#ThumbnailSize = 128x128
Looking at the defaultrenderer.conf file for the 5.00 version that command does not appear to exist for renderers. Though it is indeed in the Microsoft-XboxOne.conf file. I wonder if the devs could confirm if that command is available for all devices or not (might help with the bravia folder issues i mention)

Also if it does do anything it will not if you are inputting it with a hash (#) at the beginning, the hash will just cancel whatever command is after it, so anyone trying should make sure its without the # ;).

wongnog
Posts: 12
Joined: Fri Sep 19, 2014 3:37 pm

Re: Version 5.0.0 is released

Post by wongnog » Sun Feb 08, 2015 1:42 am

Sorry to be clear that line in Microsoft-XboxOne.conf is not commented out, so I tested by adding the # in front and my thumbnails are much nicer on the Xbox now.

User avatar
valib
Developer
Posts: 653
Joined: Fri Feb 08, 2013 3:11 am

Re: Version 5.0.0 is released

Post by valib » Sun Feb 08, 2015 4:40 am

Thanks for reporting that. I confirm that options ThumbnailSize and ThumbnailBackground were implemented and work for all renderers. Unfortunately they are not documented :oops:. The standard thumnail size is 320x180.

Paradox
Posts: 140
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 5.0.0 is released

Post by Paradox » Sun Feb 08, 2015 6:06 am

valib wrote:Thanks for reporting that. I confirm that options ThumbnailSize and ThumbnailBackground were implemented and work for all renderers. Unfortunately they are not documented :oops:. The standard thumnail size is 320x180.
Thanks valib for the confirmation :) another possibly useful function to experiment with :) Ill leave you to smack your own wrist or another devs for forgetting to add it to the default.conf hehe ;)

Phonism
Posts: 19
Joined: Sun Jun 03, 2012 4:56 am

Re: Version 5.0.0 is released

Post by Phonism » Sun Feb 08, 2015 6:56 am

Just want to come back to this thread after using 5.0.0 since release. I have to say, this version is the best UMS by far. I have been throwing everything I could at it, but it's been nothing but fast and top knotch performance!

UMS 5.3.0 - Java 8 update 60 - Windows 10 Pro 64bit
Intel Core i7-3770 - 8GB RAM
PS3 Slim 120GB
PS4

michaelt
Posts: 155
Joined: Tue Feb 03, 2015 11:18 am
Location: lost in the depths of my mind

Re: Version 5.0.0 is released

Post by michaelt » Sun Feb 08, 2015 12:08 pm

SubJunk wrote:
michaelt wrote:I am new to this, been playing for about a week with V4.4.0. Works surprisingly well with a few minor issues which I will post later if and only off they persist in V5.0.0. I am a Mac user and have viewed its forum.

I upgraded to V5 yesterday without any problems. It worked as well as V4 (or better?) with a much needed status improvement. I was root causing a memory leak issue which seemed to disappear with V5. Today I went to further isolate and verify UMS operating properly with no leaks when I ran into an unexpected error: the video files (.mkv) are no longer recognized. Going back to V4 works.

I am unix savvy but not Java. Any pointers or suggestions are welcome, especially if there is a better place to post this.
Hi michaelt, please follow the link in my signature to get support for this issue. If I have logs I can probably fix it very quickly :)
FYI - my configuration has an Index directory of symlinks to the video data. The Index links are all *.mkv pointing to the data which is just the UPC (EAN), no ".mkv" suffix on a different volume. I did test with both ".mkv" - no different - V4 works, V5 does not. I had the Log file - just did not know if you wanted them posted here or elsewhere.

*** Problem: no tab to upload and the "uploaded.net" - Ich nicht sprechen deutsch gut! Help, or another pointer please.

Edit: Also tried a simple direct file - failed, so it's not the filesystem structure.
Edit: ran one through Handbrake: H-264 & MPEG-4 X mkv & mp4 => 4 files. The *.mp4's worked, the *.mkv's failed. Looks like a mkv container issue.
MacPro5,1 - 2.8 GHz, 32 GB, 20TB, OS X 10.11.6,
. . . . and a few others.
Samsung UN55C8000
Home Theater (WIP): OS X based now, dedicated Linux later.

michaelt
Posts: 155
Joined: Tue Feb 03, 2015 11:18 am
Location: lost in the depths of my mind

Is this normal: "accept incoming network connections?"

Post by michaelt » Tue Feb 10, 2015 10:33 am

Upon launch every time I get the message:
Do you want the application “Universal Media Server.app” to accept incoming network connections?
followed by an administrator's name/passwd to get through the firewall protections.

What port(s) need to be opened up in the firewall? And why.
Who/what is communicating inbound?
Is this necessary? I don't like admin privs needed for an app to run.

thanx
MacPro5,1 - 2.8 GHz, 32 GB, 20TB, OS X 10.11.6,
. . . . and a few others.
Samsung UN55C8000
Home Theater (WIP): OS X based now, dedicated Linux later.

michaelt
Posts: 155
Joined: Tue Feb 03, 2015 11:18 am
Location: lost in the depths of my mind

Good news: OS X memory leak gone!

Post by michaelt » Tue Feb 10, 2015 11:15 am

It looks like the UMS-5.0.0-Java8 release has resolved the memory leak seen with UMS-4.4.0-Java6.
Not sure if it was UMS5 or the Java8 upgrade that did it. Either way, nice to see it resolved. I got better things to do with my memory.

thanx all
MacPro5,1 - 2.8 GHz, 32 GB, 20TB, OS X 10.11.6,
. . . . and a few others.
Samsung UN55C8000
Home Theater (WIP): OS X based now, dedicated Linux later.

AngelShine
Posts: 12
Joined: Mon Feb 03, 2014 3:07 am

Re: Version 5.0.0 is released

Post by AngelShine » Wed Feb 11, 2015 1:07 am

Hello, congrats for the new version!
There is an issue though. UMS version 5.0.0 is not choosing the right renderer for my TV. It is a LG 42LS5700-SB, I had provided a conf file for it and it was included with this version, which is awesome =) But it is not choosing the right conf file.

I had used the priority trick to make UMS choose my testing conf file, I see the included conf file in UMS 5.0.0 does not have that trick, but it did include some other difference related to agent and friendlyName, so I though that would cover it. I understand you can't distribute this conf file with priority, not everyone has my tv! :P

I tried this new version in a clean installation, and subtitles were not streaming, and video quality was worse, it was transcoding.
I checked detected media renderers and although I see the renderer named as '[TV]42LS5700-SB', clicking in its image it shows it is pointing to LS-LA6200.conf. After disabling that renderer it chooses LG-LA644V.conf and next LG-LM620. After disabling all of them one by one it finally chooses to use LS-LS5700.conf which is the one that makes subtitles stream and mantain perfect video quality, no transcoding required.

I could simply leave all of those renderers disabled, or re add the priority trick to my conf file. Is there any better option? One that would work for a new user of UMS with the same TV I own?

Thanks!

nickhere
Posts: 138
Joined: Sat Jan 03, 2015 3:28 am

Re: Version 5.0.0 is released

Post by nickhere » Wed Feb 11, 2015 5:03 am

I also have a problem with auto detection it picking up my tv as my bdt blue ray player.
It also picks up my twonky server
I have 3 panasonic as650 and 3 panasonic bdt360 blueray online
was wondering if the developers can come up with a small exe to extract the rendering information for each ip and tv.

This way i can set my config files properly
Nick

Post Reply