Greetings! Successful Deployment To Odroid-H2 / Debian Stretch / Denon X4200W

General discussion about Universal Media Server (no support or requests)
Post Reply
holografik
Posts: 15
Joined: Tue Feb 11, 2020 8:55 am

Greetings! Successful Deployment To Odroid-H2 / Debian Stretch / Denon X4200W

Post by holografik » Tue Feb 11, 2020 10:10 am

Hi Everybody,

I'm not sure if this would be the discussion to post this normally, but since it involves success rather than an immediate troubleshooting request, I thought I'd say hello.

I've successfully deployed UMS as a service to an Odroid-H2 running Debian Stretch / OpenMediaVault 4.1 (Arrakis). It's always nice to get an existence proof of a deployment ;) . I -did- have to perform a modest amount of extra configuration work, but it wasn't too time consuming to setup satisfactorily. I'm not going to publish a comprehensive description of the details in this post. Suffice it to say that in /etc/systemd/service/ums.service, I pointed to an environment file, /etc/default/ums, and then in the environment file, I employed a seldom mentioned environment variable, XDG_CONFIG_HOME. I would caution any linux novice to avoid following this path, and rely upon standard instructions.

I ran into problems with my Denon AVR-4311CI. I am encountering the often mentioned, Not Authorized problem. I tried the DHCP trick. It didn't solve the problem. I have some promising leads regarding DLNA certificates and/or a failed subscription to X_HtmlPage. I haven't sorted it out yet, and I intend to post more detailed research in the proper venue, Media Renderers.

The good news, however, is that with a very similar configuration file, UMS recognizes my Denon AVR-X4200W. Shout out to fuggi for blazing the trail, so to speak:
fuggi wrote:
Sun Feb 17, 2019 8:23 am
All,
it took me a day to set up UMS with my LG SJ800V (webOS v5.8) and Denon AVR-X2500H. You will find the configuration files attached which work very well for me, though they might not be final. I hope they will serve you well, too.

This configuration is set up in such a way to work around the "audio codec undefined" issue reported earlier.

Best regards
fuggi
With a few more modifications to the renderer config file, the X4200W now plays DSD 2.8M and FLAC 192K natively: no transcoding!.

I test-drove a number of UPNP/DLNA server implementations for linux/debian. I was not happy with Plex. It appears that it has chosen to transcode by default on my rootfs (i.e. not tmpfs in /tmp ... in ram). I found UMS to have the best device-specific rendering control of any available implementation.

Access to the source code has helped with a number of initial problems. It was how I was able to discover XDG_CONFIG_HOME, above. Of course, TRACE-level, logging is very useful as well ;) .

Great work, UMS team (and users)!
Attachments
Denon-X4200W.conf
(3.92 KiB) Downloaded 2 times

holografik
Posts: 15
Joined: Tue Feb 11, 2020 8:55 am

Re: Greetings! Successful Deployment To Odroid-H2 / Debian Stretch / Denon X4200W

Post by holografik » Tue Feb 11, 2020 10:39 am

holografik wrote:
Tue Feb 11, 2020 10:10 am
With a few more modifications to the renderer config file, the X4200W now plays DSD 2.8M and FLAC 192K natively: no transcoding!.
It would have been more precise to say: that UMS allows the X4200W to play DSD 2.8M and FLAC 192K natively. The Denon always has done that, but it can't if the file sent by UMS has already been transcoded.

holografik
Posts: 15
Joined: Tue Feb 11, 2020 8:55 am

Re: Greetings! Successful Deployment To Odroid-H2 / Debian Stretch / Denon X4200W

Post by holografik » Wed Feb 12, 2020 3:52 pm

I found out that a late modification which removed UserAgentSearch was a mistake. I discovered the next day that this entry was still used. Going forward, I would normally post a correction in, yes, the Media Renderers discussion. However, since I already attached a config file in the first post, I feel obligated to correct my mistake in the context of the original attachment. No more detailed updates in this thread. If I have any, I'll post to Media Renderers and perhaps include a reference in this thread.

I also made more readable the section, Supported Audio Formats.
Attachments
Denon-X4200W.conf
(6.53 KiB) Not downloaded yet

Post Reply