Trancode Folders missing

General discussion about Universal Media Server (no support or requests)
Post Reply
jsrobo
Posts: 4
Joined: Thu Dec 09, 2021 6:41 am

Trancode Folders missing

Post by jsrobo »

Just installed UMS using default settings, first time user.

Every thing works except some 2160p videos. Only some, these show an image file obviously sourced from the internet.

Having read the forum concerning my problem, I see a Transcode Folder should exist, where as I understand it I can say ''do not transcode''.

My problem is it does not seem to exist, and further I wouldn't know how to write an instruction anyway.

The directory C:/ProgramData/UMS does not have a transcode folder.
User avatar
mik_s
Moderator
Posts: 656
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: Trancode Folders missing

Post by mik_s »

The #--TRANSCODE--# folder will show on your device.
If you do not see it, enable "show the #--Transcode--# folder" in the GUI on the navigation tab.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
jsrobo
Posts: 4
Joined: Thu Dec 09, 2021 6:41 am

Re: Trancode Folders missing

Post by jsrobo »

Thanks for response.

Show transcode folder is already ticked in navigation settings.

As I understand it the transcode directories should exist in the C:/ProgramData/UMS folder, am I correct? A folder for each device.

Do these folders need adding manually?

Also I have Windows 10 to show hidden folders.

Can't think of anything else to do, except reinstall UMS and install without using default settings option.

Any help would be much appreciated.
jsrobo
Posts: 4
Joined: Thu Dec 09, 2021 6:41 am

Re: Trancode Folders missing

Post by jsrobo »

Further to above, the 2160p videos which don't play in UMS, do play using the inbuilt windows server.

I have 3 Samsung TV's of differing ages all show the same lack of a transcoder folder in ProgramData folder, but show a folder on the TV's screen for each directory which have videos in.

These are the 2 references to transcode folder in UMS.conf (there is another section further down the UMS.conf referring to common transcoder settings)

# Do not add engine names to filenames
# ------------------------------------
# Choose whether or not to show transcoding engine names for video; see also
# "Hide Transcode Folder" setting.
# Default: true
hide_enginenames =

# Show the "Transcode" folder
# ---------------------------
# Whether the Transcode folder is shown on clients; contents of the folder
# provide control over transcoding of video.
# Default: true
show_transcode_folder =

These were set by default installation to true, do these need changing? If so to what?
User avatar
mik_s
Moderator
Posts: 656
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: Trancode Folders missing

Post by mik_s »

The transcode folder is not on your computer, the ProgramData folder is just where UMS stores its data for settings and database. You should not need to change anything in this folder.

The #--TRANSCODE--# folder is a virtual folder that will only be shown on your device when you browse your media, and it will be present in any folder that has playable media.
You don't need to alter those settings as the default settings will show the folder.
If the number of options inside the #--TRANSCODE--# are a bit too much then you can disable some transcoding engines to tidy it up.
I personally have all but FFmpeg disabled. You should do this in the Transcoding setting tab in the GUI and not by editing the conf by hand.

If you have videos that play using another server but not in UMS then it means that your renderer conf needs tweaked to tell UMS that your device supports that format and can stream it. To confirm it will play, select the no transcoding option from the #--TRANSCODE--# folder. If you do logs I will be able to help updating your conf. See the section in red.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
jsrobo
Posts: 4
Joined: Thu Dec 09, 2021 6:41 am

Re: Trancode Folders missing - SOLVED

Post by jsrobo »

On a PC right click the UMS icon on the taskbar and go to ''main panel''. All the main UMS settings are shown and can be edited. This is the advise I required. May be usefull to others.
Post Reply