Can not disable automatic load subtitles

General discussion about Universal Media Server (no support or requests)
Post Reply
redavenger
Posts: 25
Joined: Sat Nov 11, 2017 4:44 pm

Can not disable automatic load subtitles

Post by redavenger »

hey devs,

Im running version 11.1.1.1 (and I haven't tested older versions) however in the transcoding-subtitle settings each time I untick
"Automatically load *.srt..."
the option comes back on when UMS is restarted.
How do I fix this?
CatMan
Posts: 11
Joined: Fri Jul 23, 2021 1:11 am

Re: Can not disable automatic load subtitles

Post by CatMan »

I too have this same problem

Universal Media Server (UMS) - BUG - Subtitles Still show despite the following settings:




UMS Version: 11.1.1.1
OS: Linux

TAB: Transcoding Settings
Common Transcode Settings > Subtitles settings

Disable subtitles: ON

Sub TAB: Subtitles settings:

Automatically load *.srt/*.sub subtitles with the same file name: OFF
Force external subtitles: OFF
Use embedded style: OFF

RESULT:

TV SET: #--TRANSCODE--# [VLC Video] {Audio: DTS HD/English (DTS-HD Master
I get 2 Different Types of sub-title fonts appearing at the exact same time on top of each other

TV SET: #--TRANSCODE--# [MEncoder Video] {Audio: DTS HD/English (DTS-HD Master
I get 1 sub-title font appearing upon playback

I have included a TXT file attachment of Media Info of the video file for analysis
@Sub-Junk - if you want/require a UMS Log file as well, please just let me know :)
Attachments
Jupiter Ascending 2015 BluRay 1080p AVC DTS-HD MA 7.1 x264-MgB [ETRG] - MEDIA INFO.txt
(8.06 KiB) Downloaded 8 times
Last edited by CatMan on Tue Aug 02, 2022 10:16 am, edited 2 times in total.
CatMan
Posts: 11
Joined: Fri Jul 23, 2021 1:11 am

Re: Can not disable automatic load subtitles

Post by CatMan »

This is also an attachment TXT file showing All files and folders for the Video File
Attachments
Jupiter Ascending 2015 BluRay 1080p AVC DTS-HD MA 7.1 x264-MgB [ETRG] - Folders & Files List.TXT
(2.83 KiB) Downloaded 6 times
User avatar
mik_s
Moderator
Posts: 633
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: Can not disable automatic load subtitles

Post by mik_s »

I had a look at this setting on my system and it looks like the "Automatically load *.srt/*.sub subtitles with the same file name:" checkbox has always got the tick after UMS is restarted no matter what the previous setting was.
This does not seem to effect the option in the UMS.conf file though, unchecking it sets "autoload_external_subtitles = false" and this stays the same on next reload even when it shows ticked in the GUI.

I think there is a bug here and the option is not linked correctly to the function so is not actually having any effect any more.

I'll create an issue on Github for this.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
Post Reply