New renderer for Panasonic HZX1509 (OLED)

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
Post Reply
newbietux
Posts: 24
Joined: Sun Apr 17, 2016 4:57 am
Location: DE, Glauchau/Saxony
Contact:

New renderer for Panasonic HZX1509 (OLED)

Post by newbietux »

I'm created a renderer for Panasonic HZX1509 (OLED) TV based on Panasonic-HZ1500.conf, because the HZ1500 not worked for me.

UMS has identify my TV only as "Panasonic TV". In the logfile never found the model number or so. Only a model specific string was submitted.

So I experimented with the file for HZ1500 and created a model specific file. With these renderer the TV can playing the most of my datas:
- pictures - jpeg, bmp
- audio - mp3, wav, wmv, flac (ogg not)
- video - avi, mkv (..., h264, h265 - if the computer is ready for gpu decoding)

The Panasonic TV can"t playing DTS audio. Of this reason in many cases UMS may transcode the audio stream, also it transcode the complete file for these cases.

My computer use linux OpenSUSE Leap 15.2 and my graphic card is a Radeon RX550. Because these combination I have problems to play HEVC-videos with UMS on the TV. It's playing with many little stops (stottered ?) - not smoothie ;-)

With smplayer (with the video output option "gpu") or vlc I can play the videos local on pc without problems.

When in UMS transcoding for mkv files is deactivated, the TV can playing the HEVC files without problems. Only the compatible audio streams are playing. This is a problem, that I can't solve in this time with my small knowing about the UMS configuration potentialities.
Panasonic-HZX1509.conf
renderer-file
(4.75 KiB) Downloaded 118 times
Please add the specific renderer icon to the package.
renderer-icon
renderer-icon
Panasonic-HZX1509.png (19.05 KiB) Viewed 3877 times
I hope these files can help other users with similar devices.
newbietux
Posts: 24
Joined: Sun Apr 17, 2016 4:57 am
Location: DE, Glauchau/Saxony
Contact:

Re: New renderer for Panasonic HZX1509 (OLED) - V.1.2

Post by newbietux »

Hello to all,
I modified the renderer file for Panasonic HZX1509 again.
Following added:
SupportedVideoBitDepths= 8,10
ffmpeg_mux_tsmuxer_compatible = true
audio_use_pcm = true
encoded_audio_passthrough = true

After this changes the TV play the video from mkv with H264 und H265 directly (no transcoding) - top :-)

If only DTS audio streams in the mkv-container - UMS transcoded the default audio stream.
But if the default audio stream (ger) is as DTS and another audio stream exist that's format is directly supported from the device/renderer, so UMS streamed this audio stream (e. g. eng and not default stream) to the device/renderer.

How can it solve this problem?
Panasonic-HZX1509.conf
renderer-file V.1.2
(5.37 KiB) Downloaded 114 times
newbietux
Posts: 24
Joined: Sun Apr 17, 2016 4:57 am
Location: DE, Glauchau/Saxony
Contact:

Re: New renderer for Panasonic HZX1509 (OLED) - test1+2 + 3

Post by newbietux »

My first test with the new configuration looks good - but the audio was the eng-version (Dolby-Atmos) and not the default audio stream (ger - DTS).

The second test I started UMS new - every test again a new start - and the trace for create a logfile to looking for details. Now the video was transcoded and "stottered".
The logfile shows a problem with higher bitrate as the configured. Because this reason the video should be transcoded. I think this high bitrate come from "audio_use_pcm".
But whatever shows this problem just now - and not on the first tests???
ums_dbg_2021-07-11-00-12.zip
pack-logfile-test2
(128.66 KiB) Downloaded 112 times
Now I configured the UMS.conf. I set "maximum_bitrate = 110". Then started the third test. Now the video can not playing and a error messages was showing on tv.
ums_dbg_2021-07-11-00-37.zip
pack-logfile-test3
(64.87 KiB) Downloaded 111 times
Now I make a breake and the next tests (with changed renderer file) in the next days.
newbietux
Posts: 24
Joined: Sun Apr 17, 2016 4:57 am
Location: DE, Glauchau/Saxony
Contact:

Re: New renderer for Panasonic HZX1509 (OLED) - test 4

Post by newbietux »

I removed the option "audio_use_pcm" from the renderer file and started the fourth test.
Panasonic-HZX1509.conf
renderer file V.1.3
(5.13 KiB) Downloaded 122 times
Now the video was playing without transcoding - but its playing the "eng" audio (Dolby Atmos) again and not the "ger" audio (DTS => should be transcoded to AC3).
All files with H265 and only DTS audio stream stottered.
ums_dbg_2021-07-11-01-06.zip
pack-logfile-test-4
(66.49 KiB) Downloaded 109 times
Now I haven't any idea how can solve the problem.
:cry: :evil: :twisted:
newbietux
Posts: 24
Joined: Sun Apr 17, 2016 4:57 am
Location: DE, Glauchau/Saxony
Contact:

Re: New renderer for Panasonic HZX1509 (OLED) - V.1.7 - final

Post by newbietux »

I have now understand, that the #--TRANSCODE--#-folder also gives access to the not transcoded media files. That whas the solution for my problem.
Based on that I configured out the renderer file at version 1.7. I disabled the setting "disable_transcode_for_extensions = MKV" because with this setting some files played not so pretty as I want. For example mkv movies with other AspectRatio or lower resolution whas not modified and looked not good at the screen.

I transcoded UHD mkv files with DTS sound to media file with AC3 sound. Now I can look the mkv UHD media files (original with atmos or with the AC3 sound) as not transcoded videos from the #--TRANSCOD--#-folder.

Not tested is the added option to enable "truehd" or "atmos" as audio formats by video files "mkv", "mp4" and "mpegts".

Today I tested much multimedia formats with success:
- audio "flac" and "mp3",
- video "mkv", "mp4", ...,
- photos "jpeg", "jpg"

Please add the following renderer-file and the -picture to the next release.
Panasonic-HZX1509.conf
renderer file for Panasonic OLED smart-TV HZX1509
(6.07 KiB) Downloaded 74 times
picture for renderer Panasonic OLED smart-TV HZX1509
picture for renderer Panasonic OLED smart-TV HZX1509
Panasonic-HZX1509.png (19.05 KiB) Viewed 2302 times
Post Reply