[Solved] Windows VLC client often can't see UMS

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
Post Reply
ajkessel
Posts: 30
Joined: Sun Jan 20, 2019 7:06 am

[Solved] Windows VLC client often can't see UMS

Post by ajkessel » Thu Jun 18, 2020 5:07 am

Running UMS 9.6.2 on an Ubuntu Focal system. I have a frequent but not 100% reproducible issue where VLC on a Windows box in the LAN doesn't show UMS under any of the "local network" media options (mDNS Network Discovery, Network Streams (SAP), or where I'd expect it -- "Universal Plug'n'Play"). Sometimes restarting UMS fixes it but not always. Based on the trace log, it appears UMS is seeing the query:

Code: Select all

TRACE 2020-06-17 12:47:32.692 [UPNPHelper] Received a NOTIFY from [192.168.98.2:1900]
TRACE 2020-06-17 12:47:33.780 [UPNPHelper] IP Filter: No IP filter specified, access granted to 192.168.98.200
TRACE 2020-06-17 12:47:33.780 [UPNPHelper] Received a M-SEARCH from [192.168.98.200:56541]: M-SEARCH * HTTP/1.1^M
Host: 239.255.255.250:1900
ST: urn:schemas-wifialliance-org:device:WFADevice:1
Man: "ssdp:discover"
MX: 3
But still nothing shows up on VLC.

Another possibly related problem is a Sony PS3 on the network usually sees UMS but when I navigate to the folder structure, the PS3 spins until it times out and no media options appear. Restarting UMS usually fixes this symptom.

Any ideas? I've attached a trace log and my (mostly standard) conf file. The VLC client is at 192.168.1.200 in this trace, and IP of the server is 192.168.1.2. The server is connected to the LAN via Ethernet, while the client is on WiFi. No tweaks have been made to any renderers.
Attachments
ums-log-2020-06-17.txt.gz
(369.36 KiB) Downloaded 110 times
ums-conf-2020-06-17.txt
(4.75 KiB) Downloaded 110 times

ajkessel
Posts: 30
Joined: Sun Jan 20, 2019 7:06 am

Re: Windows VLC client often can't see UMS

Post by ajkessel » Mon Jun 22, 2020 6:06 am

Another data point here--when this happens, other clients often can't see UMS either. If I try to kill the client via a kill signal, the UMS task never shuts down. But it's not (completely) frozen, as the debug log shows periodic "resending last discovery" and "sending ALIVE" messages.

If I force quit with kill -9, the task does stop and can then be restarted.

User avatar
SubJunk
Lead Developer
Posts: 3283
Joined: Sun May 27, 2012 4:12 pm

Re: Windows VLC client often can't see UMS

Post by SubJunk » Sun Sep 06, 2020 3:06 pm

This might be improved in 9.8.0, please let us know

ajkessel
Posts: 30
Joined: Sun Jan 20, 2019 7:06 am

Re: Windows VLC client often can't see UMS

Post by ajkessel » Mon Sep 07, 2020 5:01 am

Yes, as of 9.8.1, I have not been able to replicate this issue.

Post Reply