Chromecast, an Android Device, and UMS.

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
User avatar
DeFlanko
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: Chromecast, an Android Device, and UMS.

Post by DeFlanko » Fri Jan 03, 2014 2:39 am

Best thing for now, until a fix is presented, is to hand break your media to match that of your android camera media's info...

The other problem i read up on last night is that the "libfaac" and "libfaacplus" are not even built into ffmpeg by default compile... because they are non - free extensions you have to find then, add them in the svn, and then complie... which it looks like you need a Linux box to do....

The default aac profile in mencoder and ffmpeg is "aac" but in order to use it you have to add in "-strict -2" but when you do add that in mencoder throws an error...

it's wierd...

Sent from my SM-N900T Using ForumTouch for Android

Sunwind
Posts: 16
Joined: Fri Mar 15, 2013 9:13 pm

Re: Chromecast, an Android Device, and UMS.

Post by Sunwind » Thu Jan 23, 2014 11:54 pm

Just came to the forums actually to ask if there's any way to stream from UMS to my android phone, when you say "so far, it's a solution", I take it there's not really any other way to do it than described in this topic? I was hoping there'd be a nice simple app for it, but I couldn't find anything.

Wolfgan
Posts: 371
Joined: Fri Feb 08, 2013 12:33 am

Re: Chromecast, an Android Device, and UMS.

Post by Wolfgan » Fri Jan 24, 2014 11:06 pm

Sunwind wrote:Just came to the forums actually to ask if there's any way to stream from UMS to my android phone, when you say "so far, it's a solution", I take it there's not really any other way to do it than described in this topic? I was hoping there'd be a nice simple app for it, but I couldn't find anything.
Did you try with Skifta or BubbleUPNP from Google Play?
-- UMS serving PS3, WDTV, Samsung H6400 + J5500 and Kalemsoft renderers! (no video transcoding but remuxing accepted :D )

User avatar
DeFlanko
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: Chromecast, an Android Device, and UMS.

Post by DeFlanko » Sat Jan 25, 2014 12:11 pm

Sunwind wrote:Just came to the forums actually to ask if there's any way to stream from UMS to my android phone, when you say "so far, it's a solution", I take it there's not really any other way to do it than described in this topic? I was hoping there'd be a nice simple app for it, but I couldn't find anything.

What kind of Android phone do you have?

i have made the SamsungMobile.conf so if its a Samsung Device, just post up your user agent for it and see about getting it added to that.

Otherwise i would use like what wolf mentioned -- Skifta... its the only app out there that went through the DNLA credentialing (which is expensive) so that means they don't plan on updating it because it works. (protip, ever time you update a DNLA device app or software.. you have to get it recertified... which is expensive...which also if you even want ot be apart of the DNLA group you have to pay $10k first to become a member.) So yeah i like Skifta.. :P

also try to use your Native video player... not something like MXplayer or what not.. (not saying those don't work.. you can try... i just never try to load them when building my Confs)

digitalhigh
Posts: 2
Joined: Tue Feb 18, 2014 4:19 pm

Re: Chromecast, an Android Device, and UMS.

Post by digitalhigh » Tue Feb 18, 2014 4:30 pm

Has anybody else given this any love besides suggesting using something else?

I have quite a bit of MKV/AVI content, and I will not be re-converting. I use a HTPC in my living room as my primary media center, and was hoping the Chromecast would be a viable option for my bedroom where I don't have to have another peripheral or LAN connection in order to manage my content. Likewise, I don't feel like paying for a Plex subscription every month in order to use my existing collection. Might as well buy netflix.

Resultingly, I have settled on working with UMC and Avia, and found the previous profiles and started tweaking them.

For starters, I updated the UserAgentSearch string so that it should work with all release versions of the chrome OS, as the latest wasn't detected when I tried it.

Added the supported section at the bottom so it should sort out which formats it can play natively and which should be transcoded. This seems to work fine.

With the custom mencoder settings previously posted, I found it was actually causing a bunch of errors in the transcoder if you look in the debug log. So, since we're really trying to to transcode ac3 audio and all that good stuff, I simplified it to the base of what we're working with:

CustomMencoderOptions = -lavcopts vcodec=mpeg4:acodec=libfaac:abitrate=192

Code: Select all

#----------------------------------------------------------------------------
# Profile for Avia Media Player for Android -- Chromecast app.
# See PS3.conf for a description of all possible configuration options.
# Attempt to use vcodec=libx264:acodec=libaacplus
# Version 1


RendererName=Avia / Chromecast
RendererIcon=avia.png
UserAgentSearch= (CrKey armv7l)
Video=true
Audio=true
Image=true
SeekByTime = exclusive


MediaInfo = true
MaxVideoWidth = 1920
MaxVideoHeight = 1080

CustomMencoderOptions = -lavcopts vcodec=mpeg4:acodec=libfaac:abitrate=192 

#From https://developers.google.com/cast/docs/media.
Supported = f:mp4             v:mp4|h264               a:aac|mp3               m:video/mp4                n:6
#Add some audio formats, just because.
Supported = f:wav   a:dts|lpcm   n:6   s:48000   m:audio/wav
Supported = f:wav                n:2   s:48000   m:audio/wav
Supported = f:mp3                n:2             m:audio/mpeg

So, I've got more playing around to do yet, but it seems like this just needs the audio stuff tweaked correctly to get everything streaming.

User avatar
DeFlanko
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: Chromecast, an Android Device, and UMS.

Post by DeFlanko » Wed Feb 19, 2014 4:39 am

Yes i was working on something like this ... but then i had a baby... I too would love to get this going because in the long run i can then put the chrome cast in her room when she grows up =)

This is as far as i got... still having issues playing video... ill plug in your suggestions and get back with you. But as far as i understood the errors "libfaac" is not loaded correctly in UMS/Mencoder build.

Maybe its possible that @Subjunk could investigate -- id have to get more logs again.

I encourage you to do the same -- ill then open a Issue tracking ticket.

Code: Select all

#----------------------------------------------------------------------------
# Profile for Avia Media Player for Android -- Chromecast app.
# See PS3.conf for a description of all possible configuration options.
# Attempt to use vcodec=libx264:acodec=libaacplus
# Version 1
#
# User-Agent: Mozilla/5.0 (CrKey armv7l 1.3.14651) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.0 Safari/537.36, Referer: http://receiver.aviatheapp.com/
# User-Agent: Android/4.2.1 UPnP/1.0 Cling/2.0
# User-Agent: Apache-HttpClient/UNAVAILABLE (java 1.4)

RendererName=Avia / Chromecast App
RendererIcon=avia.png
UserAgentSearch= (CrKey armv7l)
#UserAgentAdditionalHeader= 
#UserAgentAdditionalHeaderSearch=
Video=true
Audio=true
Image=true
MaxVideoBitrateMbps=22
KeepAspectRatio=true
MaxVideoWidth = 1280
MaxVideoHeight = 720
KeepAspectRatio=true
CustomMencoderOptions = -channels 6 -lavdopts debug=0:threads=4 \
-lavcopts autoaspect=1:vcodec=mpeg4:acodec=libfaac:abitrate=192\
-ofps 30000/1001 \
-lavdopts fast \
-af lavcresample=48000 \
-srate 48000 \
-o

# Supported Media Type: https://developers.google.com/cast/supported_media_types
#   All Google Cast devices at a minimum support the following media types:
#      Video codecs: H.264 High Profile Level 4.1, 4.2 and 5, VP8
#      Audio decoding: HE-AAC, LC-AAC, CELT/Opus, MP3, Vorbis
#      Containers: MP4/CENC, WebM, MPEG-DASH, SmoothStreaming
#      Level 1 DRM support: Widevine, PlayReady
#
#MediaInfo = True
# Supported video formats:
# ????????????????????
# Supported audio formats:
# ????????????????????

digitalhigh
Posts: 2
Joined: Tue Feb 18, 2014 4:19 pm

Re: Chromecast, an Android Device, and UMS.

Post by digitalhigh » Wed Feb 19, 2014 4:08 pm

Code: Select all

INFO  2014-02-18 21:58:41.790 [AWT-EventQueue-0] Configuration saved to: C:\ProgramData\UMS\UMS.conf
DEBUG 2014-02-18 21:58:42.737 [background-task-0] singleton task restart started
DEBUG 2014-02-18 21:58:42.737 [background-task-0-restart(0)] task started
INFO  2014-02-18 21:58:42.737 [background-task-0-restart(0)] Sending BYEBYE...
INFO  2014-02-18 21:58:42.777 [background-task-0-restart(0)] Stopping server on host 192.168.1.253 and port 5001...
INFO  2014-02-18 21:58:43.824 [background-task-0-restart(0)] Using address /192.168.1.253 found on network interface: name:eth4 (Realtek PCIe GBE Family Controller)
INFO  2014-02-18 21:58:43.825 [background-task-0-restart(0)] Created socket: /192.168.1.253:5001
DEBUG 2014-02-18 21:58:43.857 [background-task-0-restart(0)] Sending ALIVE...
DEBUG 2014-02-18 21:58:43.895 [background-task-0-restart(0)] task ended
DEBUG 2014-02-18 21:58:44.369 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:44.370 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:44.371 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:44.371 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:44.372 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:44.372 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:44.372 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:44.372 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:44.373 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:44.373 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:44.373 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str Avatar (2009).mp4>I:\Movies\Avatar (2009)\Avatar (2009).mp4
DEBUG 2014-02-18 21:58:44.374 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str Avatar (2009).mp4>I:\Movies\Avatar (2009)\Avatar (2009).mp4
DEBUG 2014-02-18 21:58:44.374 [New I/O worker #12] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
INFO  2014-02-18 21:58:44.379 [New I/O worker #12] Checking shared folder: I:\Movies
INFO  2014-02-18 21:58:44.380 [New I/O worker #12] Checking shared folder: I:\TV
DEBUG 2014-02-18 21:58:57.210 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:57.210 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:57.211 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:57.211 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:57.212 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:57.212 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:57.212 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:57.213 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:57.213 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:57.213 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
DEBUG 2014-02-18 21:58:57.213 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str Avatar (2009).mp4>I:\Movies\Avatar (2009)\Avatar (2009).mp4
DEBUG 2014-02-18 21:58:57.214 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str Avatar (2009).mp4>I:\Movies\Avatar (2009)\Avatar (2009).mp4
DEBUG 2014-02-18 21:58:57.214 [New I/O worker #14] master is internal:net.pms.dlna.RealFile str The Avengers (2012).avi>I:\Movies\The Avengers (2012)\The Avengers (2012).avi
INFO  2014-02-18 21:58:57.218 [New I/O worker #14] Checking shared folder: I:\Movies
INFO  2014-02-18 21:58:57.219 [New I/O worker #14] Checking shared folder: I:\TV
DEBUG 2014-02-18 21:58:57.581 [New I/O worker #14] Forcing short path name on I:\Movies\The Adventures of André and Wally B. (1984)
DEBUG 2014-02-18 21:58:57.582 [New I/O worker #14] Forcing short path name on I:\Movies\The Adventures of André and Wally B. (1984)
DEBUG 2014-02-18 21:58:57.660 [New I/O worker #14] Forcing short path name on I:\Movies\Brüno (2009)
DEBUG 2014-02-18 21:58:57.661 [New I/O worker #14] Forcing short path name on I:\Movies\Brüno (2009)
DEBUG 2014-02-18 21:58:57.927 [New I/O worker #14] Forcing short path name on I:\Movies\La belle Américaine (1961)
DEBUG 2014-02-18 21:58:57.928 [New I/O worker #14] Forcing short path name on I:\Movies\La belle Américaine (1961)
DEBUG 2014-02-18 21:58:57.945 [New I/O worker #14] Forcing short path name on I:\Movies\The Lion King 1½ (2004)
DEBUG 2014-02-18 21:58:57.945 [New I/O worker #14] Forcing short path name on I:\Movies\The Lion King 1½ (2004)
DEBUG 2014-02-18 21:58:58.230 [New I/O worker #14] Starting transcode/remux of The Avengers (2012).avi with media info: container: null, bitrate: 0, size: 0, video codec: null, duration: null, width: 0, height: 0, frame rate: null, muxing mode: null, mime type: null
DEBUG 2014-02-18 21:58:58.231 [New I/O worker #14] Reading mpeg2_main_settings: default: "Automatic (Wired)", previous: "Automatic (Wireless)", current: "Automatic (Wired)"
DEBUG 2014-02-18 21:58:58.249 [New I/O worker #14] Reading mencoder_nooutofsync: default: true, previous: true, current: false
DEBUG 2014-02-18 21:58:58.249 [New I/O worker #14] Creating pipe \\.\pipe\mencoder1392782338249
DEBUG 2014-02-18 21:58:58.294 [Thread-22] Waiting for pipe connection \\.\pipe\mencoder1392782338249
DEBUG 2014-02-18 21:58:58.294 [mencoder.exe-4] Starting "C:\Program Files (x86)\Universal Media Server\win32\mencoder.exe" -ss 3005.0 "I:\Movies\The Avengers (2012)\The Avengers (2012).avi" -msglevel statusline=2 -oac lavc -of lavf -lavfopts format=mpegts -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavcopts vcodec=mpeg4:acodec=libfaac:abitrate=192 -lavdopts debug=0:threads=4 -lavcopts autoaspect=1:acodec=ac3:abitrate=640:threads=4:o=preset=superfast,crf=16,g=250,i_qfactor=0.71,qcomp=0.6,level=4.1,weightp=0,8x8dct=0,aq-strength=0:vrc_maxrate=24000:vrc_buf_size=25000 -nosub -noautosub -ofps 24000/1001 -lavdopts fast -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1392782338249
DEBUG 2014-02-18 21:58:58.297 [mencoder.exe-4] Reading pipe: \\.\pipe\mencoder1392782338249
DEBUG 2014-02-18 21:58:58.297 [mencoder.exe-4] Attaching thread: mencoder.exe-4
DEBUG 2014-02-18 21:58:58.326 [Thread-26] MEncoder sherpya-r36816+g4040b56-4.8 (C) 2000-2014 MPlayer Team
DEBUG 2014-02-18 21:58:58.329 [Thread-26] success: format: 0  data: 0x0 - 0x88c67800
DEBUG 2014-02-18 21:58:58.329 [Thread-26] libavformat version 55.30.100 (internal)
DEBUG 2014-02-18 21:58:58.332 [Thread-26] AVI file format detected.
DEBUG 2014-02-18 21:58:58.332 [Thread-26] [aviheader] Video stream found, -vid 0
DEBUG 2014-02-18 21:58:58.332 [Thread-26] [aviheader] Audio stream found, -aid 1
DEBUG 2014-02-18 21:58:58.338 [Thread-26] AVI: ODML: Building ODML index (2 superindexchunks).
DEBUG 2014-02-18 21:58:58.508 [Thread-26] VIDEO:  [XVID]  1920x1080  12bpp  23.976 fps  5499.1 kbps (671.3 kbyte/s)
DEBUG 2014-02-18 21:58:58.508 [Thread-26] [V] filefmt:3  fourcc:0x44495658  size:1920x1080  fps:23.976  ftime:=0.0417
DEBUG 2014-02-18 21:58:58.508 [Thread-26] ==========================================================================
DEBUG 2014-02-18 21:58:58.508 [Thread-26] Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
DEBUG 2014-02-18 21:58:58.509 [Thread-26] libavcodec version 55.50.100 (internal)
DEBUG 2014-02-18 21:58:58.510 [Thread-26] AUDIO: 48000 Hz, 6 ch, floatle, 640.0 kbit/6.94% (ratio: 80000->1152000)
DEBUG 2014-02-18 21:58:58.510 [Thread-26] Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
DEBUG 2014-02-18 21:58:58.510 [Thread-26] ==========================================================================
DEBUG 2014-02-18 21:58:58.510 [Thread-25] ** MUXER_LAVF *****************************************************************
DEBUG 2014-02-18 21:58:58.510 [Thread-22] Result of \\.\pipe\mencoder1392782338249 : true
DEBUG 2014-02-18 21:58:58.510 [Thread-26] OK, exit.
DEBUG 2014-02-18 21:58:58.510 [Thread-25] REMEMBER: MEncoder's libavformat muxing is presently broken and can generate
DEBUG 2014-02-18 21:58:58.511 [Thread-25] INCORRECT files in the presence of B-frames. Moreover, due to bugs MPlayer
DEBUG 2014-02-18 21:58:58.511 [Thread-25] will play these INCORRECT files as if nothing were wrong!
DEBUG 2014-02-18 21:58:58.511 [Thread-25] *******************************************************************************
DEBUG 2014-02-18 21:58:58.511 [Thread-26] Opening video filter: [expand osd=1]
DEBUG 2014-02-18 21:58:58.511 [Thread-26] Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
DEBUG 2014-02-18 21:58:58.511 [Thread-26] ==========================================================================
DEBUG 2014-02-18 21:58:58.511 [Thread-26] Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
DEBUG 2014-02-18 21:58:58.513 [Thread-26] Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
DEBUG 2014-02-18 21:58:58.513 [Thread-26] ==========================================================================
DEBUG 2014-02-18 21:58:58.513 [Thread-25] [ac3 @ 0000000001fd32c0]Channel layout not specified
DEBUG 2014-02-18 21:58:58.513 [Thread-25] [ac3 @ 0000000001fd32c0]No channel layout specified. The encoder will guess the layout, but it might be incorrect.
DEBUG 2014-02-18 21:58:58.529 [Thread-26] Movie-Aspect is undefined - no prescaling applied.
DEBUG 2014-02-18 21:58:58.529 [Thread-26] videocodec: libavcodec (1920x1080 fourcc=34504d46 [FMP4])
DEBUG 2014-02-18 21:58:58.537 [Thread-25] Unknown option preset
DEBUG 2014-02-18 21:58:58.538 [Thread-25] Unknown option crf
DEBUG 2014-02-18 21:58:58.538 [Thread-25] Unknown option weightp
DEBUG 2014-02-18 21:58:58.538 [Thread-25] Unknown option 8x8dct
DEBUG 2014-02-18 21:58:58.538 [Thread-25] Unknown option aq-strength
DEBUG 2014-02-18 21:58:58.538 [Thread-25] FATAL: Cannot initialize video driver.
DEBUG 2014-02-18 21:58:58.546 [Thread-26] 
DEBUG 2014-02-18 21:58:58.546 [Thread-26] Exiting...
INFO  2014-02-18 21:58:58.555 [mencoder.exe-4] Process C:\Program Files (x86)\Universal Media Server\win32\mencoder.exe has a return code of 1! Maybe an error occurred... check the log file
INFO  2014-02-18 21:59:04.394 [StartPlaying Event] Started playing The Avengers (2012).avi on your Avia / Chromecast
DEBUG 2014-02-18 21:59:04.396 [StartPlaying Event] The full filename of which is: I:\Movies\The Avengers (2012)\The Avengers (2012).avi and the address of the renderer is: 192.168.1.84
DEBUG 2014-02-18 21:59:06.896 [Buffered IO End Checker] Stopping process: mencoder.exe-4
Here's what happens with the copy of "The Avengers" I've been testing with - this is AVI transcoding.

And this is trying to play a mt2s of "Batman Begins":

Code: Select all

DEBUG 2014-02-18 22:04:44.306 [pool-15-thread-1] Starting "C:\Program Files (x86)\Universal Media Server\win32\ffmpeg.exe" -loglevel fatal -ss 2 -i "I:\Movies\Batman Begins (2005)\Batman Begins (2005).m2ts" -an -an -s 320x180 -vframes 1 -f image2 pipe:
DEBUG 2014-02-18 22:04:44.310 [pool-15-thread-1] Attaching thread: ffmpeg.exe-5
DEBUG 2014-02-18 22:04:47.730 [Buffered IO End Checker] Stopping process: ffmpeg.exe-5
DEBUG 2014-02-18 22:04:48.652 [New I/O worker #13] Starting transcode/remux of Batman Begins (2005).m2ts with media info: container: null, bitrate: 0, size: 0, video codec: null, duration: null, width: 0, height: 0, frame rate: null, muxing mode: null, mime type: null
DEBUG 2014-02-18 22:04:48.669 [New I/O worker #13] Creating pipe \\.\pipe\mencoder1392782688669
DEBUG 2014-02-18 22:04:48.679 [Thread-31] Waiting for pipe connection \\.\pipe\mencoder1392782688669
DEBUG 2014-02-18 22:04:48.679 [mencoder.exe-6] Starting "C:\Program Files (x86)\Universal Media Server\win32\mencoder.exe" -ss 0 "I:\Movies\Batman Begins (2005)\Batman Begins (2005).m2ts" -msglevel statusline=2 -oac lavc -of lavf -lavfopts format=mpegts -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavcopts vcodec=mpeg4:acodec=libfaac:abitrate=192 -lavdopts debug=0:threads=4 -lavcopts autoaspect=1:acodec=ac3:abitrate=640:threads=4:o=preset=superfast,crf=16,g=250,i_qfactor=0.71,qcomp=0.6,level=4.1,weightp=0,8x8dct=0,aq-strength=0:vrc_maxrate=24000:vrc_buf_size=25000 -nosub -noautosub -ofps 24000/1001 -lavdopts fast -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1392782688669
DEBUG 2014-02-18 22:04:48.682 [mencoder.exe-6] Reading pipe: \\.\pipe\mencoder1392782688669
DEBUG 2014-02-18 22:04:48.682 [mencoder.exe-6] Attaching thread: mencoder.exe-6
DEBUG 2014-02-18 22:04:48.711 [Thread-35] MEncoder sherpya-r36816+g4040b56-4.8 (C) 2000-2014 MPlayer Team
DEBUG 2014-02-18 22:04:48.714 [Thread-35] success: format: 0  data: 0x0 - 0xa268000
DEBUG 2014-02-18 22:04:48.714 [Thread-35] libavformat version 55.30.100 (internal)
DEBUG 2014-02-18 22:04:48.718 [Thread-35] TS file format detected.
DEBUG 2014-02-18 22:04:48.723 [Thread-35] VIDEO H264(pid=4113) AUDIO A52(pid=4352) NO SUBS (yet)!  PROGRAM N. 1
DEBUG 2014-02-18 22:04:48.724 [Thread-35] FPS seems to be: 23.975986
DEBUG 2014-02-18 22:04:48.724 [Thread-35] [V] filefmt:29  fourcc:0x10000005  size:1920x1088  fps:23.976  ftime:=0.0417
DEBUG 2014-02-18 22:04:48.724 [Thread-35] ==========================================================================
DEBUG 2014-02-18 22:04:48.724 [Thread-35] Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
DEBUG 2014-02-18 22:04:48.725 [Thread-35] libavcodec version 55.50.100 (internal)
DEBUG 2014-02-18 22:04:48.726 [Thread-35] AUDIO: 48000 Hz, 6 ch, floatle, 448.0 kbit/4.86% (ratio: 56000->1152000)
DEBUG 2014-02-18 22:04:48.726 [Thread-35] Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
DEBUG 2014-02-18 22:04:48.726 [Thread-35] ==========================================================================
DEBUG 2014-02-18 22:04:48.726 [Thread-31] Result of \\.\pipe\mencoder1392782688669 : true
DEBUG 2014-02-18 22:04:48.726 [Thread-35] OK, exit.
DEBUG 2014-02-18 22:04:48.726 [Thread-34] ** MUXER_LAVF *****************************************************************
DEBUG 2014-02-18 22:04:48.726 [Thread-35] Opening video filter: [expand osd=1]
DEBUG 2014-02-18 22:04:48.726 [Thread-34] REMEMBER: MEncoder's libavformat muxing is presently broken and can generate
DEBUG 2014-02-18 22:04:48.726 [Thread-35] Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
DEBUG 2014-02-18 22:04:48.727 [Thread-34] INCORRECT files in the presence of B-frames. Moreover, due to bugs MPlayer
DEBUG 2014-02-18 22:04:48.727 [Thread-35] ==========================================================================
DEBUG 2014-02-18 22:04:48.727 [Thread-34] will play these INCORRECT files as if nothing were wrong!
DEBUG 2014-02-18 22:04:48.727 [Thread-34] *******************************************************************************
DEBUG 2014-02-18 22:04:48.727 [Thread-35] Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
DEBUG 2014-02-18 22:04:48.728 [Thread-35] Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
DEBUG 2014-02-18 22:04:48.729 [Thread-34] [ac3 @ 0000000001fd32c0]Channel layout not specified
DEBUG 2014-02-18 22:04:48.729 [Thread-35] ==========================================================================
DEBUG 2014-02-18 22:04:48.729 [Thread-34] [ac3 @ 0000000001fd32c0]No channel layout specified. The encoder will guess the layout, but it might be incorrect.
DEBUG 2014-02-18 22:04:48.750 [Thread-34] 
DEBUG 2014-02-18 22:04:48.750 [Thread-34] 1 duplicate frame(s)!
DEBUG 2014-02-18 22:04:48.757 [Thread-34] 
DEBUG 2014-02-18 22:04:48.757 [Thread-34] 1 duplicate frame(s)!
DEBUG 2014-02-18 22:04:48.764 [Thread-34] 
DEBUG 2014-02-18 22:04:48.764 [Thread-34] 1 duplicate frame(s)!
DEBUG 2014-02-18 22:04:48.770 [Thread-35] Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
DEBUG 2014-02-18 22:04:48.770 [Thread-35] videocodec: libavcodec (1920x1080 fourcc=34504d46 [FMP4])
DEBUG 2014-02-18 22:04:48.781 [Thread-35] 
DEBUG 2014-02-18 22:04:48.781 [Thread-34] Unknown option preset
DEBUG 2014-02-18 22:04:48.781 [Thread-35] Exiting...
DEBUG 2014-02-18 22:04:48.781 [Thread-34] Unknown option crf
DEBUG 2014-02-18 22:04:48.781 [Thread-34] Unknown option weightp
DEBUG 2014-02-18 22:04:48.781 [Thread-34] Unknown option 8x8dct
DEBUG 2014-02-18 22:04:48.781 [Thread-34] Unknown option aq-strength
DEBUG 2014-02-18 22:04:48.781 [Thread-34] FATAL: Cannot initialize video driver.
INFO  2014-02-18 22:04:48.792 [mencoder.exe-6] Process C:\Program Files (x86)\Universal Media Server\win32\mencoder.exe has a return code of 1! Maybe an error occurred... check the log file
INFO  2014-02-18 22:04:54.779 [StartPlaying Event] Started playing Batman Begins (2005).m2ts on your Avia / Chromecast
DEBUG 2014-02-18 22:04:54.780 [StartPlaying Event] The full filename of which is: I:\Movies\Batman Begins (2005)\Batman Begins (2005).m2ts and the address of the renderer is: 192.168.1.84
DEBUG 2014-02-18 22:04:57.280 [Buffered IO End Checker] Stopping process: mencoder.exe-6
INFO  2014-02-18 22:04:58.850 [StopPlaying Event] Stopped playing Batman Begins (2005).m2ts on your Avia / Chromecast
DEBUG 2014-02-18 22:04:58.851 [StopPlaying Event] The full filename of which is: I:\Movies\Batman Begins (2005)\Batman Begins (2005).m2ts and the address of the renderer is: 192.168.1.84
DEBUG 2014-02-18 22:04:58.851 [StopPlaying Event] add MapFile [name=Batman Begins (2005).m2ts, id=null, format=MPG, children=[]] to last played MapFile [name=Batman Begins (2005), id=0$2$93, format=null, children=[MapFile [name=extrafanart, id=0$2$93$1, format=null, children=[]], MapFile [name=backdrop.jpg, id=0$2$93$2, format=JPG, children=[]], MapFile [name=banner.jpg, id=0$2$93$3, format=JPG, children=[]], TranscodeVirtualFolder [id=4, name=#--TRANSCODE--#, full path=0$2$93$4, ext=null, discovered=false], MapFile [name=Batman Begins (2005).m2ts, id=0$2$93$5, format=MPG, children=[]], MapFile [name=clearart.png, id=0$2$93$6, format=PNG, children=[]], MapFile [name=disc.png, id=0$2$93$7, format=PNG, children=[]], MapFile [name=fanart.jpg, id=0$2$93$8, format=JPG, children=[]], MapFile [name=folder.jpg, id=0$2$93$9, format=JPG, children=[]], MapFile [name=landscape.jpg, id=0$2$93$10, format=JPG, children=[]], MapFile [name=logo.png, id=0$2$93$11, format=PNG, children=[]], MapFile [name=poster.jpg, id=0$2$93$12, format=JPG, children=[]]]] RecentlyPlayed [id=1, name=Recently Played, full path=0$1, ext=null, discovered=false]

Let me know if there is any more pertinent information or if I've added to the issues with my config over yours...but removing the stuff in mine seems to get further - up to here:

DEBUG 2014-02-18 22:04:48.781 [Thread-34] Unknown option preset
DEBUG 2014-02-18 22:04:48.781 [Thread-35] Exiting...
DEBUG 2014-02-18 22:04:48.781 [Thread-34] Unknown option crf
DEBUG 2014-02-18 22:04:48.781 [Thread-34] Unknown option weightp
DEBUG 2014-02-18 22:04:48.781 [Thread-34] Unknown option 8x8dct
DEBUG 2014-02-18 22:04:48.781 [Thread-34] Unknown option aq-strength
DEBUG 2014-02-18 22:04:48.781 [Thread-34] FATAL: Cannot initialize video driver.

I've looked through both settings and my config, and can't seem to find where it's getting those options...

User avatar
DeFlanko
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: Chromecast, an Android Device, and UMS.

Post by DeFlanko » Thu Feb 20, 2014 4:08 am

Looks liek a specific codec is broken somewhere...

marcjohnsony
Posts: 1
Joined: Fri Mar 07, 2014 8:07 pm

Re: Chromecast, an Android Device, and UMS.

Post by marcjohnsony » Fri Mar 07, 2014 8:28 pm

The following article just aims to provide a step by step guide on how to Chromecast local video from Mac or Windows for easy play on HDTV or TV at http://www.idealshare.net/video-convert ... i-mp4.html

It can help to:

Stream Charomacast unsupported local video files like MKV, AVI, MP4, Apple ProRes, MOV, FLV, VOB, DAV, MPG, MXF, AVCHD, WTV, WMV, ASF, RMVB from Windows or Mac to Chromecast (Refer to Part 1 and Part 2).
Stream Charomecast incompatible audio files like FLAC, DTS, AIFF, APE, WAV, WMA, Apple Lossless, M4A, OGG, CAF and etc from computer to Chromecast (Refer to Part 1 and Part 2).
Stream Charomecast supported video or audio from computer to Chromecast (Only refer to Part 2).

User avatar
DeFlanko
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: Chromecast, an Android Device, and UMS.

Post by DeFlanko » Sat Mar 08, 2014 5:08 am

marcjohnsony wrote:The following article just aims to provide a step by step guide on how to Chromecast local video from Mac or Windows for easy play on HDTV or TV at http://www.idealshare.net/video-convert ... i-mp4.html

It can help to:

Stream Charomacast unsupported local video files like MKV, AVI, MP4, Apple ProRes, MOV, FLV, VOB, DAV, MPG, MXF, AVCHD, WTV, WMV, ASF, RMVB from Windows or Mac to Chromecast (Refer to Part 1 and Part 2).
Stream Charomecast incompatible audio files like FLAC, DTS, AIFF, APE, WAV, WMA, Apple Lossless, M4A, OGG, CAF and etc from computer to Chromecast (Refer to Part 1 and Part 2).
Stream Charomecast supported video or audio from computer to Chromecast (Only refer to Part 2).

This involves a manual process, which I'm not a huge fan of.

UMS will, evenetually, be able to convert the video on the fly, and present it to chromecast. i just have to wait for the codec to be fixed from either Subjunks build of mplayer or from the main build of mplayer.

Post Reply