Help us improve support for your devices

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
SVMartin
Posts: 13
Joined: Tue Jul 21, 2020 9:50 am

Re: Help us improve support for your devices

Post by SVMartin » Tue Jul 21, 2020 5:32 pm

Attached a first version of a renderer file for Yamaha RX-V479 AV-receiver.

Any tips how I can improve the supported audio codecs?
Attachments
Yamaha-RXV479.conf
(1.98 KiB) Downloaded 123 times

SVMartin
Posts: 13
Joined: Tue Jul 21, 2020 9:50 am

Re: Help us improve support for your devices

Post by SVMartin » Wed Jul 22, 2020 6:19 am

Trace logs contains the following, is this the list that I could (should? must?) add to the renderer config?

Code: Select all

TRACE 2020-07-21 18:05:29.561 [cling-96] Received GetProtocolInfo from "Receiver": 
Sink:
  http-get:*:audio/L16;channels=2;rate=44100:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=44100:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=48000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=48000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=32000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=32000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=88200:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=88200:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=96000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=96000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=64000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=64000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=22050:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=22050:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=24000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=24000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=16000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=16000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=11025:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=11025:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=12000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=12000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=2;rate=8000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16;channels=1;rate=8000:DLNA.ORG_PN=LPCM
  http-get:*:audio/L16:DLNA.ORG_PN=LPCM
  http-get:*:audio/mpeg:DLNA.ORG_PN=MP3
  http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMABASE
  http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMAFULL
  http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMDRM_WMABASE
  http-get:*:audio/x-ms-wma:DLNA.ORG_PN=WMDRM_WMAFULL
  http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS
  http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS_192
  http-get:*:audio/vnd.dlna.adts:DLNA.ORG_PN=AAC_ADTS_320
  http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO
  http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO_192
  http-get:*:audio/mp4:DLNA.ORG_PN=AAC_ISO_320
  http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO
  http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO_192
  http-get:*:audio/3gpp:DLNA.ORG_PN=AAC_ISO_320
  http-get:*:audio/x-ms-wma:*
  http-get:*:audio/vnd.dlna.adts:*
  http-get:*:audio/x-flac:*
  http-get:*:audio/x-mpeg:*
  http-get:*:audio/x-aac:*
  http-get:*:audio/x-mp3:*
  http-get:*:audio/x-mp4:*
  http-get:*:audio/x-mpg:*
  http-get:*:audio/x-wav:*
  http-get:*:audio/3gpp:*
  http-get:*:audio/aacp:*
  http-get:*:audio/aiff:*
  http-get:*:audio/x-aiff:*
  http-get:*:audio/flac:*
  http-get:*:audio/mpeg:*
  http-get:*:audio/aac:*
  http-get:*:audio/m4a:*
  http-get:*:audio/mp3:*
  http-get:*:audio/mp4:*
  http-get:*:audio/dsd:*
  http-get:*:audio/x-dsd:*
  http-get:*:audio/x-dsf:*
  http-get:*:audio/x-dff:*
  http-get:*:audio/wav:*

RoyalScam
Posts: 1
Joined: Sat Aug 29, 2020 9:49 am

Re: Help us improve support for your devices

Post by RoyalScam » Sat Aug 29, 2020 9:58 am

Hello,

I've set up UMS on my MacBook Pro to run a server to connect to my Onkyo receiver. UMS sees the Onkyo just fine, and I can connect and play audio via their very rudimentary Remote3 iOS app.

What I'd prefer to do is run foobar2000 Mobile on my iPhone, access Universal Media Server, and use that to feed my Onkyo via AirPlay. I can get foobar2000 Mobile to open and recognize UMS and my music folders, but in UMS it's showing as Unknown Renderer. Does that matter and how can I fix that? (Sorry if this is a stupid question, I'm just now diving into this stuff.)

This is what I'm seeing in the logs, and zip file is attached.
17:43:08 INFO Media renderer was not recognized. Possible identifying HTTP headers:
User-Agent: foobar2000-mobile/1.x
17:43:11 INFO Media renderer was not recognized. Possible identifying HTTP headers:
User-Agent: foobar2000-mobile/1.x
Icy-MetaData: 1
17:43:11 INFO Started playing 01 Say You'll Be Mine.flac on your Unknown renderer
17:43:34 INFO Stopped playing 01 Say You'll Be Mine.flac on Unknown renderer
Attachments
ums_dbg_2020-08-28-17-42.zip
(32.42 KiB) Downloaded 93 times

User avatar
SubJunk
Lead Developer
Posts: 3283
Joined: Sun May 27, 2012 4:12 pm

Re: Help us improve support for your devices

Post by SubJunk » Sun Oct 04, 2020 12:42 pm

Hi guys,
I'm going to close this thread since it is quite difficult to add good support for everything in the same thread. From now on please make a new thread for each media renderer and then it will be easier to help

Locked