Vizio Smart TVs

Discuss media renderers like Xbox 360, TVs, smartphones, etc.
Ranger187
Posts: 72
Joined: Sun Jun 03, 2012 12:11 am
Contact:

Re: Vizio Smart TVs

Post by Ranger187 » Sat Apr 26, 2014 1:15 pm

Update bump....

And here's more info from some TvMobili Nazi that always bumps their product over on PMS's site... maybe it will help in debugging.
Postby Jackie1 » Sun Dec 01, 2013 4:16 pm

Just trying to help so you know why this is happening. Below I'm quoting some stuff from how we got the other program to week with every file. Most people that download ps3 media server aren't going to mess with all these config files. I hope this will help for an end solution...

Transcoding on-the-fly is a very delicate operation because the transcoder has to process every frame that it handles and is therefore normally only a few seconds ahead of the play head on your device. The MPEG-PS container allows the device to start playing the movie, even though we are still transcoding. If this did not happen you would have a 1 or 2 hour wait before the movie started due to us having to wait until the whole transcode finished.

In all the logs that I have seen from Visio customers, the TV requests a few chunks of data right at the start of the file which kicks the transcode process off. After a few seconds it then requests a chunk of data right from the very end of the file! at this point we say that we cannot possibly service that request because the transcoder is nowhere near that point of the file and the wait time would be large.

All other devices Sony, Samsung etc. etc. request small, incremental chunks of data that are always behind the transcoder write head, meaning that we can always service that request. We have a spoofing mechanism in place that just generates random data when the device requests it at the end of the file and I think that it is this random data that is causing the issue.

The mechanic of the streaming is what is breaking the transcoding, not the actual format of the files.

Vizio is not the only ones who act like this, there are a couple more but, the vast majority behave correctly. That is why we built the 'back door' into the tvmobili media server for clients that do behave this way.

User avatar
DeFlanko
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: Vizio Smart TVs

Post by DeFlanko » Sat Apr 26, 2014 2:42 pm

Ranger187 wrote:Update bump....

And here's more info from some TvMobili Nazi that always bumps their product over on PMS's site... maybe it will help in debugging.
Postby Jackie1 » Sun Dec 01, 2013 4:16 pm

Just trying to help so you know why this is happening. Below I'm quoting some stuff from how we got the other program to week with every file. Most people that download ps3 media server aren't going to mess with all these config files. I hope this will help for an end solution...

Transcoding on-the-fly is a very delicate operation because the transcoder has to process every frame that it handles and is therefore normally only a few seconds ahead of the play head on your device. The MPEG-PS container allows the device to start playing the movie, even though we are still transcoding. If this did not happen you would have a 1 or 2 hour wait before the movie started due to us having to wait until the whole transcode finished.

In all the logs that I have seen from Visio customers, the TV requests a few chunks of data right at the start of the file which kicks the transcode process off. After a few seconds it then requests a chunk of data right from the very end of the file! at this point we say that we cannot possibly service that request because the transcoder is nowhere near that point of the file and the wait time would be large.

All other devices Sony, Samsung etc. etc. request small, incremental chunks of data that are always behind the transcoder write head, meaning that we can always service that request. We have a spoofing mechanism in place that just generates random data when the device requests it at the end of the file and I think that it is this random data that is causing the issue.

The mechanic of the streaming is what is breaking the transcoding, not the actual format of the files.

Vizio is not the only ones who act like this, there are a couple more but, the vast majority behave correctly. That is why we built the 'back door' into the tvmobili media server for clients that do behave this way.
go buy a Sammy; solve world headaches :lol:

Ranger187
Posts: 72
Joined: Sun Jun 03, 2012 12:11 am
Contact:

Re: Vizio Smart TVs

Post by Ranger187 » Sat Apr 26, 2014 3:38 pm

I have one on the kitchen. ;)

Ranger187
Posts: 72
Joined: Sun Jun 03, 2012 12:11 am
Contact:

Re: Vizio Smart TVs

Post by Ranger187 » Fri May 23, 2014 9:21 am

Bump for any progress??????

I submitted a ticket months ago. ;)

ziekko
Posts: 2
Joined: Thu Jan 02, 2014 8:24 am

Re: Vizio Smart TVs

Post by ziekko » Sat May 31, 2014 2:39 am

same here, is there any additional testing that needs to be done? I have some free time this coming weekend and would be happy to do dedicate some time to testing.

Starrion
Posts: 9
Joined: Wed Jan 01, 2014 4:57 am

Re: Vizio Smart TVs

Post by Starrion » Thu Oct 02, 2014 8:43 am

Any more info on this? I am getting the same results with the Vizio E600i-B3.

Starrion
Posts: 9
Joined: Wed Jan 01, 2014 4:57 am

Re: Vizio Smart TVs

Post by Starrion » Fri Oct 03, 2014 12:11 am

I gave TVmobili a try last night and it worked. I was able to browse folders and video's on my Vizio TV without issue.
I honestly was not expecting it to work.

Another thing that was impressive was viewing the files from my PS3. On UMS it takes a while to load the file list and display the thumbnails.
On TVmobili it was actually pretty quick. The downside was that I could not get DTS to work. It outputted the audio as DD5.1 instead.
I have not played on their forum yet to see if this can be corrected. The other issue is that about 10-15 percent of movies i tried would not play.

Both UMS and TVmobili run side by side so this may be my backup option until UMS can resolve it.

xbones
Posts: 4
Joined: Fri May 30, 2014 1:21 pm

Re: Vizio Smart TVs

Post by xbones » Tue Oct 28, 2014 6:28 pm

bump.. common Vizio Smart TV M series FIX!

Ranger187
Posts: 72
Joined: Sun Jun 03, 2012 12:11 am
Contact:

Re: Vizio Smart TVs

Post by Ranger187 » Tue Dec 09, 2014 7:16 am

Bump...................................

inspirat
Posts: 2
Joined: Tue Mar 31, 2015 8:31 am

Re: Vizio Smart TVs

Post by inspirat » Tue Mar 31, 2015 8:32 am

Bump, would love to see a fix for this.

Post Reply