Jumpy Plugin (26 October 2016)

Discuss third party additions, plugins and translations for Universal Media Server
Casper
Posts: 32
Joined: Wed Jul 24, 2013 10:20 pm

Re: Jumpy Plugin (7 August 2013)

Post by Casper » Thu Sep 26, 2013 11:37 pm

infidel wrote: btw do you see the 'Bookmark added/deleted' video messages on the Panasonic too?.
My Panasonic does not play the bookmark videos, it just briefly shows the standard Panasonic 'Please wait' message.

UMS 3.0.0-a5 + Jumpy 0.2.9 working great and running hot. 8-)

User avatar
S7eele
Posts: 104
Joined: Thu Jun 07, 2012 8:12 am

Re: Jumpy Plugin (14 September 2013)

Post by S7eele » Fri Oct 04, 2013 12:03 pm

infidel wrote:
S7eele wrote:The problem with the Jumpy messages not working was using a PS3 ... it fails the first try but works correctly thereafter
Thanks S7eele, very useful :) . When you get a chance please attach a TRACE log.
I will provide the logs you need for the situation discussed in the above posts but I wanted to drop by real quick and say that overall things are working better than they have in a long while for me. I verified that the behavior discussed above still exists on my PS3 but I want to test on my Bravia and see what happens there so I can include those logs as well. One other thing I found related to that issue is that it doesn't work everytime after the first try, it actually alternates between failing and working for as long as I tested).

Basically this is just a thanks for all the hard work, UMS 3.0.0 -a5 with Jumpy 0.2.9 and XBMC (Frodo) working quite well.

I will return for other stuff.
Peace!

blazejwiecha
Posts: 2
Joined: Thu Oct 17, 2013 6:18 am

Re: Jumpy Plugin (14 September 2013)

Post by blazejwiecha » Thu Oct 17, 2013 6:25 am

Hello
I've installed jumpy to my ps3 media server and universal media server. Problem is that i want to watch weeb.tv through xbmc
Channels are showing , and first 3 secounds i can watch, next I got pause , and there is no way to play it
Is there any way to resolve this problem ?
all software is up to date

sorry for my english!

I've tried everythink. weeb.tv via this jumpy runs only on 0.2.7 version :( 0.2.8 stops all the time video

infidel
Developer
Posts: 571
Joined: Thu Jul 12, 2012 5:37 am

Re: Jumpy Plugin (14 September 2013)

Post by infidel » Thu Oct 17, 2013 3:35 pm

blazejwiecha wrote:i want to watch weeb.tv through xbmc. Channels are showing , and first 3 secounds i can watch, next I got pause , and there is no way to play it. Is there any way to resolve this problem ?
Hi blazejwiecha, I just tested the weeb.tv addon and it works ok for me in both Windows and linux (UMS 3.0.0-a5, jumpy 0.2.9). Please
  • Do a fresh up-to-date install of UMS and jumpy.
  • Attach a set of TRACE logs showing whatever navigation/playback is possible in weeb.tv.

Agiz
Posts: 2
Joined: Mon Oct 21, 2013 10:20 pm

Re: Jumpy Plugin (14 September 2013)

Post by Agiz » Mon Oct 21, 2013 10:41 pm

Hey there,

i am trying to install Jumpy on my Mac OSX 10.8 since friday ! But i am not able to run it or install it correctly.
I've placed the jumpy.run in my UMS Plugins folder ~User/Applications/Universal\ Media\ Server.app/Contents/Resources/Java/plugins
made it in terminal with

Code: Select all

chmod +x
executable and run it finally with

Code: Select all

sudo sh
.
there were a few error i.e. lmxl and imagemagick

Code: Select all

Name:~ USERNAME$ sudo sh /Applications/Universal\ Media\ Server.app/Contents/Resources/Java/plugins/jumpy-0.2.9.run
Password:
Verifying archive integrity... All good.
Uncompressing Jumpy Plugin for PMS/UMS......................................................................................................................................................
+ permissions are ok
+ jumpy-0.2.9.jar is installed
found UMS.conf: /Users/USERNAME/Library/Application Support/UMS/UMS.conf
checking python
Python 2.7.2
setting python.path = /usr/bin/python
+ python is installed
checking py4j
+ py4j is installed
checking py4j version
0.8
checking beautifulsoup4
+ beautifulsoup4 is installed
checking lxml
installing lxml
need admin rights to install lxml
Searching for lxml
Reading http://pypi.python.org/simple/lxml/
Best match: lxml 3.2.3
Downloading https://pypi.python.org/packages/source/l/lxml/lxml-3.2.3.tar.gz#md5=fef47bb4ac72ac38ce778518dac42236
Processing lxml-3.2.3.tar.gz
Running lxml-3.2.3/setup.py -q bdist_egg --dist-dir /tmp/easy_install-QnE9ut/lxml-3.2.3/egg-dist-tmp-M7ajO3
Building lxml version 3.2.3.
Latest version of libiconv is 1.14
Downloading libiconv into libs/libiconv-1.14.tar.gz
Unpacking libiconv-1.14.tar.gz into build/tmp
Latest version of libxml2 is 2.9.1
Downloading libxml2 into libs/libxml2-2.9.1.tar.gz
Unpacking libxml2-2.9.1.tar.gz into build/tmp
Latest version of libxslt is 1.1.28
Downloading libxslt into libs/libxslt-1.1.28.tar.gz
Unpacking libxslt-1.1.28.tar.gz into build/tmp
Starting build in build/tmp/libiconv-1.14
Running "./configure --disable-dependency-tracking --disable-shared --prefix=/private/tmp/easy_install-QnE9ut/lxml-3.2.3/build/tmp/libxml2" in build/tmp/libiconv-1.14
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... build-aux/install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... no
checking whether make sets $(MAKE)... (cached) no
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/private/tmp/easy_install-QnE9ut/lxml-3.2.3/build/tmp/libiconv-1.14':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details
Traceback (most recent call last):
  File "/usr/bin/easy_install-2.7", line 10, in <module>
    load_entry_point('setuptools==0.6c12dev-r88846', 'console_scripts', 'easy_install')()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 1712, in main
    with_ei_usage(lambda:
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 1700, in with_ei_usage
    return f()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 1716, in <lambda>
    distclass=DistributionWithoutHelpCommands, **kw
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/core.py", line 152, in setup
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 953, in run_commands
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py", line 972, in run_command
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 211, in run
    self.easy_install(spec, not self.no_deps)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 446, in easy_install
    return self.install_item(spec, dist.location, tmpdir, deps)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 476, in install_item
    dists = self.install_eggs(spec, download, tmpdir)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 655, in install_eggs
    return self.build_and_install(setup_script, setup_base)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 930, in build_and_install
    self.run_setup(setup_script, setup_base, args)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/command/easy_install.py", line 919, in run_setup
    run_setup(setup_script, args)
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/sandbox.py", line 62, in run_setup
    lambda: execfile(
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/sandbox.py", line 105, in run
    return func()
  File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/setuptools/sandbox.py", line 64, in <lambda>
    {'__file__':setup_script, '__name__':'__main__'}
  File "setup.py", line 218, in <module>
  File "setup.py", line 130, in setup_extra_options
  File "/tmp/easy_install-QnE9ut/lxml-3.2.3/setupinfo.py", line 57, in ext_modules
  File "/tmp/easy_install-QnE9ut/lxml-3.2.3/buildlibxml.py", line 329, in build_libxml2xslt
  File "/tmp/easy_install-QnE9ut/lxml-3.2.3/buildlibxml.py", line 257, in cmmi
  File "/tmp/easy_install-QnE9ut/lxml-3.2.3/buildlibxml.py", line 249, in call_subprocess
Exception: Command "./configure --disable-dependency-tracking --disable-shared --prefix=/private/tmp/easy_install-QnE9ut/lxml-3.2.3/build/tmp/libxml2" returned code 256
checking lxml
Warning : unable to install lxml
checking xbmc
+ xbmc is installed
adding jumpy repo
checking rtmpdump
RTMPDump 2.4
setting rtmpdump.path = rtmpdump
+ rtmpdump is installed
checking phantomjs
Installing phantomjs
downloading https://phantomjs.googlecode.com/files/phantomjs-1.9.1-macosx.zip
######################################################################## 100,0%
Installing to /Users/osx
checking phantomjs
1.9.1
+ phantomjs is installed
checking youtube-dl
downloading http://youtube-dl.org/downloads/2013.10.18.2/youtube-dl-2013.10.18.2.tar.gz
######################################################################## 100,0%
Installing to /Users/osx
checking youtube-dl
2013.10.18.2 2013.10.18.2
setting youtube-dl.lib.path = /Users/osx/youtube_dl
+ youtube-dl is installed
checking imagemagick convert
Installing imagemagick
downloading http://www.imagemagick.org/download/binaries/ImageMagick-x86_64-apple-darwin12.4.0.tar.gz

curl: (22) The requested URL returned error: 404
Installing to /Users/osx
./jumpy/setup/setup.sh: line 885: /Users/osx/convert: No such file or directory
chmod: /Users/osx/convert: No such file or directory
checking imagemagick convert
Warning : problem installing imagemagick - see /Users/USERNAME/jumpy/setup/setup.log
backing up and replacing UMS.conf
+ done

Warning : some items were not installed
see '/Users/USERNAME/jumpy/setup/setup.log'
Here is my jumpy setup log:

Code: Select all

Mo 21 Okt 2013 12:32:50 CEST
jumpy setup 2.2 - mode: installer

Darwin USERNAME-MacBook-Pro-2.local 12.5.0 Darwin Kernel Version 12.5.0: Sun Sep 29 13:33:47 PDT 2013; root:xnu-2050.48.12~1/RELEASE_X86_64 x86_64
PMSDIR=/Users

server_ip=192.168.2.102
jumpy-0.2.9.jar is installed

files:
.
./.DS_Store
./debug.log
./jumpy-scripts.diff
./quickpatch.py
./repository.jumpy.addons-1.0.0.zip
./script.module.jumpy-2.0.0.zip
./setup.log
./setup.sh

found UMS.conf: /Users/USERNAME/Library/Application Support/UMS/UMS.conf
search path=/Users/osx:

checking python
Python 2.7.2
setting python.path = /usr/bin/python
python is installed

checking py4j
py4j is installed
checking py4j version
0.8

checking beautifulsoup4
beautifulsoup4 is installed

checking lxml
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named lxml
installing lxml
need admin rights to install lxml
checking lxml
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named lxml
Warning : unable to install lxml

checking xbmc
	identifier:    com.teamxbmc.xbmc (0x800117d3)
xbmc is installed

adding jumpy repo
Archive:  script.module.jumpy-2.0.0.zip
  inflating: /Users/USERNAME/Library/Application Support/XBMC/addons/script.module.jumpy/addon.xml  
Archive:  repository.jumpy.addons-1.0.0.zip
  inflating: /Users/USERNAME/Library/Application Support/XBMC/addons/repository.jumpy.addons/addon.xml  

checking rtmpdump
RTMPDump 2.4
setting rtmpdump.path = rtmpdump
rtmpdump is installed

checking phantomjs
./jumpy/setup/setup.sh: line 770: phantomjs: command not found
Installing phantomjs
downloading https://phantomjs.googlecode.com/files/phantomjs-1.9.1-macosx.zip
Archive:  phantomjs-1.9.1-macosx.zip
  inflating: phantomjs-1.9.1-macosx/bin/phantomjs  
Installing to /Users/osx
checking phantomjs
1.9.1
phantomjs is installed

checking youtube-dl
2013.10.18.2
downloading http://youtube-dl.org/downloads/2013.10.18.2/youtube-dl-2013.10.18.2.tar.gz
Installing to /Users/osx
checking youtube-dl
2013.10.18.2
OK 2013.10.18.2
setting youtube-dl.lib.path = /Users/osx/youtube_dl
youtube-dl is installed

checking imagemagick convert
./jumpy/setup/setup.sh: line 861: convert: command not found
Installing imagemagick
downloading http://www.imagemagick.org/download/binaries/ImageMagick-x86_64-apple-darwin12.4.0.tar.gz
download error
Installing to /Users/osx
mv: rename  to /Users/osx/: No such file or directory
checking imagemagick convert
./jumpy/setup/setup.sh: line 861: convert: command not found
Warning : problem installing imagemagick - see /Users/USERNAME/jumpy/setup/setup.log

backing up and replacing UMS.conf
removing  phantomjs-1.9.1-macosx.zip phantomjs-1.9.1-macosx youtube-dl-2013.10.18.2.tar.gz youtube-dl ImageMagick-x86_64-apple-darwin12.4.0.tar.gz 
done

Warning : some items were not installed
see '/Users/USERNAME/jumpy/setup/setup.log'
do you need some more informations to help me ?
thank you for your advice in advance !!

infidel
Developer
Posts: 571
Joined: Thu Jul 12, 2012 5:37 am

Re: Jumpy Plugin (14 September 2013)

Post by infidel » Tue Oct 22, 2013 2:35 am

Agiz wrote:there were a few error i.e. lmxl and imagemagick
Hi Agiz :). jumpy should be mostly functional without these two packages, but here's what you can do:
  • lxml requires a c compiler (gcc) for setup, which you appear to be missing. To install gcc on OSX have a look here.
  • imagemagick is continually updating its binaries and the urls expire, alas. If you open up plugins/jumpy/setup/setup.sh and fix the package version in line 875 it should work:
    pkg=ImageMagick-x86_64-apple-darwin12.5.0.tar.gz
    Note: run setup.sh from its own directory in Terminal after making this change.

Agiz
Posts: 2
Joined: Mon Oct 21, 2013 10:20 pm

Re: Jumpy Plugin (14 September 2013)

Post by Agiz » Tue Oct 22, 2013 5:41 am

Hey infidel

everything is now installed, but i noticed that my jumpy folder is not in the plugins folder you mentioned !
and the plugin still is not appearing in the UMS app...

what am i doing wrong ?! should i drag the jumpy folder into my plugins folder ?

edit:
i drag it into the plugins folder and voila there it is ! hopefully its functional as it should be ! :D
thanks !

blazejwiecha
Posts: 2
Joined: Thu Oct 17, 2013 6:18 am

Re: Jumpy Plugin (14 September 2013)

Post by blazejwiecha » Tue Oct 22, 2013 9:36 am

infidel wrote:
blazejwiecha wrote:i want to watch weeb.tv through xbmc. Channels are showing , and first 3 secounds i can watch, next I got pause , and there is no way to play it. Is there any way to resolve this problem ?
Hi blazejwiecha, I just tested the weeb.tv addon and it works ok for me in both Windows and linux (UMS 3.0.0-a5, jumpy 0.2.9). Please
  • Do a fresh up-to-date install of UMS and jumpy.
  • Attach a set of TRACE logs showing whatever navigation/playback is possible in weeb.tv.
Ok
I will add some logs if this will occur i 0.3.0 :)
I really don't want to change all the settings again. And i wait for 0.3.0 :)

nomi2013
Posts: 30
Joined: Thu Sep 12, 2013 12:45 am

Re: Jumpy Plugin (14 September 2013)

Post by nomi2013 » Wed Oct 23, 2013 1:53 am

Hi Infidel
I want to ask you which version of jumpy is compatible with PMS server, I tried latest version (0.2.9) but it shows folder but when go into it shows message "No items found" but know there are items as can play with XBMC.. I also tried 0.2.4 but no success can you attached the version or URL for PMS latest build compatible jumpy version?
I am also using UMS with latest jumpy but had issue with voice and now lately TV restarting itself which I post in another post and trying to figure it out.. :)
nouman

infidel
Developer
Posts: 571
Joined: Thu Jul 12, 2012 5:37 am

Re: Jumpy Plugin (14 September 2013)

Post by infidel » Wed Oct 23, 2013 4:03 am

nomi2013 wrote:which version of jumpy is compatible with PMS server
Afaik any version, I just checked jumpy-0.2.9 + PMS 1.90.1 (in linux) and everything was normal. As usual post logs if you're having a problem :).

Post Reply