Channels Plugin

Discuss third party additions, plugins and translations for Universal Media Server
User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Channels Plugin

Post by SharkHunter » Wed Feb 20, 2013 7:35 pm

lastmoexit wrote:so, as i understand it then furk, tpb, ard, etc. are there just to browse the sites themselves? ...i am unable to actually watch the content on them? ...they are only for reference? ...thanks ...peace

-lastmoexit
Nope they are "real" channels that you can browse and actually stream from without getting out of the couch BUT they are "meta" channels (tpb,eztv) in the sense that there is another channel that does all the streaming a channel that lacks the "browse" function. Look into the .ch file and search for the keyword switch.
kuroukage wrote:I understand your explanation in reference as to what channels do what. I'm just wondering if you plan on fixing any of the channels (mentioned above) that are having issues and making them work properly again (such as 1ch, RTMPGUI, Icefilms)? If not (or it's not possible to) then why not just remove them from the channels folder (so people don't get confused)?
Like I said I can't keep up with all the channles of the word. SOme of the channels are authored by other people as well. IceFIlms DO work at least the 180upload links.
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

User avatar
kuroukage
Posts: 304
Joined: Wed Dec 12, 2012 3:56 pm

Re: Channels Plugin

Post by kuroukage » Wed Feb 20, 2013 7:47 pm

SharkHunter wrote:Like I said I can't keep up with all the channles of the word. SOme of the channels are authored by other people as well. IceFIlms DO work at least the 180upload links.
So are you saying that you'll maintain the plugin, but you expect other people to write/maintain the channel files?
黒影
_______________________________________________|_._._._._._._._._._
\______________________________________________|_#_#_#_#_#_#_|
------------------------------------------------------------------|---------------------

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Channels Plugin

Post by SharkHunter » Wed Feb 20, 2013 8:00 pm

kuroukage wrote:
SharkHunter wrote:Like I said I can't keep up with all the channles of the word. SOme of the channels are authored by other people as well. IceFIlms DO work at least the 180upload links.
So are you saying that you'll maintain the plugin, but you expect other people to write/maintain the channel files?
No I maintain most (all) channels but I don't use all channels, thus if 1channel changes something and I don't use it it might take a while before it's fixed. And in the meantime I don't remove it because that wold be as hard as fixing it. I don't have time to go through all channels each release.

As a note a fileshare suffer from links coming and going. If your unlucky you hit a dead link...
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Channels Plugin

Post by SharkHunter » Thu Feb 21, 2013 6:42 am

Hi,

I updated both the plugin and 1channel. 1channel worked for the Tvseries but not the movies. Now both works.
I also added a new feature to the plugin which allows scrapers to detect "bad" links (which is implemented for putlocker in te new channels). If you hit a "bad" link you'll see the UMS red X on your render.
For example Skyfall which was tried in some logs seen here has all links dead. Note also that Channels don't support all fileshares on 1channel.

Edit. This is what happends once in awhile http://forum.wiziwig.eu/threads/58518-r ... ost1564198
Now this occured 1-2 months ago and since no one informed me I don't know.
Will it be removed? Who knows maybe?
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

User avatar
kuroukage
Posts: 304
Joined: Wed Dec 12, 2012 3:56 pm

Re: Channels Plugin

Post by kuroukage » Thu Feb 21, 2013 8:17 pm

SharkHunter wrote:I updated both the plugin and 1channel. 1channel worked for the Tvseries but not the movies. Now both works.
I tested some TV episodes and I ran into the folder issue with those. Where you see the links (for the websites) and you click on the folder and it does nothing (wont show you a link to click on because you can't get inside the folder). Is this an issue with folder depth that can't be fixed? I was however able to get links for the movies folder.

Also, are there plans to fix/update RTMPGUI and RTMPList? Or are those plugins dead for good now?

As for the Youtube channel...do you plan to update that (so it will work with PMSE off)? I also notice that for subscriptions it only lists a minimal amount of folders (in non alphabetical order) and that when you enter a subscription folder it only lists a minimal amount of videos to play. Would it be possible to update this channel as well (so that more folders will show up and that subscription folders will be in ABC order)?

Thanks,
黒影
_______________________________________________|_._._._._._._._._._
\______________________________________________|_#_#_#_#_#_#_|
------------------------------------------------------------------|---------------------

tubby
Posts: 9
Joined: Wed Feb 27, 2013 7:06 pm

Re: Channels Plugin

Post by tubby » Wed Feb 27, 2013 7:21 pm

First of all, great work with the channels plugin! :-) Currently trying to getting it to work, but when I have it working I am planning to work on some channels files.

I'm running Kubuntu 64-bit and I have looked in the forums for some pointers but could not find any. If this is the wrong place for questions please redirect me. I have attached the debug-package.

I have tried several channels, svtplay, kanal5, tv6, tv8 and they all results in UMS not being able to transcode. Watching DVD-isos, avi and so forth is working from the local disk on my renderers.

When looking at the debug.log I can see
There is no inputstream to return for PLAY
I tried running the mencoder command displayed in the debug.log manually on the command-line but I get the error
No stream to handle url rtmpdump:// ....
Any ideas? I have installed mencoder, mediainfo, ia32-libs and ubuntu-restricted-extras packages.
Attachments
ums_dbg.zip
(225.13 KiB) Downloaded 228 times

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Channels Plugin

Post by SharkHunter » Wed Feb 27, 2013 7:43 pm

Hi Tubby,

svt and viasat are the most used channels in my household so they work :).

Now you use 2.06 on linux which means you have to do some more hard work yourself.
You are missing rtmpdump and curl in your install.

Download those (mostly you need rtmpdump) and set "rtmpdump.path=xxx" in your UMS.conf.
or upgrade to 2.14 which should make use of ffmpeg for rtmpstreams.

Linux don't like unquoted urls with & in them. I think the ffmpegvideo can handle this.
Try and remove pmsencoder (just move the jar file out of the plugins dir) and then in the gui move FFMPEGwebvideo to the top of webvideo and try again (using 2.14 here as well)
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

tubby
Posts: 9
Joined: Wed Feb 27, 2013 7:06 pm

Re: Channels Plugin

Post by tubby » Thu Feb 28, 2013 2:14 am

SharkHunter wrote:Hi Tubby,

svt and viasat are the most used channels in my household so they work :).
It is the same in our household :-D
Now you use 2.06 on linux which means you have to do some more hard work yourself.
You are missing rtmpdump and curl in your install.
Is there a curl, config too? "curl.path"?
Linux don't like unquoted urls with & in them. I think the ffmpegvideo can handle this.
Hmm, yes that is true when running on the cmd-line, which is the way of Linux sometimes :-D. The & is coming from what part of the transcoding, pmsencoder, UMS or Channels scripts? Sorry for the newb-questions but I am familiar with Java so i might be able to tweak it myself.

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Channels Plugin

Post by SharkHunter » Thu Feb 28, 2013 2:21 am

Yes there is a "curl.path".

The & should really be fixed in the pmsencoder scripts. I thought it was.

But then SVT swapped from rtmp to hls a while ago. And hls links are perhaps not quoted.

I'll look at the scripts again.
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

User avatar
SharkHunter
Developer
Posts: 669
Joined: Fri Jun 01, 2012 9:36 pm

Re: Channels Plugin

Post by SharkHunter » Thu Feb 28, 2013 8:00 pm

My system crashed and I have been meaning to upgrade it so have been offline doing so for some time now. Need to install latest UMS and Channels versions, excited to see how far everything has come and glad to be back. Looks like a lot of work has been done, as always it is much appreciated.

To verify latest versions t be used - UMS-2.4.2 with tv_plug_216.jar and channels_211.zip?
Since 2.12 there is no more channels_xxx.zip instead the .ch files and scripts are fetched directly from github. It's simpler that way. Since 2.12 the channels.pmsencoder cfg has been introduced and if you need to use pmsencoder you must (manually) set this to true. In the future UMS/fmmpeg can cope with "all" videos without pmsencoder...
We reject: kings, presidents and voting.
We believe in: rough consensus and running code.

Post Reply