Version 3.0.0-a4 is released

Announcements about Universal Media Server
Post Reply
User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Version 3.0.0-a4 is released

Post by SubJunk » Sun Sep 01, 2013 7:27 pm

General:

This improves iTunes support, filename prettifying, video playback stability and fixes many important bugs!


Download:

Windows
Linux
OS X


Changes since 3.0.0-a3:
  • General:
    • Improved support for iTunes compilations
    • Added support for external subtitles in VLC
    • Expanded and fixed filename prettifying
    • Made video playback more stable
    • Fixed support for non-English iTunes libraries
    • Fixed external ASS/SSA support (Thanks, skeptical!)
    • Fixed FFmpeg muxing on non-PS3 renderers
    • Fixed use of custom Java Heapsize (Thanks, OptimusPrime!)
    • Fixed VLC audio/subtitle language selection
    • Fixed streaming radio timing out after 1:45:32
    • Fixed MEncoder subtitle support when the font name contains a space
    • Run the program in Java's server mode when using 64-bit JRE
  • Renderers:
    • Added support for Bravia W series TVs
    • Improved support for KalemSoft Media Player on BlackBerry PlayBook
  • Languages:
    • Updated French translation
    • Updated Spanish translation (thanks, AlfredoRamos!)
  • External Components:
    • Updated Apache Commons Codec to 1.8
    • Updated Checkstyle to 2.10
    • Updated Cobertura Maven Plugin to 2.5.2
    • Updated FindBugs Maven Plugin to 2.5.2
    • Updated Gson to 2.2.4
    • Updated H2 Database Engine to 1.3.172
    • Updated JBoss APIviz to 1.3.2
    • Updated jgoodies-forms to 1.6.0
    • Updated jgoodies-looks to 2.5.2
    • Updated JUnit to 4.11
    • Updated Logback to 1.0.13
    • Updated Maven Project Info Reports to 2.7
    • Updated Maven Source Plugin to 2.2.1
    • Updated Maven Surefire to 2.15
    • Updated PMD Maven Plugin to 3.0.1
    • Updated slf4j to 1.7.5
    • Updated Thumbnailator to 0.4.5, which:
      • Fixes use of Exif orientation
    • Updated xmlwise to 1.2.11

Upgrade Notes:

For all versions:
Some configuration options for 3.x are not compatible with the 2.x releases, and a lot of them were renamed between 3.0.0-a1 and 3.0.0-a2, so it may be wise to make a backup of your configuration before installing.
It is recommended (but usually not necessary) to delete your UMS.conf file prior to installing this version. Windows users can choose the "clean install" option while installing instead.

Wolfgan
Posts: 371
Joined: Fri Feb 08, 2013 12:33 am

Re: Version 3.0.0-a4 is released

Post by Wolfgan » Mon Sep 02, 2013 2:32 am

Thx Subjunk. I just installed a4 over my previous a3 installation, and the following error msg appeared:
"Error: missing 'server' at 'C:\[path]\jre7\bin\server\jvm.dll' Please install or use JRE or JDK that contains these missing components."

Anyone observing the same? Wolf.
-- UMS serving PS3, WDTV, Samsung H6400 + J5500 and Kalemsoft renderers! (no video transcoding but remuxing accepted :D )

leocheine
Posts: 6
Joined: Mon Sep 02, 2013 3:01 am

Re: Version 3.0.0-a4 is released

Post by leocheine » Mon Sep 02, 2013 3:06 am

I have a bug, already installed JRE and JDK "Error: missing 'server' at 'C: \ [path] \ jre7 \ bin \ server \ jvm.dll' Please install or use JRE or JDK that contains these missing components. "but not decided what do I do??

I'm from Brazil sorry my english.

leocheine
Posts: 6
Joined: Mon Sep 02, 2013 3:01 am

Re: Version 3.0.0-a4 is released

Post by leocheine » Mon Sep 02, 2013 3:09 am

oh and this occurred after updating, the old version was working fine.

Thanks!

User avatar
DeFlanko
Moderator
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: Version 3.0.0-a4 is released

Post by DeFlanko » Mon Sep 02, 2013 4:00 am

Before any install, make sure your wrapper and java executables are stopped. Also if you have UMS running as a service, make sure that's stopped too.

User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.0.0-a4 is released

Post by SubJunk » Mon Sep 02, 2013 9:44 am

Thanks for reporting the bug guys. I will release a5 soon to fix that.

Madoka
Posts: 316
Joined: Fri Jun 01, 2012 12:51 pm

Re: Version 3.0.0-a4 is released

Post by Madoka » Mon Sep 02, 2013 11:33 am

Hmm, I'm running 64-bit Java on a 64-bit Win7 box, and a4 works as expected. I didn't get any Java errors. Watched 2 short shows with subtitles ok.

Edit: Concerning OP post below, I'm on 7u25, and do not have 6 on my machine.
Last edited by Madoka on Tue Sep 03, 2013 3:25 am, edited 1 time in total.

User avatar
Optimus_prime
Moderator
Posts: 690
Joined: Fri Jun 01, 2012 6:39 pm
Location: Sydney, Australia

Re: Version 3.0.0-a4 is released

Post by Optimus_prime » Mon Sep 02, 2013 6:25 pm

Ok guys i had this problem, you have to uninstall any Java 6 JRE/JDK's you have. Then reinstall the java 7 JRE. Thats what fixed it for me, might not work for everyone.

Edit: This is related to something from a PMS commit and is something they use to run Java in 32 or 64 bit. The issue is when UMS (3.0.0-a4) looks into the registry it doesn't see what it needs (Java 7 etc) and defaults back to the other (JRE) version installed. In my case this was Java 6. My fix was to uninstall any JRE, all java 6 related JRE then reinstall the Java 7 JRE. Feedback would be helpfull.
How Ask For Support
Remember, Debug Log's Can/Will Help and Explain your issues, we're not mind reader's but here to help
OS's I Use And Can Assist With: Windows 7/8, Mac OS-X 10.8 & 10.9
Mac OS-X Java 7 Builds Mac OS-X Java 7 Forum

leocheine
Posts: 6
Joined: Mon Sep 02, 2013 3:01 am

Re: Version 3.0.0-a4 is released

Post by leocheine » Tue Sep 03, 2013 12:28 am

I managed to make it work, I copied the jvm.dll from jdk I entered in "C: \ Program Files \ Java \ jdk1.7.0_25 \ jre \ bin \ server" and copied the file to "C: \ Program Files \ Java \ jre7 \ bin \ server", but I had to create the directory server, then it rebooted my Moden / router, I started the server and it worked.

Post Reply