Version 3.1.1 is released

Announcements about Universal Media Server
Post Reply
User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Version 3.1.1 is released

Post by SubJunk » Sun Nov 24, 2013 3:23 pm

General:

You can download it from the front page.

This release fixes video compatibility and subtitle bugs as well as improving speed and stability.


Changes since 3.1.0:
  • General:
    • Sort renderers by name in the "Default renderer" option
    • Fixed a bug that caused unnecessary transcoding/muxing
    • Fixed subtitles not being transcoded when they should be
    • Fixed parsing of FFmpeg protocols
    • Fixed memory leaks
    • Optimized code
  • Renderers:
    • Improved video support on Panasonic TX-L32V10E TVs
    • Improved video support on PS3
  • Languages:
    • Updated Dutch translation (thanks, leroy!)
    • Updated Spanish translation (thanks, AlfredoRamos!)
  • External Components:
    • Updated h2database to 1.3.174, which:
      • Improves speed
      • Improves stability
    • Updated MediaInfo for Windows to 0.7.65, which:
      • Improves stability

Upgrade Notes:

For 3.0.0-b1 and newer:
No action necessary.

For all versions below 3.0.0-b1:
It is recommended to delete your UMS.conf file prior to installing this version. Windows users can choose the "clean install" option while installing instead.

hannubys
Posts: 17
Joined: Mon Apr 01, 2013 3:27 am

Re: Version 3.1.1 is released

Post by hannubys » Sun Nov 24, 2013 3:56 pm

Why "Enable GPU acceleration" is greyed out with the new version ?

User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.1.1 is released

Post by SubJunk » Sun Nov 24, 2013 4:27 pm

hannubys wrote:Why "Enable GPU acceleration" is greyed out with the new version ?
It will become enabled if you enable an engine that supports GPU acceleration, which for now is only the AviSynth engines

Madoka
Posts: 316
Joined: Fri Jun 01, 2012 12:51 pm

Re: Version 3.1.1 is released

Post by Madoka » Sun Nov 24, 2013 6:53 pm

Thanks for the new release!

robertc99
Posts: 6
Joined: Sun Nov 24, 2013 9:56 pm

Re: Version 3.1.1 is released

Post by robertc99 » Sun Nov 24, 2013 10:00 pm

The "new media" feature has never worked for me. I can't seem to get the folder to appear.
When it didnt work in 3.0 I figured it would be fixed in the next release.
But still not working, so I figured I'd better report it.

I'm using a ps3.

ExSport
Posts: 596
Joined: Wed Oct 10, 2012 1:57 am

Re: Version 3.1.1 is released

Post by ExSport » Sun Nov 24, 2013 11:08 pm

What about to "tick" "Advanced monitroing"? ;)

User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.1.1 is released

Post by SubJunk » Sun Nov 24, 2013 11:10 pm

Thanks for reminding me, I've been meaning to make it more obvious that "advanced monitoring" needs to be enabled for that to work. I'll try to put that in the next version.

ExSport
Posts: 596
Joined: Wed Oct 10, 2012 1:57 am

Re: Version 3.1.1 is released

Post by ExSport » Mon Nov 25, 2013 2:15 am

@SubJunk:
Tested latest version and as I already reported earlier, new tsMuxeR versions doesn't work well with other renderers than PS3.
I have many "general" MKV documents which play on PS3 but not with Panasonic TV. When I replaced tsMuxeR 2.2.3 or 2.0.8 to 1.10.6, PanTV started to work.
You have PanTV too so you can test it to reproduce it. I suppose majority of mkv files will have this symptom...
EDIT1:
Ok, 50% works, 50% not...so not all mkv files are affected (when 2.x.x versions used) 8-)
EDIT2:
Btw. FFMPEG engine uses:
  • Remux videos with FFmpeg when possible instead of transcoding
  • Remux videos with tsMuxeR when possible instead of transcoding
Quite confusing for many people...How to set it? What does it mean? When file is remuxable, what technique will be used?
Both can be enabled together so I lost the logic what will happen with this engine when UMS will try to remux or what is better to be used? 8-)
EDIT3:
DVD folders doesn't work. Folder structure played outside TRANSCODE folder doesn't work but any option tested in TRANSCODE folder works!

D-Kalck
Posts: 15
Joined: Wed May 22, 2013 11:02 am

Re: Version 3.1.1 is released

Post by D-Kalck » Mon Nov 25, 2013 7:56 am

With 3.1.0 and 3.1.1 the duration for video files doesn't work anymore, like pre 3.0.0

User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.1.1 is released

Post by SubJunk » Mon Nov 25, 2013 4:26 pm

ExSport wrote:@SubJunk:
Tested latest version and as I already reported earlier, new tsMuxeR versions doesn't work well with other renderers than PS3.
I have many "general" MKV documents which play on PS3 but not with Panasonic TV. When I replaced tsMuxeR 2.2.3 or 2.0.8 to 1.10.6, PanTV started to work.
You have PanTV too so you can test it to reproduce it. I suppose majority of mkv files will have this symptom...
EDIT1:
Ok, 50% works, 50% not...so not all mkv files are affected (when 2.x.x versions used) 8-)
EDIT2:
Btw. FFMPEG engine uses:
  • Remux videos with FFmpeg when possible instead of transcoding
  • Remux videos with tsMuxeR when possible instead of transcoding
Quite confusing for many people...How to set it? What does it mean? When file is remuxable, what technique will be used?
Both can be enabled together so I lost the logic what will happen with this engine when UMS will try to remux or what is better to be used? 8-)
EDIT3:
DVD folders doesn't work. Folder structure played outside TRANSCODE folder doesn't work but any option tested in TRANSCODE folder works!
The first two issues are fixed in 3.1.2. The 3rd I can't reproduce but I'll keep trying more DVDs
D-Kalck wrote:With 3.1.0 and 3.1.1 the duration for video files doesn't work anymore, like pre 3.0.0
Hopefully it's fixed in 3.1.2 :)

Post Reply