Version 3.4.1 is released

Announcements about Universal Media Server
User avatar
SubJunk
Lead Developer
Posts: 3375
Joined: Sun May 27, 2012 4:12 pm

Version 3.4.1 is released

Post by SubJunk »

General:

You can download it from the front page.

This release fixes bugs, improves stability and improves speed!


Changes since 3.4.0:
  • General:
    • Fixed MPlayer thumbnail generation
    • Fixed support for the MovieInfo and LastFMScrobbler plugins
    • Improved math accuracy
    • Improved thread-safety
    • Improved code speed
    • Minor GUI improvements
  • External Components:
    • Updated JGoodies Forms to 1.6.0
    • Updated Maven Checkstyle plugin to 2.11
    • Updated Maven Doxia Docbook Simple plugin to 1.5
    • Updated Maven FindBugs Plugin to 2.5.3
    • Updated Maven Site plugin to 3.3
    • Updated Maven Surefire Report plugin to 2.16

Upgrade Notes:

For all versions below 3.2.0:
If you have enabled FFmpeg's fontconfig or hid the New Media folder, you will need to re-apply those settings.

For all versions below 3.0.0-b1:
It is recommended to delete your UMS.conf file prior to installing this version. Windows users can choose the "clean install" option while installing instead.
spkbr
Posts: 8
Joined: Thu Dec 05, 2013 2:22 am

Re: Version 3.4.1 is released

Post by spkbr »

Thank you SubJunk. LastFMScrobbler is working just fine now. Thanks!
Wolfgan
Posts: 370
Joined: Fri Feb 08, 2013 12:33 am

Re: Version 3.4.1 is released

Post by Wolfgan »

Thanks for the release guys. Updating my install now. Wolf.
-- UMS serving PS3, WDTV, Samsung H6400 + J5500 and Kalemsoft renderers! (no video transcoding but remuxing accepted :D )
domain
Posts: 7
Joined: Wed Aug 07, 2013 6:31 pm

Re: Version 3.4.1 is released

Post by domain »

MediaInfo.dll still cause crash.
See also: viewtopic.php?f=9&t=1427
maildeamon
Posts: 1
Joined: Sun Feb 16, 2014 7:30 am

Re: Version 3.4.1 is released

Post by maildeamon »

after update subtitles didn,t work anymore ?
rollin back to 330 and subs are back.
Madoka
Posts: 328
Joined: Fri Jun 01, 2012 12:51 pm

Re: Version 3.4.1 is released

Post by Madoka »

Thanks for the new release, SJ! So close to 3.1.4.

Subs work fine for me, but I'm on a PS3.

I've been meaning to ask, is there an advantage to using MPlayer to generate video thumbnails?

And since "A/V sync alternative method" is the default method, maybe it shouldn't be the "alternative" method anymore? Just wondering.
User avatar
SubJunk
Lead Developer
Posts: 3375
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.4.1 is released

Post by SubJunk »

Madoka wrote:I've been meaning to ask, is there an advantage to using MPlayer to generate video thumbnails?
It's a good question, and it's explained in the tooltip for that option, but basically it's a tradeoff between speed and accuracy; MPlayer is slower at generating the thumbnails, but they are the correct aspect ratio, while FFmpeg is faster but all thumbnails are widescreen.
Madoka wrote:And since "A/V sync alternative method" is the default method, maybe it shouldn't be the "alternative" method anymore? Just wondering.
That's a good point, we should rename it! :)
maildeamon wrote:after update subtitles didn,t work anymore ?
rollin back to 330 and subs are back.
On which device? Check the link in my signature :)
domain wrote:MediaInfo.dll still cause crash.
See also: viewtopic.php?f=9&t=1427
I'll rollback MediaInfo in the next version, sorry for missing that in this one :)
spkbr wrote:Thank you SubJunk. LastFMScrobbler is working just fine now. Thanks!
Cool, thanks for confirming :)
Wolfgan wrote:Thanks for the release guys. Updating my install now. Wolf.
You're welcome, hope it goes well :)
Monica Jae
Posts: 48
Joined: Mon Oct 21, 2013 6:11 pm

Re: Version 3.4.1 is released

Post by Monica Jae »

why do i keep getting this annoying

mediainfo64.dll error everytime i try to install? and i'm doing clean.
User avatar
SubJunk
Lead Developer
Posts: 3375
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.4.1 is released

Post by SubJunk »

That probably means the program is still running while you're trying to install, or that it didn't close properly. You can open task manager and close "javaw.exe" manually, or restart your computer.
Monica Jae
Posts: 48
Joined: Mon Oct 21, 2013 6:11 pm

Re: Version 3.4.1 is released

Post by Monica Jae »

SubJunk wrote:That probably means the program is still running while you're trying to install, or that it didn't close properly. You can open task manager and close "javaw.exe" manually, or restart your computer.
AAHHH that makes sense! ok, got it.
Post Reply