Version 3.6.3 is released

Announcements about Universal Media Server
User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Version 3.6.3 is released

Post by SubJunk » Sun Jun 15, 2014 6:11 pm

General:

You can download it from the front page.

This release fixes DTS transcoding, adds and improves support for many renderers, fixes thumbnail seek position and more!


Changes since 3.6.2:
  • General:
    • Added and improved documentation for more renderer options to PS3.conf (CustomFFmpegOptions, OverrideFFmpegVideoFilter and KeepAspectRatio)
    • Added support for configuring whether UMS can run just one or multiple instances
    • Made the renderer setting KeepAspectRatio more reliable
    • Renamed the renderer option OverrideVideoFilter to OverrideFFmpegVideoFilter
    • Fixed incorrect aspect ratios being cached
    • Fixed thumbnail seek position
    • Fixed bugs with FFmpeg subtitle styles
  • Renderers:
    • Added support for nPlayer, skifta and TwonkyBeam on portable Apple devices (thanks, MattDetroit!)
    • Added support for LG LM620 TVs (thanks, michal-sapsa!)
    • Added support for Sony Bravia W7 series TVs (thanks, shtirlic!)
    • Improved support for DirecTV HR
    • Improved support for OPPO devices
    • Improved support for Panasonic TVs
    • Improved support for Samsung mobile devices
  • Languages:
    • Updated Czech translation
    • Updated Spanish translation (thanks, AlfredoRamos!)
  • External Components:
    • Updated Apache commons-lang to 3.3.2, which:
      • Fixes bugs
    • Updated Logback to 1.1.2, which:
      • Fixes bugs
    • Updated Maven FindBugs Plugin to 2.5.4
    • Updated Maven Git Commit ID Plugin to 2.1.9
    • Updated MPlayer/MEncoder for Windows to SB55, which:
      • Fixes DTS-ES to AC-3 transcoding
    • Updated Netty to 3.9.1, which:
      • Fixes bugs
    • Updated slf4j to 1.7.7

Upgrade Notes:

For all versions below 3.2.0:
If you have enabled FFmpeg's fontconfig or hid the New Media folder, you will need to re-apply those settings.

For all versions below 3.0.0-b1:
It is recommended to delete your UMS.conf file prior to installing this version. Windows users can choose the "clean install" option while installing instead.

Madoka
Posts: 316
Joined: Fri Jun 01, 2012 12:51 pm

Re: Version 3.6.3 is released

Post by Madoka » Sun Jun 15, 2014 7:32 pm

Thanks for the new release!

Edit: Few observations. FFmpeg will now transcode subtitles even if "Remux with tsmuxer" is checked which is great. Also, so far, I haven't come across the giant FFmpeg default .ass subs bug with "Fontconfig" checked. Also with "Fontconfig" checked, .srt subtitles will follow the color specified in the "Subtitles" tab. Thanks for the great fixes!

There seems to be an occasional bug where FFmepg, with "Fontconfig" checked, will ignore the color of the Default subtitles specified in the .ass file and use the color saved in the "Subtitles" tab. Doesn't seem to do it all the time. Still testing this out. Not a big issue though.

BTW, did you mean SB55 as you are up to SB57 on Spriton.
Last edited by Madoka on Mon Jun 16, 2014 2:10 pm, edited 1 time in total.

Paradox
Posts: 127
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 3.6.3 is released

Post by Paradox » Mon Jun 16, 2014 1:25 pm

Just a couple of queries...

With regards to these 2 settings/items...
Made the renderer setting KeepAspectRatio more reliable
Fixed incorrect aspect ratios being cached

What exact changes have you made? Im assuming the first is Mencoder command related as in prior UMS versions? But what has the command been altered to???
With regards to the second is that also Mencoder command related?

Also with regards to...
Renamed the renderer option OverrideVideoFilter to OverrideFFmpegVideoFilter

Is this just to make it easy for the devs and users to understand/remember that command affects FFmpeg only?

Other than that Great work again and thanks Subjunk and everyone concerned for another update :)

User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.6.3 is released

Post by SubJunk » Mon Jun 16, 2014 3:01 pm

Madoka wrote:Thanks for the new release!

Edit: Few observations. FFmpeg will now transcode subtitles even if "Remux with tsmuxer" is checked which is great. Also, so far, I haven't come across the giant FFmpeg default .ass subs bug with "Fontconfig" checked. Also with "Fontconfig" checked, .srt subtitles will follow the color specified in the "Subtitles" tab. Thanks for the great fixes!
Awesome, cheers :)
Madoka wrote:There seems to be an occasional bug where FFmepg, with "Fontconfig" checked, will ignore the color of the Default subtitles specified in the .ass file and use the color saved in the "Subtitles" tab. Doesn't seem to do it all the time. Still testing this out. Not a big issue though.
Thanks for reporting this. If you can reproduce it we'd love to see the logs along with the .ass file
Madoka wrote:BTW, did you mean SB55 as you are up to SB57 on Spriton.
Yeah I rolled back to SB55 because 56 and 57 have a bug that breaks DTS-ES transcoding to AC-3. It will hopefully be fixed in SB58 which I'm working on now.
Paradox wrote:With regards to these 2 settings/items...
Made the renderer setting KeepAspectRatio more reliable
Fixed incorrect aspect ratios being cached

What exact changes have you made? Im assuming the first is Mencoder command related as in prior UMS versions? But what has the command been altered to???
With regards to the second is that also Mencoder command related?
KeepAspectRatio wasn't being applied when the file was compatible with the renderer, so I fixed that.
The incorrect aspect ratio thing just relates to the aspect ratios that we store in the database, which isn't used by default. Before we were storing the same type of aspect ratio 3 times, so now we are storing all 3 types of aspect ratio correctly.
Paradox wrote:Also with regards to...
Renamed the renderer option OverrideVideoFilter to OverrideFFmpegVideoFilter

Is this just to make it easy for the devs and users to understand/remember that command affects FFmpeg only?
Yeah
Paradox wrote:Other than that Great work again and thanks Subjunk and everyone concerned for another update :)
Cheers! :)

Madoka
Posts: 316
Joined: Fri Jun 01, 2012 12:51 pm

Re: Version 3.6.3 is released

Post by Madoka » Mon Jun 16, 2014 3:13 pm

I was mistaken about the "Mux with tsMuxer" issue. I forgot that I was manually selecting things from the transcode folder when I was switching between Mencoder and FFmepg during testing. :facepalm: With FFmpeg as the default engine and "Mux with tsMuxer" checked, it will still ignore subtitles and Mux the video...even tho it doesn't need to as it's a native .mp4 file. Sorry for the error.

User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Re: Version 3.6.3 is released

Post by SubJunk » Mon Jun 16, 2014 3:23 pm

Madoka wrote:I was mistaken about the "Mux with tsMuxer" issue. I forgot that I was manually selecting things from the transcode folder when I was switching between Mencoder and FFmepg during testing. :facepalm: With FFmpeg as the default engine and "Mux with tsMuxer" checked, it will still ignore subtitles and Mux the video...even tho it doesn't need to as it's a native .mp4 file. Sorry for the error.
Can you make a thread for it with logs? We added debugging info recently that might help us see why that's happening

User avatar
pipin
Posts: 65
Joined: Fri Dec 28, 2012 12:17 am

Re: Version 3.6.3 is released

Post by pipin » Tue Jun 17, 2014 1:32 am

Great work guys.

But I hate Samsung now. After buying an UE32F4580 (subtitles worked fine) I bought a Samsung 3D LED TV UE48H6600 on which the subtitles won't work. :(
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600

Paradox
Posts: 127
Joined: Tue Dec 17, 2013 5:50 am

Re: Version 3.6.3 is released

Post by Paradox » Tue Jun 17, 2014 5:29 am

SubJunk wrote:
Paradox wrote:With regards to these 2 settings/items...
Made the renderer setting KeepAspectRatio more reliable
Fixed incorrect aspect ratios being cached

What exact changes have you made? Im assuming the first is Mencoder command related as in prior UMS versions? But what has the command been altered to???
With regards to the second is that also Mencoder command related?
KeepAspectRatio wasn't being applied when the file was compatible with the renderer, so I fixed that.
The incorrect aspect ratio thing just relates to the aspect ratios that we store in the database, which isn't used by default. Before we were storing the same type of aspect ratio 3 times, so now we are storing all 3 types of aspect ratio correctly.
I still do not think the "KeepAspectRatio" setting will work properly for all devices. AND NOW AFTER LOOKING TO SEE WHAT YOU TWEAKED I THINK IVE SPOTTED THE LONG RUNNING ISSUE.
Currently in the source here...
https://github.com/UniversalMediaServer ... java#L1897

As you can see you have the expand option set to ":::0:16/9" This will not work for every video or renderer for a few reasons.

Firstly this is the config for the "expand" option......

Code: Select all

expand[=w:h:x:y:o:a:r]
Expands (not scales) movie resolution to the given value and places the unscaled original at coordinates x, y. Can be used for placing subtitles/OSD in the resulting black bands.

<w>,<h>
Expanded width,height (default: original width,height). Negative values for w and h are treated as offsets to the original size.

<x>,<y>
position of original image on the expanded image (default: center)

<o>
OSD/subtitle rendering
0: disable (default)
1: enable

<a>
Expands to fit an aspect instead of a resolution (default: 0).

<r>
Rounds up to make both width and height divisible by <r> (default: 1).
I COULD BE WRONG ON THIS BUT......
What I THINK you currently have set with ":::0:16/9" is one semi colon (:) short of what i think you actually want.
At the moment i believe you basically have set this......
no width alteration : no height alteration : no x positioning : ALTERED Y POSITIONING TO 0 {ZERO} (THIS IS WHERE I THINK IT IS WRONG) : subrendering not set : expand to 16/9 aspect : no round up/division of resolution

SEMI COLONS COME AFTER NOT BEFORE A SETTING

What i imagine you wanted to set was....
"=::::0:16/9" (NOTE 4 semi colons rather than 3)
Which would equate to....
no width alteration : no height alteration : no x positioning : no altered y positioning : SUBRENDERING SET TO 0 (IE DISABLE) : expand to 16/9 aspect : no round up/division of resolution.

^^^^ I tried to underline the semi colons (:) to make them stand out and explain whats going on though im not sure if it makes enough sense.

Basically it means you are correctly not expanding anything but just setting the display AR to 16/9, this would be ok but for a few problems. The first being the altered Y positioning, the others as follows....

You have no <r> figure set.
Some codecs will not divide by 1 (IE you have nothing set for option <r> after 16/9 to tell it what it should round/divide the resolution to be so it is not doing anything) For things like xvid playback this is critical, older xvid revisions had to be dividable by 16, newer revisions you can get away with resolutions dividable by 2 or 4. It is the same for other odd codecs, in fact the only ones i know that can do default resolutions by a scale factor of 1 is h.264/mp4)

I suggest you alter that to this "16/9:2" (the :2 being the figure for <r>) it will then round up/divide all resolutions to a even number (IE dividable by 2) So when someone has for example a video with say a poorly encoded resolution of 720x405, it will take that 405 figure and make it dividable by 2. (Probably round it up or down to 404 or 406) This increases the potential for the command to work with all codecs, all renderers and all screen resolutions. Without it it will not work on all devices (my Sony again as example)

In short i recommend testing and then changing that expand command/or rather line 1897 in https://github.com/UniversalMediaServer ... java#L1897 to the following........

Code: Select all

vfValuePrepend += "::::1:16/9:2";
I personally in my renderer conf file use "=-vf softskip,expand=::::1:16/9:2" and it works correctly. (The 1 sets subtitle rendering to enable, it may be best on some devices to set that to 0 though).

I hope this helps to improve things even further with the aspect functioning :)

PS: The other change to stop TSMuxer using the Keepaspectratio setting when a video is 16:9 is also a nice idea, though im not sure it will be a good one. Does TSMuxer display resolutions correctly on devices that need the "keepaspectratio" setting otherwise? (I have not tested TSMuxer enough to know but will this week).

User avatar
valib
Developer
Posts: 608
Joined: Fri Feb 08, 2013 3:11 am

Re: Version 3.6.3 is released

Post by valib » Tue Jun 17, 2014 8:35 am

Thanks for your input but there is not missing semicolon. In the line 1894 there is

Code: Select all

vfValuePrepend += "expand=-" + expandBorderWidth + ":-" + expandBorderHeight;
and the previous code checks if resolution is divided by 4 and this line add the black bars where needed.

Triplefun
Posts: 136
Joined: Sat Jun 02, 2012 2:29 pm

Re: Version 3.6.3 is released

Post by Triplefun » Tue Jun 17, 2014 8:51 am

Thanks for the latest release. How does this compare to 4.0.0-a1- supposedly 4 adds the new web interface which is not planned for 3. I was forcing transcode of MP4 and M2TS files but found with playback of MP4 using 3.6.3 and the latest Cambridge Audio 752bd firmware suddenly stopped. The direct play of some of my MP4 files never used to work on the PS3 in previous releases. I have switched off the forced transcode and now all MP4 files appear to play on both the PS3 and 752bd.

Post Reply