Version 4.0.2 is released

Announcements about Universal Media Server
User avatar
SubJunk
Lead Developer
Posts: 2832
Joined: Sun May 27, 2012 4:12 pm

Version 4.0.2 is released

Post by SubJunk » Thu Aug 07, 2014 1:48 pm

General:

You can download it from the front page.

This release fixes Live Subtitles support, fixes external subtitle support on Samsung TVs, improves support for other renderers, fixes bugs and more!


Changes since 4.0.1:
  • General:
    • The Java 8 build on Windows offers to update Java 7
    • Added all default renderer values to PS3.conf to make it easier to support new renderers
    • Added documentation and formatting to PS3.conf
    • Fixed automatic Java download/installation on Windows for users without it
    • Fixed the Live Subtitles feature
    • Fixed external subtitle support
  • Renderers:
    • Improved support for DirecTV HR
    • Improved support for Panasonic TVs
    • Improved support for Samsung devices
  • External Components:
    • Updated Java Runtime Environment automatic downloader for Windows to 8u11, which:
      • Improves security
    • Updated Maven Compiler Plugin to 3.1

Madoka
Posts: 316
Joined: Fri Jun 01, 2012 12:51 pm

Re: Version 4.0.2 is released

Post by Madoka » Thu Aug 07, 2014 2:01 pm

Thanks for the new release!

But something broke FFmpeg and fontconfig. All subtitles are stretched horizonatally, both external and internal. Turning it off results in normal/correct subs. Affects both .ass and .srt subtitles. This is on the Java 7 build.

I've gone back to 4.0.1 for now as subs work best for me so far (PS3).

User avatar
pipin
Posts: 65
Joined: Fri Dec 28, 2012 12:17 am

Re: Version 4.0.2 is released

Post by pipin » Fri Aug 08, 2014 4:02 am

Sorry but external subtitles still not working on samsung as with 4.0.0.
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600

Maniac
Posts: 6
Joined: Fri Aug 08, 2014 8:36 am

Re: Version 4.0.2 is released

Post by Maniac » Fri Aug 08, 2014 8:44 am

Since upgrading to the v4 releases UMS no longer works with my Sony Bravia KDL-46W905A. Videos can be seen listed as available but when you select a video to play it looks like it's about to start but just displays a black screen. If there is another video to play it attempts to play that but does the same thing. This is most prevalent with MP4 files. Playback on PS3 remains functional.

To try and assist in resolving the issue I elected to reset my config during the install of 4.0.2 and upgraded to Java 8 but playback continues to be an issue. All was fine in the last release of v3.

The_Wolf88
Posts: 1
Joined: Fri Aug 08, 2014 10:09 am

Re: Version 4.0.2 is released

Post by The_Wolf88 » Fri Aug 08, 2014 10:12 am

Some MP4 files are not working. Video Playback is broken on Sony Bravia W600 since version 4 and it's still broken even with 4.0.2 !!

lokillo_20
Posts: 12
Joined: Fri Aug 08, 2014 9:49 am

Re: Version 4.0.2 is released

Post by lokillo_20 » Fri Aug 08, 2014 10:35 am

For my philips 2013, external subtitle doesn't work too (I use *.ssa because it's only format that my tv supported for media servers)

The Spanish language pack not work!

Regards!

I Leave my own profile because the philips included in UMS doesn't work for me and i leave the user manual that show all the formats supported to improve the profile.

Code: Select all

#----------------------------------------------------------------------------
# Profile for Philips Smart TV 2013.
# See PS3.conf for a description of all possible configuration options.
#

RendererName=Philips Smart TV 2013
RendererIcon=viziosmarttv.png
UserAgentSearch = IPI/1.0 UPnP/1.0 DLNADOC/1.50
 
Video=true
Audio=true
Image=true
SeekByTime=true
TranscodeVideo=MPEGTS-H264-AAC
TranscodeAudio=LPCM
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=30
MaxVideoWidth = 1920
MaxVideoHeight = 1080
H264Level41Limited=true
MimeTypesChanges=audio/wav=audio/L16|video/mp4=video/mpeg
DLNALocalizationRequired=true
TranscodeExtensions=
StreamExtensions=
 
# For Bravia TVs and Sony Bluray players
ForceJPGThumbnails=false
 
MediaInfo = true
CreateDLNATreeFaster = true
# [Supported video formats]:
# Here we declare support (or lack) of DTS (here, none of the entries declare dts as a supported audio codec)
Supported = f:mpegps     v:mpeg1|mpeg2|mp4|h264   a:aac|aac-he|mpeg1|mpeg2         m:video/mpeg
Supported = f:mpegts     v:mpeg2|mp4|h264         a:aac|aac-he|mpeg1|mpeg2        m:video/mpeg
Supported = f:avi|divx   v:mp4|divx               a:mp3|lpcm|wma|aac|aac-he   m:video/x-divx     gmc:0
Supported = f:mp4        v:mp4|h264               a:aac|aac-he|wma     m:video/mp4                n:2
Supported = f:mkv        v:mp4|h264               a:mpeg1|mpeg2|aac|aac-he        m:video/mkv          n:2


# [Supported audio formats]:
Supported = f:wav a:dts|lpcm n:6 s:48000 m:audio/wav
Supported = f:wav n:2 s:48000 m:audio/wav
Supported = f:mp3 n:2 m:audio/mpeg
# Apple lossless not supported
Supported = f:aac n:2 a:(?!alac).+ m:audio/x-m4a
Supported = f:wma n:2 m:audio/x-ms-wma
Supported = f:atrac n:2 m:audio/x-oma
# [Supported image formats]
Supported = f:jpg m:image/jpeg
Supported = f:png m:image/png
Supported = f:gif m:image/gif
Supported = f:tiff m:image/tiff

SupportedSubtitlesFormats = ASS

User avatar
valib
Developer
Posts: 609
Joined: Fri Feb 08, 2013 3:11 am

Re: Version 4.0.2 is released

Post by valib » Fri Aug 08, 2014 11:23 am

Pleas everybody who reported a problem to follow the instruction at viewtopic.php?f=9&t=556 and reproduce the bug otherwise we are lost. I have for example only a Panasonic TV and everything is working correctly so without your support we can't do anything. Thanks

Maniac
Posts: 6
Joined: Fri Aug 08, 2014 8:36 am

Re: Version 4.0.2 is released

Post by Maniac » Fri Aug 08, 2014 8:12 pm

Maniac wrote:Since upgrading to the v4 releases UMS no longer works with my Sony Bravia KDL-46W905A. Videos can be seen listed as available but when you select a video to play it looks like it's about to start but just displays a black screen. If there is another video to play it attempts to play that but does the same thing. This is most prevalent with MP4 files. Playback on PS3 remains functional.

To try and assist in resolving the issue I elected to reset my config during the install of 4.0.2 and upgraded to Java 8 but playback continues to be an issue. All was fine in the last release of v3.
Debug files have now been uploaded to the General Help and Support section - viewtopic.php?f=9&t=2075&p=11478#p11478

Biteyourconsole
Posts: 1
Joined: Sat Aug 09, 2014 1:44 am

Re: Version 4.0.2 is released

Post by Biteyourconsole » Sat Aug 09, 2014 1:49 am

Good morning, I noticed that the audio and video files can not be uploaded on PS4, audio files do not allow me to click on the buttons of the player, while the video recite "html5: Unsupported video format".

nymous
Posts: 1
Joined: Sun Aug 10, 2014 2:04 am

Re: Version 4.0.2 is released

Post by nymous » Sun Aug 10, 2014 2:06 am

FLAC playback using DMC as third device is broken on all my devices since 3.x and doesn't seem to be fixed anytime soon.

Post Reply