Version 5.0.1 is released

Announcements about Universal Media Server
User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Version 5.0.1 is released

Post by SubJunk » Mon Feb 16, 2015 10:28 am

General:

You can download it from the front page.

This release adds and improves support for lots of devices and filetypes, updates several language translations and squashes a whole heap of bugs!


Changes since 5.0.0:
  • General:
    • Fixed text in the Windows automatic updater
    • Fixed MediaInfo not parsing some rare data
    • Fixed detection of font attachments
    • Fixed support for subtitled files with apostrophes in the name
    • Fixed errors when packing debug files
    • Fixed support for resuming playback on some devices
    • Improved support for MOV, 3GP and 3G2 files
    • Reduced CPU load when the Status tab is visible
    • Improved support for 1920x1088 videos
    • Fixed logging error
    • Fixed the web interface when browsing via Safari
    • Improved stability when disabling renderers
  • Renderers:
    • Added support for Kodi Media Center
    • Added support for more Panasonic Blu-ray players
    • Added support for Samsung HT-F4 series home entertainment systems
    • Improved detection of some LG TVs
    • Improved detection of some Panasonic Blu-ray players and TVs
    • Improved detection of some Samsung devices
    • Improved support for Samsung ES6100 TVs
    • Improved support for Samsung ES6575 TVs
    • Improved support for Sony Xperia Z3 smart phones
    • Updated the image for Xbox 360
    • Fixed 24-bit FLAC playback on PS3 via the Videos folder
  • Languages:
    • Updated Czech translation
    • Updated French translation (thanks, Kirvx!)
    • Updated Spanish translation (thanks, AlfredoRamos!)
  • External Components:
    • Updated MediaInfo for OS X to 0.7.71, which:
      • Improved folder population time
      • Added and improved support for many formats
      • Fixed bugs

blue000000
Posts: 11
Joined: Mon Feb 16, 2015 11:43 am

Re: Version 5.0.1 is released

Post by blue000000 » Mon Feb 16, 2015 11:52 am

I am having installer issues with all version after 4.3.1.

viewtopic.php?f=9&t=3027

Wolfgan
Posts: 371
Joined: Fri Feb 08, 2013 12:33 am

Re: Version 5.0.1 is released

Post by Wolfgan » Mon Feb 16, 2015 4:31 pm

Thanks for the update! Something I noticed it changed (updating from 4.4 codeline) was that my default renderer conf file specifies image and audio files as false, but they still are being sent as present to all renderers.
Did anything change about that functionality? Wolf.
-- UMS serving PS3, WDTV, Samsung H6400 + J5500 and Kalemsoft renderers! (no video transcoding but remuxing accepted :D )

Madoka
Posts: 316
Joined: Fri Jun 01, 2012 12:51 pm

Re: Version 5.0.1 is released

Post by Madoka » Mon Feb 16, 2015 6:08 pm

Thanks for the update. I noticed that the high CPU usage, non-deferral to MEncoder with embedded fonts, and netty exception bugs have been fixed. Thanks!

On the PS3, the name of the playing file doesn't show up in the GUI anymore. There's just a blank where the scrolling name should be.

I don't have AviSynth installed, but now the "enable GPU acceleration" box is not greyed out, and I can turn it on. Is FFmpeg or some other engine now able to use GPU acceleration? Before it was always greyed out for me.

simakuutio
Posts: 4
Joined: Mon Feb 16, 2015 5:40 am

Re: Version 5.0.1 is released

Post by simakuutio » Wed Feb 18, 2015 2:29 am

Neither 5.0 or 5.0.1 save resume file (4.4 did it properly, tested multiple times with both version branches). 5.* also sometimes doesn't detect (at least in log) start of play (video plays fine anyway) and most of the time, doesn't detect (in log) stop of the play. With 4.4 and earlier versions, didn't have any of those problems.

sma76928
Posts: 13
Joined: Thu Sep 18, 2014 10:20 pm

Re: Version 5.0.1 is released

Post by sma76928 » Wed Feb 18, 2015 6:09 am

thanks for the update.
this version doesn't work with LG WebOs. the 4.4.0 works on ffmpeg only (but it works). this version doesn't work at any trasncoder mode.

Rocket
Posts: 9
Joined: Fri Oct 24, 2014 12:45 pm

Re: Version 5.0.1 is released

Post by Rocket » Wed Feb 18, 2015 6:14 pm

Unable to browse files with the Xbox360 on this release, it seems to be trying to load some photo/image menus. Host machine is Win7 x64.

4.40 is the last working version for full 360 support.

michaelt
Posts: 155
Joined: Tue Feb 03, 2015 11:18 am
Location: lost in the depths of my mind

Re: Version 5.0.1 is released

Post by michaelt » Thu Feb 19, 2015 5:17 pm

This version seems a bit better than V5.0.0:
  • status page has more useful info
    long titles now scroll reliably
. . . but a few issues carry over:
  • Java versions 7 & 8 require admin privileges (network ports I believe)
    memory leak is a bit better (I think) -see below for figures
    thumbnails do not appear
Memory test with three different Blu-ray titles:
V5.0.1 J6:
- Mem Inactive: 1h=11GB, 2h=23GB. 3h=25GB but not paging!
--- it ate up all but 27MB of free memory but when next movie started it dropped to 14MB & paging went up an insignificant few MB.

V5.0.1 J7:
- Asks: "allow input connections"
- Mem Inactive: 1h=2.3GB, 2h=4GB, 2h44m(end)=5.8GB - no paging, lots free

V5.0.1 J8:
- Asks: "allow input connections"
- Mem Inactive: 1h=15.2GB, 1h58m(end)=27.7GB - <200MB free - minimal paging as for J6
- <150MB recovered when UMS terminates, 1.1GB more after logout.
System must be rebooted to recover the Inactive memory.

***Edit: 02-20 13:30 - tried to recheck anomalies immediately after reboot again on V5.0.1 multiple runs :
  • ask to allow "connection" with admin authentication : J7 J8
    mkv files not recognized, seems random on multiple runs: J6 J7 J8
Last edited by michaelt on Sat Feb 21, 2015 5:21 am, edited 1 time in total.
MacPro5,1 - 2.8 GHz, 32 GB, 20TB, OS X 10.11.6,
. . . . and a few others.
Samsung UN55C8000
Home Theater (WIP): OS X based now, dedicated Linux later.

derlau
Posts: 1
Joined: Fri Feb 20, 2015 6:38 pm

Re: Version 5.0.1 is released

Post by derlau » Fri Feb 20, 2015 6:43 pm

After I updated to version 5.0.1, an error message saying 'cannot play back file' pop up when I tried to watch the MP4 video file which I used to watch on version 5.0.0. I watched it on Sharp Aquos TV. Everything worked fine until I updated the new version.

ExSport
Posts: 596
Joined: Wed Oct 10, 2012 1:57 am

Re: Version 5.0.1 is released

Post by ExSport » Fri Feb 20, 2015 8:18 pm

logs, logs, logs,...

Post Reply