Version 6.0.0 released

Announcements about Universal Media Server
Post Reply
User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Version 6.0.0 released

Post by SubJunk » Sat Jan 30, 2016 9:06 am

General:

You can download it from the front page.

This release adds the "Fully played action" feature, improves Status tab accuracy, fixes automatic cover downloads, improves performance, fixes many bugs, and more!


Changes since 5.5.0:
  • General:
    • Added "Fully played action" setting to control what UMS does with media that has been fully played. The options are:
      • Do nothing
      • Add an overlay to the thumbnail (default)
      • Hide the file
      • Move the file to a different folder
      • Move the file to the recycle/trash bin
    • Added "Thumbnails" renderer config option, to specify whether the renderer can display thumbnails
    • The Status tab updates when media is fast-forwarded or rewound
    • Audio and image thumbnails are output at consistent dimensions
    • Added SquareAudioThumbnails and SquareImageThumbnails renderer configuration options
    • Improved support for thumbnail generation
    • Improved detection of the position of media while playing
    • Improved logging
    • Improved headless support
    • Fixed font size of subtitles
    • Improved filename prettifying
    • Fixed transcoding to LPCM
    • Added and updated tooltips
    • Stability improvements
    • Fixed and improved automatic cover downloading
    • Fixed OS X version
  • Renderers:
    • Improved Status tab display for Panasonic TVs
    • Improved VLC for iOS support
    • Improved Panasonic VT60 support
  • Languages:
    • Synchronized translations with crowdin
  • External Components:
    • Updated Google gson to 2.5
    • Updated h2database to 1.4.191
    • Updated MediaInfo to 0.7.81

Changes since 6.0.0-b2:
  • General:
    • Improved headless support
    • Fixed font size of subtitles
    • Improved performance
    • Stability improvements
    • Improved filename prettifying
    • Fixed transcoding to LPCM
    • Added and updated tooltips
    • Fixed and improved automatic cover downloading
    • Fixed OS X version
  • Renderers:
    • Improved VLC for iOS support
    • Improved Panasonic VT60 support
  • Languages:
    • Synchronized translations with crowdin
  • External Components:
    • Updated Google gson to 2.5
    • Updated h2database to 1.4.191
    • Updated MediaInfo to 0.7.81

WAusJackBauer
Posts: 19
Joined: Mon Jun 22, 2015 10:53 pm

Re: 6.0.0 released

Post by WAusJackBauer » Sat Jan 30, 2016 12:10 pm

Well done on this release!

Videos that I had issues with before now work. I think mostly due to "Improved Panasonic VT60 support".

But yeah thank you so much and keep it up!

nambit
Posts: 14
Joined: Sat Nov 10, 2012 10:28 pm

Re: 6.0.0 released

Post by nambit » Sun Jan 31, 2016 6:48 pm

Does Panasonic VT60 Support include ZT60 support? Figured they're basically the same TV, but I've never had luck with UMS and the ZT60.
Basically it shows as a "Panasonic TV" on UMS (even though I see no renderer file in the directory), and when I try to play things on the TV, it says
"please wait a moment" for a long time and freezes when playing. I think it's defaulting to the panasonic.conf file for the ZT60.

User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Re: 6.0.0 released

Post by SubJunk » Sun Jan 31, 2016 8:52 pm

WAusJackBauer wrote:Well done on this release!

Videos that I had issues with before now work. I think mostly due to "Improved Panasonic VT60 support".

But yeah thank you so much and keep it up!
Cool, glad to hear it :)
nambit wrote:Does Panasonic VT60 Support include ZT60 support? Figured they're basically the same TV, but I've never had luck with UMS and the ZT60.
Basically it shows as a "Panasonic TV" on UMS (even though I see no renderer file in the directory), and when I try to play things on the TV, it says
"please wait a moment" for a long time and freezes when playing. I think it's defaulting to the panasonic.conf file for the ZT60.
If you post some TRACE logs for us we can create a ZT60 profile for better support

cristidb
Posts: 5
Joined: Thu Feb 12, 2015 4:47 am
Location: Bucharest

Re: 6.0.0 released

Post by cristidb » Mon Feb 01, 2016 6:16 am

I cannot believe that Prevent windows sleep still doesn't work properly. It suppose to prevent windows from sleeping WHILE streaming.

Wolfgan
Posts: 371
Joined: Fri Feb 08, 2013 12:33 am

Re: 6.0.0 released

Post by Wolfgan » Tue Feb 02, 2016 12:55 am

FOA thanks for this release!
cristidb wrote:I cannot believe that Prevent windows sleep still doesn't work properly. It suppose to prevent windows from sleeping WHILE streaming.
I also think this feature fells short. There were a couple of nights lately where i forgot to force the server to shut down so stayed idle all night (and when I tested disabling UMS Prevent Sleep feature a while ago, the server went to stand by mid streaming).

Maybe there's an external util that may be better suited for this functionality, allowing for customized rules (ie if network traffic <5% and later than 2AM go to stand by). If anyone has any suggestion it will be appreciated.
-- UMS serving PS3, WDTV, Samsung H6400 + J5500 and Kalemsoft renderers! (no video transcoding but remuxing accepted :D )

robertc99
Posts: 6
Joined: Sun Nov 24, 2013 9:56 pm

Re: 6.0.0 released

Post by robertc99 » Tue Feb 02, 2016 10:44 am

Starting with 5.5.0,UMS no longer seems to work with 32 bit java.
I had 32 bit installed since thats the version that works with firefox.

I only figured it out since I uninstalled java and let UMS reinstall it. Then I noticed it had installed 64 bit java.
Which isnt really a problem since its been a long time since I've used a java based website.
But it might be worth a note in the announcements in case other people have problems.

WAusJackBauer
Posts: 19
Joined: Mon Jun 22, 2015 10:53 pm

Re: 6.0.0 released

Post by WAusJackBauer » Tue Feb 02, 2016 12:49 pm

robertc99 wrote:Starting with 5.5.0,UMS no longer seems to work with 32 bit java.
I had 32 bit installed since thats the version that works with firefox.

I only figured it out since I uninstalled java and let UMS reinstall it. Then I noticed it had installed 64 bit java.
Which isnt really a problem since its been a long time since I've used a java based website.
But it might be worth a note in the announcements in case other people have problems.
Uninstall both and install the 2 offline versions here.

https://www.java.com/en/download/manual.jsp

User avatar
SubJunk
Lead Developer
Posts: 2831
Joined: Sun May 27, 2012 4:12 pm

Re: 6.0.0 released

Post by SubJunk » Tue Feb 02, 2016 5:02 pm

I just tested with 32-bit Java and it works for me

WAusJackBauer
Posts: 19
Joined: Mon Jun 22, 2015 10:53 pm

Re: 6.0.0 released

Post by WAusJackBauer » Tue Feb 02, 2016 7:29 pm

btw for anyone having problems with audio sync after seeking forward / backward, go to audio settings and change the AC3 re-encoding to 2 channels (stereo).

This may depend on your renderer though, I have a Panasonic TV P50ST60A. I think this was only with MEncoder as well.

Speaking of which, is there a renderer for this model?

Post Reply