[Solved] Samsung Q9 series issues

For help and support with Universal Media Server
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Nadahar
Posts: 1952
Joined: Tue Jun 09, 2015 5:57 pm

Re: Samsung Q9 series issues

Post by Nadahar »

The thumbnail issue probably is UMS' fault. There are at least two things I can think of which should handle it. First, it's the UPnP change event mechanism that should be used to tell renderers that an item has changed - it might lead the PS4 to discard the cached thumbnail, if UMS had sent it (which it doesn't, not for any change). Second, on the HTTP level UMS specified an expiry for the thumbnail which is probably far in the future. That actually tells the renderer to cache it and not query again until it has expired. This is "tricky" to solve though, as the only "solution" is to use a very short expiry value which would lead to a lot of requests for things that aren't changed. There are more "advanced" HTTP techniques like "validation" where the renderer simply asks if the cached resource is still valid, but it's not supported by UMS and I have my doubt as to how many renderers would support it if it were.
speckledegg
Posts: 32
Joined: Wed Apr 22, 2015 12:57 am

Re: Samsung Q9 series issues

Post by speckledegg »

No, I'm not using virtual folders and I do have the folder monitoring enabled however, it looks like the cache wasn't enabled.

I have now enabled the cache and will test it tonight to see if it is marking files as expected.
User avatar
SubJunk
Lead Developer
Posts: 3485
Joined: Sun May 27, 2012 4:12 pm

Re: Samsung Q9 series issues

Post by SubJunk »

Thanks for the update, looking forward to your confirmation
speckledegg
Posts: 32
Joined: Wed Apr 22, 2015 12:57 am

Re: Samsung Q9 series issues

Post by speckledegg »

So it appears not to be working; there's no change in the thumbnails when a programme has been watched.

Logs attached.
ums_dbg_2021-07-27-00-35.zip
(1.46 MiB) Downloaded 18 times
User avatar
mik_s
Moderator
Posts: 450
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: Samsung Q9 series issues

Post by mik_s »

I have not looked too much into your logs as this is not an area I know much about, but with some extra logging in this version I can see that of the 6 videos played, 3 were marked as fully played and the other 3 marked as not fully played.

If you are still seeing no change to the thumbnails then it is possible your TV is storing them, similar to what I see on my PS4 till I fully quit the Media Player.

See if there is anyway to clear the play history in your TV's menu. For my F series the option in the the smart features menu.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
sdabrams3
Posts: 14
Joined: Sun Sep 23, 2018 6:08 pm

Re: Samsung Q9 series issues

Post by sdabrams3 »

mik_s wrote: Thu Jul 29, 2021 10:59 am I have not looked too much into your logs as this is not an area I know much about, but with some extra logging in this version I can see that of the 6 videos played, 3 were marked as fully played and the other 3 marked as not fully played.

If you are still seeing no change to the thumbnails then it is possible your TV is storing them, similar to what I see on my PS4 till I fully quit the Media Player.

See if there is anyway to clear the play history in your TV's menu. For my F series the option in the the smart features menu.
I have a similar post with both my Q800T and Q900TS having problems with the wrong thumbnails being shown and I was unable to find a way to clear the Cashe or play history.

Scott
speckledegg
Posts: 32
Joined: Wed Apr 22, 2015 12:57 am

Re: Samsung Q9 series issues

Post by speckledegg »

Yes, there is definitely a lack of options on the Samsung menu. The thumbnails (when they show) don't change whether the file is fully played or not. I think my original point about crappy software on the TV might be the issue, rather than UMS. However, if anyone who knows more than me (not difficult) can see anything obvious, I'm happy to try it!
Nadahar
Posts: 1952
Joined: Tue Jun 09, 2015 5:57 pm

Re: Samsung Q9 series issues

Post by Nadahar »

As I've explained above (and everybody just seems to ignore), there are mechanisms in the UPnP AV protocol for how to notify a renderer when an item has changed. UMS does NOT implement this.

The UPnP AV protocol is what defines the standard under which servers like UMS and renderers communicate, so what it says is supposed to be "the law". Unfortunately, there are loads and loads of situations where the protocol is violated, both from servers and renderers, but that doesn't change the fact that this is how it's supposed to be done.

I think it's unreasonable to "conclude" that the error most likely is with the TV when we KNOW that UMS does NOT inform the renderer as its supposed to. Most renderer implementations seems to just request thumbnails over and over again each time they're needed, which is why the current system "usually works". If every renderer followed the specification, the behavior seen on the Samsung would happen on all renderers.

So, while I cannot claim to know that the Samsung software isn't bugged, there is a known lack in UMS' implementation which prevents it from working as it should. Why would you look for another explanation when you already know of one reason why it won't work?
User avatar
SubJunk
Lead Developer
Posts: 3485
Joined: Sun May 27, 2012 4:12 pm

Re: Samsung Q9 series issues

Post by SubJunk »

The thumbnail updating works for me on PS3, PS4, Panasonic TV, and VLC for iOS (which are my go-to renderers). I remember that back in the day I looked at change-detection and we did increment a thing that worked for PS3 but that might have been the DLNA-way and not the UPnP way.
Anyway I'm interested in looking to improve this for Samsung TVs if we can, I will look into it soon to see what we can do, and if I make a testing build I'll post it in this thread :)
User avatar
SubJunk
Lead Developer
Posts: 3485
Joined: Sun May 27, 2012 4:12 pm

Re: Samsung Q9 series issues

Post by SubJunk »

Please test this and let me know how it goes: https://www.universalmediaserver.com/up ... c9a57a.exe
Post Reply