[Solved] UMS not displaying internal subtitles

For help and support with Universal Media Server
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Gumpnerd
Posts: 3
Joined: Thu Sep 23, 2021 10:17 am

[Solved] UMS not displaying internal subtitles

Post by Gumpnerd »

No matter what I do, UMS doesn't appear to want to display any subtitles on my ps4 (minus one or two rare instances with a couple random movies). The overwhelming majority of shows will not display subs for me, I haven't bothered trying with external sub files but I also don't want the headache of downloading subs manually for my entire library when they already have internal subs as needed. UMS just wont display them for some reason. I was running version 10.0.0 so I updated to the latest version with a clean install yet the bug still persists. I tried it with three files that I verified have internal subs using VLC media player. attached is my debug log. please help :(
Attachments
ums_dbg_2021-09-22-15-47.zip
(169.14 KiB) Downloaded 7 times
User avatar
mik_s
Moderator
Posts: 459
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: UMS not displaying internal subtitles

Post by mik_s »

You should be able to turn on subtitles on your PS4 if the video you are playing is supported and is being streamed.

Most of the videos in your log are not supported on the PS4 so need to be transcoded, and normally it does not include the subtitle stream so that will mean the subtitles will be burned in by UMS to be seen.

I think the logic behind when to do this is dependent on the language, by default if the system language is the same as the audio language then the subs are not shown. If they are different (or have the forced tag) then the they are included. This can be changed with the subtitle language priority setting.

You can force UMS to use any subs if you try playing from the #--TRANSCODE--# folder. All combinations of audio tracks, subs and transcoding engines will be shown.
(if you do not see it, enable "show the #--Transcode--# folder" in the GUI on the navigation tab)
If the video has a lot of internal subs/audio tracks this can be a bit overwhelming so you could reduce this by disabling all but one transcoding engine (FFmpeg).
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
Gumpnerd
Posts: 3
Joined: Thu Sep 23, 2021 10:17 am

Re: UMS not displaying internal subtitles

Post by Gumpnerd »

mik_s wrote: Thu Sep 23, 2021 4:23 pm You should be able to turn on subtitles on your PS4 if the video you are playing is supported and is being streamed.

Most of the videos in your log are not supported on the PS4 so need to be transcoded, and normally it does not include the subtitle stream so that will mean the subtitles will be burned in by UMS to be seen.

I think the logic behind when to do this is dependent on the language, by default if the system language is the same as the audio language then the subs are not shown. If they are different (or have the forced tag) then the they are included. This can be changed with the subtitle language priority setting.

You can force UMS to use any subs if you try playing from the #--TRANSCODE--# folder. All combinations of audio tracks, subs and transcoding engines will be shown.
(if you do not see it, enable "show the #--Transcode--# folder" in the GUI on the navigation tab)
If the video has a lot of internal subs/audio tracks this can be a bit overwhelming so you could reduce this by disabling all but one transcoding engine (FFmpeg).
I can't find the subtitle language priority setting. This is what I'm seeing in my subtitle options, with these settings there are no subs on the ps4. Can I burn them in or something? See attached image. :(
Attachments
ums _subs.png
ums _subs.png (70.01 KiB) Viewed 205 times
User avatar
mik_s
Moderator
Posts: 459
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: UMS not displaying internal subtitles

Post by mik_s »

You can enable subtitles in the PS4 by pressing the options button and selecting the (...) icon and you can pick the subtitles to use. If transcoding this will not show anything as the subtitle will have to be burned in to the video.

It is possible to stream external subs separately instead of burning in but does not work for internal subs. TBH I'm not sure that works any more but I have that option enabled for my PS4.
It would be great if all subs (including internal) could be added to the stream but I think it is limited to just the 1
Sony-PlayStation4 mod.conf
(1.84 KiB) Downloaded 8 times


Your language priority is eng,off;und,off;*,eng;*,und which basically means
  • if audio is eng then turn subs off;
  • If audio is undefined then turn subs off;
  • If audio is anything else use eng subs;
  • If audio is anything and there is no eng subs use undefined subs (subs that have no language defined)
If you always want to show eng subs you could change this to just

Code: Select all

*,eng
But if you just want then on every now and again it is best to play from the #--TRANSCODE--# folder
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
Gumpnerd
Posts: 3
Joined: Thu Sep 23, 2021 10:17 am

Re: UMS not displaying internal subtitles

Post by Gumpnerd »

mik_s wrote: Fri Sep 24, 2021 10:01 am You can enable subtitles in the PS4 by pressing the options button and selecting the (...) icon and you can pick the subtitles to use. If transcoding this will not show anything as the subtitle will have to be burned in to the video.

It is possible to stream external subs separately instead of burning in but does not work for internal subs. TBH I'm not sure that works any more but I have that option enabled for my PS4.
It would be great if all subs (including internal) could be added to the stream but I think it is limited to just the 1Sony-PlayStation4 mod.conf



Your language priority is eng,off;und,off;*,eng;*,und which basically means
  • if audio is eng then turn subs off;
  • If audio is undefined then turn subs off;
  • If audio is anything else use eng subs;
  • If audio is anything and there is no eng subs use undefined subs (subs that have no language defined)
If you always want to show eng subs you could change this to just

Code: Select all

*,eng
But if you just want then on every now and again it is best to play from the #--TRANSCODE--# folder
ahh ok I get it now. Everything is working fine, thank you.
Post Reply