I am surprised no iso dvd audio

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
nickhere
Posts: 138
Joined: Sat Jan 03, 2015 3:28 am

I am surprised no iso dvd audio

Post by nickhere » Sun Jul 30, 2017 10:58 am

I came back to ums so i can have a media server that read iso dvd
you never fix the dvd audio on some dvd
sound is still muted

Nadahar
Posts: 1813
Joined: Tue Jun 09, 2015 5:57 pm

Re: I am surprised no iso dvd audio

Post by Nadahar » Sun Jul 30, 2017 11:12 am

If you start with reading the text in red above, we might get an idea of what your problem is.

nickhere
Posts: 138
Joined: Sat Jan 03, 2015 3:28 am

Re: I am surprised no iso dvd audio

Post by nickhere » Mon Jul 31, 2017 5:10 am

i reported this on Fri Jan 23, 2015 i even provided a link to a iso that comes up with the audio muted. Gus i have to do it again and resupply the download

Nadahar
Posts: 1813
Joined: Tue Jun 09, 2015 5:57 pm

Re: I am surprised no iso dvd audio

Post by Nadahar » Mon Jul 31, 2017 5:21 am

It's impossible for us (at least for me) to keep track of all the different issues and reports. If you could link to the previous thread it would help, I did a quick search through your posts but couldn't find it. We have done some fixes to DVD ISO playback, and I thought it was working fine now. I don't remember the exact issue with missing audio though.

If you can find the previous link to the ISO image that didn't work, I can download and test it. If it works for me but not for you, I'll need new debug files though. We have made significant changed to the log files produces in the 6.7.x versions, which makes logs produced with them much more useful for figuring out problems.

nickhere
Posts: 138
Joined: Sat Jan 03, 2015 3:28 am

Re: I am surprised no iso dvd audio

Post by nickhere » Fri Aug 04, 2017 1:36 pm


Nadahar
Posts: 1813
Joined: Tue Jun 09, 2015 5:57 pm

Re: I am surprised no iso dvd audio

Post by Nadahar » Sat Aug 05, 2017 1:31 am

Thank you for the sample. I've confirmed the problem and created an issue here. It seems to be a problem with MEncoder, which is the only transcoding engine we have that's capable of reading DVD ISOs. The project is more or less abandoned though, so if we can't find a workaround I doubt it will be fixed.

I'm not able to debug MEncoder, I know way to little about the code to even know where to start, not to mention that I don't even know how to build it (although I'm sure I could figure that out if spending enough time). SubJunk (the project owner) used to be a developer at MPlayer/MEncoder, so hopefully he can figure it out. Follow the GitHub issue if you want to track any progress.

User avatar
Sami32
Posts: 852
Joined: Mon Apr 11, 2016 5:09 am

Re: I am surprised no iso dvd audio

Post by Sami32 » Sat Aug 05, 2017 6:34 am

Hello @nickhere,

Could you try to add these lines into your renderer's configuration file, and take the time to report feedback ?

Code: Select all

DisableMencoderNoskip = true
CustomMencoderOptions = -mc 0
or replace them by that one instead:

Code: Select all

CustomMencoderOptions = -psprobe 10000
or

Code: Select all

CustomMencoderOptions = -demuxer lavf
Note: I guess that you was not able to find your own issue ? as posting in it will have make it appear as that one, avoidind the opening of a duplicated one without all the log or explanation that was shared at that time.
Last edited by Sami32 on Sat Aug 05, 2017 8:26 am, edited 1 time in total.

nickhere
Posts: 138
Joined: Sat Jan 03, 2015 3:28 am

Re: I am surprised no iso dvd audio

Post by nickhere » Sat Aug 05, 2017 7:08 am

CustomMencoderOptions = -demuxer lavf

Give me sound but on another iso it plays too fast

User avatar
Sami32
Posts: 852
Joined: Mon Apr 11, 2016 5:09 am

Re: I am surprised no iso dvd audio

Post by Sami32 » Sat Aug 05, 2017 8:28 am

Do we need to do a donation to get a log ;-)
As i cannot afford to download a such big file, and i wasn't even a part of the team at the time you've posted your issue...

1) So, the ISO with no sound worked correctly with "CustomMencoderOptions = -demuxer lavf" ?

2) Is that was your only ISO having no sound ?

3) Did you mean that all your others ISO play faster with that option, or only one ?

nickhere
Posts: 138
Joined: Sat Jan 03, 2015 3:28 am

Re: I am surprised no iso dvd audio

Post by nickhere » Sat Aug 05, 2017 2:08 pm

1 yes
2 no
3 other iso seem to skip even one with perfect sound

I will need some time to fiqure it out but some iso were compress from 8gb to 4gb
i will create a web server so you can download and test

Post Reply