Landing folder

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
User avatar
valib
Developer
Posts: 653
Joined: Fri Feb 08, 2013 3:11 am

Re: Landing folder

Post by valib » Fri Dec 15, 2017 9:29 am

HT1 do you have in the UMS.conf only

Code: Select all

folders = \\\\192.168.1.50\\tv\\new stuff
? If you have set only that and your TV is showing only the "tv" folder than this is a problem of your TV. Next time please follow the rules written in red above because is better to see the debug.log and UMS.conf together with the problem description.

EDIT: what about the web interface? What it shows?

HT1
Posts: 122
Joined: Thu Mar 05, 2015 12:30 pm

Re: Landing folder

Post by HT1 » Fri Dec 15, 2017 10:04 am

> HT1 do you have in the UMS.conf only
yes that is all.

web interface, i see the same thing, stuff to watch and web and jumpy. see attached screenshot

it's always shown just that, it is not my TV.
umswebinterface.PNG
umswebinterface.PNG (227.59 KiB) Viewed 2329 times
Win 10 64bits java 8
Qnap TS-212 2x3TB WD Red
Sony Bravia MN (my conf)

User avatar
valib
Developer
Posts: 653
Joined: Fri Feb 08, 2013 3:11 am

Re: Landing folder

Post by valib » Fri Dec 15, 2017 10:21 am

HT1 we can try the last test. Add the \\ at the end of the folder description in the UMS.conf and test it.

HT1
Posts: 122
Joined: Thu Mar 05, 2015 12:30 pm

Re: Landing folder

Post by HT1 » Fri Dec 15, 2017 8:50 pm

i added a double backslash in the conf file, yes i shutdown ums before and started it after editing, but network interface shows the same thing as above.
Win 10 64bits java 8
Qnap TS-212 2x3TB WD Red
Sony Bravia MN (my conf)

boss
Posts: 202
Joined: Thu Jun 30, 2016 1:07 pm

Re: Landing folder

Post by boss » Fri Dec 15, 2017 11:59 pm

What about if you use the share "name" instead of the IP address.
Like: \\sharename\tv\new stuff

Other things you could try is to change: \\192.168.1.50\tv\new stuff
To: "\\192.168.1.50\tv\new stuff"
Change: the new stuff folder name to new_stuff
And change the target folder in UMS to \\192.168.1.50\tv\new_stuff
Some devices don't like spaces.

HT1
Posts: 122
Joined: Thu Mar 05, 2015 12:30 pm

Re: Landing folder

Post by HT1 » Sat Dec 16, 2017 9:43 am

boss wrote:
Fri Dec 15, 2017 11:59 pm
What about if you use the share "name" instead of the IP address.
Like: \\sharename\tv\new stuff
tried and same.

boss wrote:
Fri Dec 15, 2017 11:59 pm
Other things you could try is to change: \\192.168.1.50\tv\new stuff
To: "\\192.168.1.50\tv\new stuff"
Change: the new stuff folder name to new_stuff
And change the target folder in UMS to \\192.168.1.50\tv\new_stuff
Some devices don't like spaces.
tried and same.

it's just how ums is. It tells the renderer, my tv and browser, what to display.

I think we've exhausted all we can do on the user end, can we check the code to see if it supposed to work with long paths/urls ?
Win 10 64bits java 8
Qnap TS-212 2x3TB WD Red
Sony Bravia MN (my conf)

User avatar
valib
Developer
Posts: 653
Joined: Fri Feb 08, 2013 3:11 am

Re: Landing folder

Post by valib » Sun Dec 17, 2017 1:09 am

HT1 we are in the circle. I think that I misunderstand your last answer to Nadahar and I tried to solve something what would never work. Now I see that my first feeling of your original request was right and Nadahar's and also my reaction that would require wery big effort to change the UMS behaviour was right. And yes UMS supports long paths/url so we not need to check it.

HT1
Posts: 122
Joined: Thu Mar 05, 2015 12:30 pm

Re: Landing folder

Post by HT1 » Sun Dec 17, 2017 6:05 pm

well, say what you will but it just doesn't work for long paths.

but it shouldn't be that hard to fix. just substitute one folder for another to the renderer.

i men, clearly it's not just me, it's everybody, so why not make your users happy.
Win 10 64bits java 8
Qnap TS-212 2x3TB WD Red
Sony Bravia MN (my conf)

User avatar
valib
Developer
Posts: 653
Joined: Fri Feb 08, 2013 3:11 am

Re: Landing folder

Post by valib » Sun Dec 17, 2017 10:34 pm

HT1 I don't understand what do you mean that UMS doesn't work for long paths. Can you explain it more and give some example? The best way how to explain it is to browse some long path which doesn't work for you and send the log.

Nadahar
Posts: 1439
Joined: Tue Jun 09, 2015 5:57 pm

Re: Landing folder

Post by Nadahar » Mon Dec 18, 2017 2:42 am

HT1 it's not easy to fix when you can't even clearly explain the problem. I am still very much unsure what the problem is. If the problem is that you have to enter the shared folder before you see the content, it is by design. You can have more than one shared folder, and UMS' "root folder" can only contain other folders - the shared folders.

If the problem is something else, please make some screenshots to show us.

Post Reply