UMS 3.0.0-a5

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
crack00r
Posts: 7
Joined: Fri Sep 13, 2013 7:45 pm

UMS 3.0.0-a5

Post by crack00r » Fri Sep 13, 2013 7:48 pm

Hi, i have a Problem with UMS 3.0.0-a5
On 1st install and start it runs ok
but after reboot, i just get this error in log

Anyone know some help?
2.6.5 runs ok

Code: Select all

09-13 09:44:28  Found plugin: com.sharkhunter.channel.CH_plugin
09-13 09:44:28  Exception in thread "main" java.lang.VerifyError: class com.chocolatey.pmsencoder.PMSEncoder overrides final method launchTranscode.(Ljava/lang/String;Lnet/pms/dlna/DLNAResource;Lnet/pms/dlna/DLNAMediaInfo;Lnet/pms/io/OutputParams;)Lnet/pms/io/ProcessWrapper;
09-13 09:44:28  	at java.lang.ClassLoader.defineClass1(Native Method)
09-13 09:44:28  	at java.lang.ClassLoader.defineClass(Unknown Source)
09-13 09:44:28  	at java.security.SecureClassLoader.defineClass(Unknown Source)
09-13 09:44:28  	at java.net.URLClassLoader.defineClass(Unknown Source)
09-13 09:44:28  	at java.net.URLClassLoader.access$100(Unknown Source)
09-13 09:44:28  	at java.net.URLClassLoader$1.run(Unknown Source)
09-13 09:44:28  	at java.net.URLClassLoader$1.run(Unknown Source)
09-13 09:44:28  	at java.security.AccessController.doPrivileged(Native Method)
09-13 09:44:28  	at java.net.URLClassLoader.findClass(Unknown Source)
09-13 09:44:28  	at java.lang.ClassLoader.loadClass(Unknown Source)
09-13 09:44:28  	at java.lang.ClassLoader.loadClass(Unknown Source)
09-13 09:44:28  	at java.lang.Class.getDeclaredConstructors0(Native Method)
09-13 09:44:28  	at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
09-13 09:44:28  	at java.lang.Class.getConstructor0(Unknown Source)
09-13 09:44:28  	at java.lang.Class.newInstance0(Unknown Source)
09-13 09:44:28  	at java.lang.Class.newInstance(Unknown Source)
09-13 09:44:28  	at net.pms.external.ExternalFactory.instantiateEarlyListeners(ExternalFactory.java:419)
09-13 09:44:28  	at net.pms.external.ExternalFactory.lookup(ExternalFactory.java:399)
09-13 09:44:28  	at net.pms.PMS.init(PMS.java:658)
09-13 09:44:28  	at net.pms.PMS.createInstance(PMS.java:1033)
09-13 09:44:28  	at net.pms.PMS.main(PMS.java:1129)
Attachments
ums_dbg.zip
(12.85 KiB) Downloaded 139 times

orgon3
Posts: 33
Joined: Fri Jun 15, 2012 7:12 pm

Re: UMS 3.0.0-a5

Post by orgon3 » Tue Sep 24, 2013 2:40 pm

I get a separate issue, but similar enough to post in the same thread I guess. Attached is my debug log. Latest Java 7u40 64bit (is being used by default by the program, finally :P). Pretty default install options (Clean Install of course) and just set it up for my network.
Attachments
ums_dbg.zip
(22.32 KiB) Downloaded 139 times

User avatar
DeFlanko
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: UMS 3.0.0-a5

Post by DeFlanko » Tue Sep 24, 2013 4:51 pm

These are plugin errors that are not yet compatible with 3.0.0-a5

...also noticed you have a SCH-I545...ill add that to the list.. =)

orgon3
Posts: 33
Joined: Fri Jun 15, 2012 7:12 pm

Re: UMS 3.0.0-a5

Post by orgon3 » Tue Sep 24, 2013 5:04 pm

DeFlanko wrote:These are plugin errors that are not yet compatible with 3.0.0-a5

...also noticed you have a SCH-I545...ill add that to the list.. =)
Whoops. There I go, jumping to conclusions on my Jump To Conclusions mat. Sorry for the trouble. And yes, my roommate does have an S4, and would actually use it to stream, lol. Thanks a lot for everything!

(also, would you know any reason why only tsmuxer shows up on the Sharp Aquos? I am just confused as to why it wouldn't accept a transcoded stream. It shouldn't know the difference..........)

User avatar
DeFlanko
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: UMS 3.0.0-a5

Post by DeFlanko » Tue Sep 24, 2013 5:13 pm

no idea lol

Wolfgan
Posts: 371
Joined: Fri Feb 08, 2013 12:33 am

Re: UMS 3.0.0-a5

Post by Wolfgan » Wed Sep 25, 2013 8:33 am

In relation to the wrong container detected (see viewtopic.php?f=3&t=1147&start=20#p7140), I found some clue on going thru the logs. It seems ffmpeg detects various containers on the streams:

Code: Select all

DEBUG 2013-09-24 17:02:40.280 [Thread-32] Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'E:\zInetTransfer\!(0TV) Various\Bones.S09E02.HDTV.x264-LOL.mp4':
DEBUG 2013-09-24 17:02:40.280 [Thread-32]   Metadata:
DEBUG 2013-09-24 17:02:40.280 [Thread-32]     major_brand     : isom
DEBUG 2013-09-24 17:02:40.280 [Thread-32]     minor_version   : 1
DEBUG 2013-09-24 17:02:40.280 [Thread-32]     compatible_brands: isom
Full logs attached for further review. Thanks! Wolf
Attachments
ums_dbg.zip
Debug logs
(15.92 KiB) Downloaded 141 times
-- UMS serving PS3, WDTV, Samsung H6400 + J5500 and Kalemsoft renderers! (no video transcoding but remuxing accepted :D )

Post Reply