[Solved] An Unexpected Error and I can't fix it

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
wurstpistole
Posts: 12
Joined: Mon Apr 23, 2018 6:33 pm

[Solved] An Unexpected Error and I can't fix it

Post by wurstpistole » Mon Apr 23, 2018 6:40 pm

Hi,
I have regular problems on my Samsung UHD KS7090.
For some files (I Can not make out a pattern) I get the unexpected error, regardless of which video engine I use.
The files are ok, must be some kind of special codec that UMS doesn't like I guess.

Here is my log, playing the file does not produce an error:

https://pastebin.com/4msy9axz

I use this renderer, which fixed some of the files that do not work, but not all of them.

I recently formatted and set up my PC fresh again, and I can not remember having those problems before that. But I didn't do any special or fancy settings before. It just worked.
What can I do to fix this?

[Edit]
I tried something else, I opened the Transcode folder and tried out all the engines. None of them work.
Playing without Transcoding works.

Furthermore I just opened the files in MediaInfo to find out maybe what is causing this. Here's one file that doesn't work:

https://pastebin.com/PqhZngJU

Here is another file that doesn't work:

https://pastebin.com/jwH3RiRA

And here is a file that does work fine:

https://pastebin.com/n0fEH5nk

Any idea why File 3 works, but 2 and 1 don't?

User avatar
valib
Developer
Posts: 685
Joined: Fri Feb 08, 2013 3:11 am

Re: An Unexpected Error and I can't fix it

Post by valib » Tue Apr 24, 2018 1:55 am

@wurstpistole please follow Forum rules written in red above and send the log here but now in the TRACE mode. "Info" you provided at https://pastebin.com/4msy9axz is useless.

wurstpistole
Posts: 12
Joined: Mon Apr 23, 2018 6:33 pm

Re: An Unexpected Error and I can't fix it

Post by wurstpistole » Tue Apr 24, 2018 7:41 am

Oh alright, I was in a hurry and didn't realize it. Here's the file attached.
It shows me trying to play File A that doesn't work, then File B that doesn't work, then File C that does work.
Maybe one can shed a light.
I add again that for the two files that do not work it does not matter which video engine I use. Some of them show Check network connection, some show unexpected error and Avisynth/MEncoder just shows a loading circle and nothing happens.
For my Trace log, I decided to go with MEncoder which shows the unexpected error.

Judging from that prior to my Windows 10 re-setup I never had this problem, and I also did not use any custom renderer but just standard settings - maybe I have some codec missing on my system that UMS would want to utilize but can't since it's not there? Pretty sure I had K-Lite Codec Pack installed through the years. Just an idea.
Attachments
ums_dbg.zip
(85.44 KiB) Downloaded 171 times

User avatar
valib
Developer
Posts: 685
Joined: Fri Feb 08, 2013 3:11 am

Re: An Unexpected Error and I can't fix it

Post by valib » Wed Apr 25, 2018 8:59 am

In your Samsung-UHD.conf are wrong descriptions of audio codecs. The "aac" instead of "aac-lc" and "aac-he" instead of "he-aac" that is why videos are transcoded not directly streamed. Here is an updated conf.
Samsung-UHD.conf
(6.53 KiB) Downloaded 253 times
EDIT: supported formats and their abbreviations are listed in the DefaultRenderer.conf

wurstpistole
Posts: 12
Joined: Mon Apr 23, 2018 6:33 pm

Re: An Unexpected Error and I can't fix it

Post by wurstpistole » Wed Apr 25, 2018 5:57 pm

Thanks, I tried it and the previously non-working files now instantly run.
Oddly enough I never used a custom renderer like that on my old Windows 10 setup and never had a problem.

Post Reply