Version 7.4 standalone eats up memory

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
turbo78
Posts: 13
Joined: Wed Sep 11, 2013 5:30 am

Version 7.4 standalone eats up memory

Post by turbo78 » Wed Oct 03, 2018 3:16 am

As I mentioned in announcment thread, Before this version I have not tried any standalone versions, and with olders I did not have this problem...

I use Win 10 64bit.

When I start UMS everything is ok, I can play anything on my TV (Panasonic ST50 series).

After a playback when I leave the server and watch some TV I can not go back to server it says can not connect to server when it has to read out contents of a folder.

I then open UMS on PC and everything seems fine, except the PC is slow... Then I go to task manager and figured out that JAVA TM Platform SE Binary have eaten up all my available memory, the processor time is not at 100% it is about 25-30% on a i5 processor with 4 cores.

I have to close the process, and restart UMS again to can play back something on my TV.

I try to start UMS as standard and also as administrator, but in every way I end up with eaten up memory after one use of UMS.

I uploaded a log also, tell me if I need to do anything else to get you some info.
Attachments
ums_dbg.zip
(3.65 MiB) Downloaded 88 times

User avatar
SubJunk
Lead Developer
Posts: 3009
Joined: Sun May 27, 2012 4:12 pm

Re: Version 7.4 standalone eats up memory

Post by SubJunk » Fri Oct 12, 2018 6:57 pm

Hi turbo78, thanks for this.
Have you tried the regular release of 7.4.0 (not standalone)? Also how about 7.3.0?

AVARIAS
Posts: 1
Joined: Thu Nov 01, 2018 11:07 pm

Re: Version 7.4 standalone eats up memory

Post by AVARIAS » Thu Nov 01, 2018 11:36 pm

Hi,

I also have the same problem, since I formatted my computer in September. I have installed the latest version of the standalone 7.5.0, and after some time the memory shoots through the roof and can't do anything else. It will keep rendering what I'm currently watch, but if I change to something else, it won't buffer. I can browse between folders, but that's pretty much what allows m to do. I check the processes and see that the memory it's never less than 1200Mb, most of the times more than 1400Mb and the CPU around 25% to 30%. Last weekend I have formatted my computer again, installed earlier versions for the standalone, still the same issue, then I tested the regular release for version 7.5.0, also the same problem. I was going to try to uninstall this version and try an older version, but I didn't had the time to do it.

I also followed the steps to create the TRACE logs, but when the UMS restarts, it just hangs on the logo and stays there until I shut down the services.

Anything else that you can recommend for me to try?

Thanks in advance. ;)
Attachments
debug.log.prev.zip
(1.18 MiB) Downloaded 81 times

Post Reply