How to share a mapped drive

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
turbo78
Posts: 13
Joined: Wed Sep 11, 2013 5:30 am

How to share a mapped drive

Post by turbo78 » Tue Mar 12, 2019 6:55 am

Hi to Everyone!
I have a problem.
I recently get a Thecus 4520 NAS, and copyed there all my movies and audio collection... and here comes the trouble...
I Have mapped the shared folder from the NAS on Windows 10, it's now drive X:
I can see it from WIN, can play back everything...
Tried to share drive X: in UMS but the folder not appears on my TV. I have only the real drives from my computer (D: and L:) but there is no X:, so I can not see my NAS on the TV
I can not manage to install any DLNA software to the nas to connect id directly, and I really like to use UMS so it would be nice to get it work to use the mapped folder trough the UMS.
Can anyone help me?

If it is important, the PC uses Windows 10 with all the actual updates, UMS is 8.0 RC1, on Thecus is OS6

Nadahar
Posts: 1681
Joined: Tue Jun 09, 2015 5:57 pm

Re: How to share a mapped drive

Post by Nadahar » Tue Mar 12, 2019 8:11 am

As long as it's mapped to a drive letter it should work just fine. I do the same myself with no problem. The only thing I can think of is that you didn't restart UMS after adding the shared folder, or that there is some permission issue.

Did you restart UMS after adding the new shared folder?

turbo78
Posts: 13
Joined: Wed Sep 11, 2013 5:30 am

Re: How to share a mapped drive

Post by turbo78 » Wed Mar 13, 2019 3:10 am

From the first time I added the mapped drive I did restart the PC, the UMS and the NAS several times, but still the mapped drive is not present on my TV when I access UMS,,,

turbo78
Posts: 13
Joined: Wed Sep 11, 2013 5:30 am

Re: How to share a mapped drive

Post by turbo78 » Wed Mar 13, 2019 3:14 am

now I noticed these lines in the LOG, but do not know why is that happening

16:00:24 INFO Checking shared folder: "X:\"
16:00:24 WARN "X:\" does not exist. Please remove it from your shared folders list on the "!LooksFrame.22!" tab or in the configuration file.

Nadahar
Posts: 1681
Joined: Tue Jun 09, 2015 5:57 pm

Re: How to share a mapped drive

Post by Nadahar » Wed Mar 13, 2019 4:29 am

Your log information clearly indicates that UMS can't "find" the drive. I guess you should look into both permissions and how you do the mapping. Are you using normal Windows file sharing/CIFS by running Samba or similar on the NAS, or do you use some less standard way? You should also make sure that the drive is mapped before you start UMS. If you don't map it in your login script, you should enable "reconnect on login" or whatever the option is called, which makes Windows set up the mapping during the login process.

It could also be that the user under which UMS is running doesn't have read permissions to the share. If that's the case, it won't be "visible" for UMS and the effect will be the same.

Post Reply