Disable Resume Video

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Raynor98
Posts: 5
Joined: Sat Feb 02, 2019 9:44 am

Disable Resume Video

Post by Raynor98 » Sat Apr 20, 2019 7:12 pm

Hello again people. i still need help trying to disable the resume video from last position. i have all Samsung tvs and no matter what i set in the UMS.conf for video resuming it still starts where i stopped. i do not like this feature and would like to get rid of it completely. i did come across this today and would like help on how to disable it completely.

Code: Select all

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
    <s:Body>
        <u:X_SetBookmark xmlns:u="urn:schemas-upnp-org:service:ContentDirectory:1">
            <ObjectID>73</ObjectID>
            <PosSecond>59</PosSecond>
            <CategoryType>0</CategoryType>
            <RID>0</RID>
        </u:X_SetBookmark>
    </s:Body>
</s:Envelope>
Thank you in Advance. looking to stop this frustration once and for all
ums_dbg.zip
(85.15 KiB) Downloaded 34 times

User avatar
mik_s
Moderator
Posts: 56
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: Disable Resume Video

Post by mik_s » Sun Apr 21, 2019 12:59 pm

Just turn off "Enable video resuming" in Navigation settings. If the video still resumes from last position then it is your TV that is doing it.
I tried it on my Samsung TV and it does resume on its own, not sure if you can disable that feature.
The media player in Samsung TVs are fairly crap so i use a different renderer, and that has an option to auto resume or ask to resume when playing a partially watched video.

Raynor98
Posts: 5
Joined: Sat Feb 02, 2019 9:44 am

Re: Disable Resume Video

Post by Raynor98 » Mon Apr 22, 2019 7:28 am

It is unchecked. and set to false in the UMS.conf and it still resumes.

Fnative2
Posts: 2
Joined: Tue Dec 18, 2018 10:10 am

Re: Disable Resume Video

Post by Fnative2 » Mon Apr 22, 2019 8:51 pm

Same problem here.

I got 2 TVs UE40F8000 and UE46F8000 both connected to UMS on my PC. After 7.6.0 version (since the "Allshare" prefix has been added to server's name) I don't know how to disable it.
If some video file (mkv) has been played on first device (e.g. UE40) and stopped on titles moment in the end of it, the second TV (UE46) will start this file right from the moment it was stopped by the first device.

Auto-resume function is unchecked. Please fix this bug. I'm using 7.5.0 now without auto-resuming.

Raynor98
Posts: 5
Joined: Sat Feb 02, 2019 9:44 am

Re: Disable Resume Video

Post by Raynor98 » Tue May 14, 2019 1:28 pm

Updated to 8.1.0 and still having issues with the video resuming where i left off.

Code: Select all

TRACE 2019-05-13 19:15:14.355 [HTTPv2 Request Worker 13] Searching FILES_STATUS with "SELECT BOOKMARK FROM FILES_STATUS WHERE FILENAME = 'T:\Torrent\Career.Opportunities.1991.WEBRip.x264-RARBG\Career.Opportunities.1991.WEBRip.x264-RARBG.mkv'"
DEBUG 2019-05-13 19:15:14.355 [HTTPv2 Request Worker 13] Setting bookmark for T:\Torrent\Career.Opportunities.1991.WEBRip.x264-RARBG\Career.Opportunities.1991.WEBRip.x264-RARBG.mkv => 59
TRACE 2019-05-13 19:15:14.358 [HTTPv2 Request Worker 13] Response sent to [TV]Samsung LED32 [Samsung E+ Series]:
ums_dbg.zip
(490.77 KiB) Downloaded 29 times

mikeaoller
Posts: 31
Joined: Sat Sep 22, 2012 9:09 am

Re: Disable Resume Video

Post by mikeaoller » Wed May 22, 2019 10:21 pm

I have exactly the same issue (on PS4 with 8.1.0 standalone x64) - video does still resume, even after unchecking "Enable video resuming".

But I do only see this behaviour when defaulting to MEncoder Video. In my case, if I set FFmpeg Video as the default engine, unchecking "Enable video resuming" works.

As my Russian .srt subtitles do only work with MEncoder, this behaviour is very annoying for me, and it would be great if this could be fixed quickly.

Raynor98
Posts: 5
Joined: Sat Feb 02, 2019 9:44 am

Re: Disable Resume Video

Post by Raynor98 » Thu Aug 08, 2019 8:04 pm

After updating to 9.0b2 i still have this issue. with everything disabled or unchecked for resuming the video. i found that if i uncheck http v2 engine the problem goes away, no more resuming of any video.
also i do not see any issues with UMS since the disable of HTTP v2 engine as of yet. if the Dev could look into the why the http v2 engine is overriding the settings in this area and show a possible fix that would be awesome.

Post Reply