Disable Subtitles in new version?

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
ravenfaust
Posts: 9
Joined: Tue Dec 03, 2013 2:20 pm

Disable Subtitles in new version?

Post by ravenfaust » Tue Dec 03, 2013 2:22 pm

when i play a video and there is a subtitle file in the folder, it now plays along wiht the video, before the latest version it did not do this ,how can i disable subtitles to autoplay?

User avatar
DeFlanko
Posts: 724
Joined: Thu Jun 21, 2012 3:43 am
Location: San Pedro, CA
Contact:

Re: Disable Subtitles in new version?

Post by DeFlanko » Tue Dec 03, 2013 4:28 pm

see if this box is checked:
Image

Casper
Posts: 32
Joined: Wed Jul 24, 2013 10:20 pm

Re: Disable Subtitles in new version?

Post by Casper » Tue Dec 03, 2013 7:56 pm

By default, english subtitles shouldn't display if the audio track is english.
The default value for the "Audio/subtitle language priority" setting for English users is:

Code: Select all

eng,off;*,eng;*,und
Which means:
If the audio is English, turn subtitles off. If the audio is anything else, display either English or Undefined subtitles.
http://www.universalmediaserver.com/faq/#Video3

Edit: I just tested and subtitles are incorrectly displaying so it seems the Audio/subtitle language priority setting is not working as intended.

ExSport
Posts: 596
Joined: Wed Oct 10, 2012 1:57 am

Re: Disable Subtitles in new version?

Post by ExSport » Wed Dec 04, 2013 4:21 am

ravenfaust wrote:when i play a video and there is a subtitle file in the folder, it now plays along wiht the video, before the latest version it did not do this ,how can i disable subtitles to autoplay?
Yesterday I played subtitles in Radio and it worked 8-)
Now seriously. What about to write more info? What renderer used??? If renderer supports subtitles, UMS will not burn them into the picture but send them as is (I suppose Audio/Sub settings is not taken into account in this case).
If it is your case (Samsung TV, PanTV,...), you have to disable them on TV. UMS sends separate subs only, TV is the culprit which loads them.

User avatar
SubJunk
Lead Developer
Posts: 2954
Joined: Sun May 27, 2012 4:12 pm

Re: Disable Subtitles in new version?

Post by SubJunk » Sat Dec 07, 2013 3:06 pm

It's likely that the subtitle file has not defined its language

Post Reply