ump as a service

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
nectovelius
Posts: 3
Joined: Fri Jul 20, 2012 5:55 am

ump as a service

Post by nectovelius » Fri Jul 20, 2012 5:57 am

installed as a windows service
the service is started both cant find ump from any devices...
also how do i change the settings when installed as a service?

Thanks

UMS User
Posts: 1
Joined: Fri Jul 20, 2012 6:56 am

Re: ump as a service

Post by UMS User » Fri Jul 20, 2012 7:22 am

I cant get the service to work either; it runs, but my ps3 cannot find it.

The only way for UMS to show up is if I start up the program manually, and often I'll have to continually switch ports between 5001 and 6001 in order for it to detect the ps3.
ums_dbg.zip
(3.74 KiB) Downloaded 287 times
nectovelius wrote: ...how do i change the settings when installed as a service?
Thanks
Open up the service's properties and choose 'Log On-->Log On As:This Account' then type in your accounts user name and password.
Open up the program, make whatever changes you need, press save, then press restart server.

Triplefun
Posts: 136
Joined: Sat Jun 02, 2012 2:29 pm

Re: ump as a service

Post by Triplefun » Mon Jul 23, 2012 8:20 am

make sure you have opened up TCP port 5001 in the firewall. Also, to change the settings you need to stop the service, run UMS console and change the settings, save the settings, quit, and then retstart the service.

nectovelius
Posts: 3
Joined: Fri Jul 20, 2012 5:55 am

Re: ump as a service

Post by nectovelius » Thu Jul 26, 2012 4:16 am

Triplefun wrote:make sure you have opened up TCP port 5001 in the firewall. Also, to change the settings you need to stop the service, run UMS console and change the settings, save the settings, quit, and then retstart the service.
it is, the program works fine when only the service isn't working, i'd find it much more convenient to get it working as a service. Had the same problem with PMS tried this one hoping it'd be better but if I can't resoleve this, i'll go back.

Triplefun
Posts: 136
Joined: Sat Jun 02, 2012 2:29 pm

Re: ump as a service

Post by Triplefun » Thu Jul 26, 2012 8:21 am

What operating system are you running. I have no trouble running it on WHS v1 using the UMS prompt - note you need to rerun the prompt everytime you do a new install. Once installed as service go to the service manager and check the properties (set start to Automatic). You can also load it as a service using the Windows tools for your operating system (see Google).

nectovelius
Posts: 3
Joined: Fri Jul 20, 2012 5:55 am

Re: ump as a service

Post by nectovelius » Thu Jul 26, 2012 9:00 am

im on win7, I did make sure the service was running, but neither ps3 nor any of my other device would see it (ipad, tv, xbox). As mentionned I am only having issues with the service. Rebooted, stopped, restarted the service. I am guessing it needs something else done but did find what so far.

unknownsoldierx
Posts: 2
Joined: Mon Jan 28, 2013 9:30 am

Re: ump as a service

Post by unknownsoldierx » Mon Jan 28, 2013 9:34 am

Anyone find the solution to this?

I've set the service to run using my user account, but UMS still doesn't work when running as a service. Works when not running as a service.

User avatar
SubJunk
Lead Developer
Posts: 2955
Joined: Sun May 27, 2012 4:12 pm

Re: ump as a service

Post by SubJunk » Mon Jan 28, 2013 5:15 pm

Maybe try uninstalling the service (there's a button for that now on the General Configuration tab) then install it again

unknownsoldierx
Posts: 2
Joined: Mon Jan 28, 2013 9:30 am

Re: ump as a service

Post by unknownsoldierx » Mon Jan 28, 2013 7:42 pm

Tried that a few times already.

SpeedyQ
Posts: 173
Joined: Tue Jul 03, 2012 9:43 pm

Re: ump as a service

Post by SpeedyQ » Tue Jan 29, 2013 8:14 am

Maybe you want to install UMS as Administrator and the make the run as service change also while being Administrator.
I have had this problem before and I think it is worth a try... ;)

Post Reply