Page 1 of 1

PS3 Folder Limit & How You Navigate w/Controler

Posted: Sat Nov 17, 2012 5:32 pm
by gottoast
OK, I've been beating my head against this for a couple days and think I've stumbled on to something... at least I hope so, since I've not found anything like it on the boards.

It has to do with the folder limits in the PS3 and how you use your PS3 controller to browse through the Channel menus. My theory is only use the X and O buttons to execute your selections, X to make a selection (your only choice) and O to exit or back out one level (the Directional pad can also do this but this is where I think the issue happens). My thought is if the left directional pad button is used to back up a level it does something to confuse the folder limit and not properly executed or registered but I'm not sure if that's because of the PS3 or in UMS. When using the directional button I eventually get the following:

[New I/O server worker #1-1] Depth limit potentionally hit for "whatever it was I tried to view"

Followed by:

[New I/O server worker #1-1] setting folder lim ChannelPMSSaveFolder [id=11, name="whatever it was I tried to view", full path=0$8$11$3$2$141$16$11, ext=null, discovered=false]

And from then on nothing is viewable on the PS3 until I reboot both it and UMS.

To test this I rebooted both the PS3 & UMS and used only X and O to execute as described above in IceFilms and was able to view 3-4 shows without one problem!Then to verify the directions button would force a folder limit used it to back out 3 levels and selected another show from a folder I had previously accessed. Like clockwork it gave me the notorious "THIS CONTENT CANNOT BE PLAYED. (800288E1)" error. I checked the logs and sure enough it said the Depth limit was hit.

I zipped the logs and have attached, I have some more tests in mind to either prove or disprove and will post.

*** Should also mention that I have the folder_limit=true set in the UMS.conf and once this happens the Folder Limit trick on the PS3 might work the first time but that is all, it doesn't seem to clear or reset upon new folder limits.

Re: PS3 Folder Limit & How You Navigate w/Controler

Posted: Sat Nov 17, 2012 5:40 pm
by gottoast
In test 2 I simply wanted to find out if restarting the UMS would clear things up so I could at least view 1 show on IceFilms.

I shutdown and restarted UMS. Then without rebooting the PS3 or turning on/off the Media Server setting browsed straight to a show I had just previously accessed and watched and it failed. Giving me the "THIS CONTENT CANNOT BE PLAYED. (800288E1)" Viewed the logs and there it was at the bottom again, Depth limit potentionally hit (which is misspelled btw :D )

Zipped up the logs and attached.

On to test 3.....

Re: PS3 Folder Limit & How You Navigate w/Controler

Posted: Sat Nov 17, 2012 6:07 pm
by gottoast
Well this one my have disproved it, used only X and O buttons, was able to view 1 new show that I hadn't tried before and then the folder limit hit and nothing was viewable... :cry: hmm seems very random now. Zipped up the logs again and have one more test in mind.

Re: PS3 Folder Limit & How You Navigate w/Controler

Posted: Sun Nov 18, 2012 6:43 am
by gottoast
Test 4
Removed Folder Limit from the UMS.conf and rebooted both the PS3 & UMS. Using only X & O seems to make no difference. Eventually the folder limit is hit making things unreachable, even tried going as far as I could and adding that point to my Favorites so that maybe I could short cut from the Favorites folder but it will just say the folder is empty. Seems once the folder limit hits and shows up in the logs the PS3 navigation gets really buggy. One second you can open a folder and see the contents the next it is either empty or unreachable. And if you are persistent enough, occasionally view a link, by sometimes trying to open it multiple times.

I'm at a loss :? . I can pretty much view what I want (in IceFilms) if I go directly to it the first time from a fresh reboot of both UMS & the PS3. After that it's hard to tell what I can do once the folder limit pops in the log.

Any and all input is welcome, anyone else using a PS3 having or had this issue? Last set of logs attached :(

Re: PS3 Folder Limit & How You Navigate w/Controler

Posted: Sun Nov 18, 2012 7:10 am
by SharkHunter
The folder limit is a HARD limit within the PS3. No matter what you do you can't go around it. The Folder limit workaround in UMS works as follows. Once you hit the folder limit (and the folder limit is active of course) you MUST back out all the way to the root. On top a folder called "Folder Limit" should be found. Go into that folder and you you should be able to continue to browse.

Re: PS3 Folder Limit & How You Navigate w/Controler

Posted: Sun Nov 18, 2012 8:20 am
by gottoast
Yes, have read several threads on the topic and using the method you describe it fails or at least it may work 1 time but but the once folder depth has been hit and I see it in the log nothing else will be browsable (is that a word? ;) ). If I try to use the "Folder Limit" folder more that one time it will only ever take me back to the folder it was used on the first time, and that usually won't work twice. It's like it's not resetting or clearing the memory each time, then becomes confused causing the rest of the navigation to go buggy. When this happens folders I try to browse that were previously accessible now say empty or no longer have icon images and sometimes for a split second I'll see duplicate files on screen that will then disappear before they can be selected.

I don't know, just seems once "Depth limit potentionally hit" appears in the log navigation through any method becomes near impossible until I reboot.

Also , thanks for the reply, I know you likely have tons of better things to do than instruct a stranger on how to browse folders on his PS3 :lol: I also know, being a technical writer myself, that typing out explanations and instructions is hard, everyone can read something and interpret it differently. So thanks for your efforts!