Windows Server 2008 R2 - UMS - PS3 Configuration

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Ranger187
Posts: 73
Joined: Sun Jun 03, 2012 12:11 am
Contact:

Windows Server 2008 R2 - UMS - PS3 Configuration

Post by Ranger187 »

Ok, I've read a TON of threads and this is all I had to do to get it to work. I even created a VMware session to verify it.

OS: Windows Server 2008 R2
Updates: Run all the windows updates PRIOR

1. Install 64 bit Java, Install UMS

2. Open Server Manager > Add Features > Click DESKTOP EXPERIENCE. You'll reboot after.
Pics and info: http://www.win2008r2workstation.com/themes/

3. Install this: http://www.microsoft.com/en-us/download ... x?id=20424 File name: Windows6.1-KB963697-x64.msu KB: KB963697 and REBOOT after install.

4. Go to Administrative Tools > Windows Firewall with Advanced Security and create 4 rules. These are all PROGRAM type rules
4a. INBOUND RULES -----> New Rule > PROGRAM > This program path > ENTER THE PATH TO UMS.EXE > Allow the connection > Applies to (leave domain/private/public checked) > NAME THE RULE

4b. INBOUND RULES -----> New Rule > PROGRAM > This program path > ENTER THE PATH TO JAVAW.EXE > Allow the connection > Applies to (leave domain/private/public checked) > NAME THE RULE

4c. OUTBOUND RULES -----> New Rule > PROGRAM > This program path > ENTER THE PATH TO UMS.EXE > Allow the connection > Applies to (leave domain/private/public checked) > NAME THE RULE

4d. OUTBOUND RULES -----> New Rule > PROGRAM > This program path > ENTER THE PATH TO JAVAW.EXE > Allow the connection > Applies to (leave domain/private/public checked) > NAME THE RULE

5. Go to Administrative Tools > Services and enable these services, changing the startup type to: AUTOMATIC
Windows Audio / SSDP Discovery / UPnP Device Host.

After doing that, it will appear in the XMB on the PS3/Xbox etc.

You can adjust the security ie: domain/private/public if you wish but I left them all checked.

I hope this helps others running a server os. This is the exact way I set up EVERY Server 2008 R2 box in my house and it works 100%.
Post Reply