[SOLVED]Sony BDP-S590 - 2012 US Models ONLY

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Ranger187
Posts: 73
Joined: Sun Jun 03, 2012 12:11 am
Contact:

[SOLVED]Sony BDP-S590 - 2012 US Models ONLY

Post by Ranger187 »

I've since updated this original post to have all the relevant information which I will continuously update if I find better settings.


=====================================================================================================
UPDATE HERE IS THE FINAL CHANGES MADE TO MAKE THE SONY BDP-S590 STREAM NEARLY EVERYTHING TOSSED TO IT
=====================================================================================================

Code: Select all

#----------------------------------------------------------------------------
# Profile for Sony Blu-ray Players (2010 Bravia Internet Video-enabled models).
# See PS3.conf for a description of all possible configuration options.
#

RendererName=Sony Blu-ray
RendererIcon=sonybluray.png

# ============================================================================
# Sony Bluray uses the following headers:
#
# User-Agent: UPnP/1.0
# X-AV-Client-Info: av=5.0; cn="Sony Corporation"; mn="Blu-ray Disc Player"; mv="2.0";
# X-AV-Physical-Unit-Info: pa="Blu-ray Disc Player";
# ---
# User-Agent: UPnP/1.0 DLNADOC/1.50
# X-AV-Client-Info: av=5.0; cn="Sony Corporation"; mn="Blu-ray Disc Player"; mv="2.0";
# X-AV-Physical-Unit-Info: pa="Blu-ray Disc Player";
# ============================================================================
# The User-Agent strings are too generic to match
#UserAgentSearch=
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(cn="Sony Corporation"; mn="Blu-ray Disc Player")
Video=true
Audio=true
Image=true
SeekByTime=false
TranscodeVideo=MPEGTSAC3
TranscodeAudio=LPCM
DefaultVBVBufSize=true
MuxH264ToMpegTS=false
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
#MimeTypesChanges=
DLNALocalizationRequired=true
#TranscodeExtensions=
#StreamExtensions=
MediaParserV2_ThumbnailGeneration=false

# For Sony Bluray players and Bravia TVs
ForceJPGThumbnails=true
# For Sony Bluray players
ChunkedTransfer=true

# Specs below taken from http://www.sony.co.uk/product/blu-ray-disc-player/bdp-s370#pageType=TechnicalSpecs
# then fine-tuned by lengthy trial and error since so much of that advertised spec is inaccurate.
# US models don't support video/divx mime type but European and Canadian models do.
# Subtitles in mkv files are only displayed if mime type is video/divx.
# Vob subtitles are not supported.
# See also http://forum.serviio.org/viewtopic.php?f=11&t=2004 for more DLNA-related info on these players.

MediaInfo=true
# Supported video formats:
Supported = f:mpegps|mpegts   v:mpeg1|mpeg2     a:ac3|dts|lpcm|mpa|mp3                    m:video/mpeg 
Supported = f:mpegts          v:h264|vc1        a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/vnd.dlna.mpeg-tts
Supported = f:mp4|m4v         v:mp4|h264        a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/mp4
Supported = f:wmv             v:wmv|vc1         a:wma                                     m:video/mp4
######### NON-US MODELS: CHANGE THE FOLLOWING 2 MIME-TYPES TO m:video/divx
Supported = f:avi        v:mp4        a:ac3|lpcm|mpa|mp3                        m:video/mp4
Supported = f:mkv             v:mp4|h264   a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/x-matroska

# Supported audio formats:
Supported = f:wma    n:2   m:audio/mpeg
Supported = f:mp3    n:2   m:audio/mpeg
Supported = f:lpcm   n:2   m:audio/L16   s:48000

# Supported image formats:
Supported = f:jpg   m:image/jpeg

=========================================================
THESE ARE THE ONLY LINES CHANGED IN \Renders\SonyBluray.conf:
=========================================================

Change this line:

Code: Select all

Supported = f:avi|divx        v:divx|mp4        a:ac3|lpcm|mpa|mp3                        m:video/mpeg
To this:

Code: Select all

Supported = f:avi        v:mp4        a:ac3|lpcm|mpa|mp3                        m:video/mp4
Change this line:

Code: Select all

Supported = f:mp4|m4v         v:mp4|h264        a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/mpeg
To this:

Code: Select all

Supported = f:mp4|m4v         v:mp4|h264        a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/mp4
Change this line:

Code: Select all

Supported = f:mkv             v:mp4|divx|h264   a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/x-matroska
To this:

Code: Select all

Supported = f:mkv             v:mp4|h264   a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/x-matroska
Below is the final file with changes.
Attachments
SonyBluray.conf
2013-03-31-5:15pm Edit
(3.01 KiB) Downloaded 591 times
Last edited by Ranger187 on Mon Apr 01, 2013 9:16 am, edited 5 times in total.
Ranger187
Posts: 73
Joined: Sun Jun 03, 2012 12:11 am
Contact:

Re: Sony BDP-S590

Post by Ranger187 »

Changing:

Code: Select all

Supported = f:avi|divx   v:divx|mp4   a:ac3|lpcm|mpa|mp3   m:video/mpeg
To:

Code: Select all

Supported = f:avi|divx   v:divx|mp4   a:ac3|lpcm|mpa|mp3   m:video/mp4
Might have helped....

I do know that Twonky marks all the files as "AVI", whereas UMS marks the same files as mpeg, so is there a way to force mpeg,mp4,m2ts,mkv to transcode as avi?
Ranger187
Posts: 73
Joined: Sun Jun 03, 2012 12:11 am
Contact:

Re: Sony BDP-S590

Post by Ranger187 »

Mental note:

AVI's play if they are xvid. If they are .avi's that are divx it fails.

=======================================================

How would I go about forcing UMS to transcode .avi's that have divx in the media info as an avi instead? (mpeg)....
Ranger187
Posts: 73
Joined: Sun Jun 03, 2012 12:11 am
Contact:

Re: Sony BDP-S590

Post by Ranger187 »

Ranger187
Posts: 73
Joined: Sun Jun 03, 2012 12:11 am
Contact:

Re: Sony BDP-S590

Post by Ranger187 »

So far, this update has alleviated almost all my issues. We are still working on it on the PMS site (oddly I'm getting more support there!)....

All that was changed was the avi and mp4 lines. I bolded it. NOTHING IN UMS thus far needs changed.

Here's my conf for SonyBluray.conf

Code: Select all

#----------------------------------------------------------------------------
# Profile for Sony Blu-ray Players (2010 Bravia Internet Video-enabled models).
# See PS3.conf for a description of all possible configuration options.
#

RendererName=Sony Blu-ray
RendererIcon=sonybluray.png

# ============================================================================
# Sony Bluray uses the following headers:
#
# User-Agent: UPnP/1.0
# X-AV-Client-Info: av=5.0; cn="Sony Corporation"; mn="Blu-ray Disc Player"; mv="2.0";
# X-AV-Physical-Unit-Info: pa="Blu-ray Disc Player";
# ---
# User-Agent: UPnP/1.0 DLNADOC/1.50
# X-AV-Client-Info: av=5.0; cn="Sony Corporation"; mn="Blu-ray Disc Player"; mv="2.0";
# X-AV-Physical-Unit-Info: pa="Blu-ray Disc Player";
# ============================================================================
# The User-Agent strings are too generic to match
#UserAgentSearch=
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(cn="Sony Corporation"; mn="Blu-ray Disc Player")
Video=true
Audio=true
Image=true
SeekByTime=false
TranscodeVideo=MPEGTSAC3
TranscodeAudio=LPCM
DefaultVBVBufSize=true
MuxH264ToMpegTS=false
MuxDTSToMpeg=false
WrapDTSIntoPCM=false
MuxLPCMToMpeg=false
MaxVideoBitrateMbps=0
MaxVideoWidth=0
MaxVideoHeight=0
H264Level41Limited=true
#MimeTypesChanges=
DLNALocalizationRequired=true
#TranscodeExtensions=
#StreamExtensions=
MediaParserV2_ThumbnailGeneration=false

# For Sony Bluray players and Bravia TVs
ForceJPGThumbnails=true
# For Sony Bluray players
ChunkedTransfer=true

# Specs below taken from http://www.sony.co.uk/product/blu-ray-disc-player/bdp-s370#pageType=TechnicalSpecs
# then fine-tuned by lengthy trial and error since so much of that advertised spec is inaccurate.
# US models don't support video/divx mime type but European and Canadian models do.
# Subtitles in mkv files are only displayed if mime type is video/divx.
# Vob subtitles are not supported.
# See also http://forum.serviio.org/viewtopic.php?f=11&t=2004 for more DLNA-related info on these players.

MediaInfo=true
# Supported video formats:
Supported = f:mpegps|mpegts   v:mpeg1|mpeg2     a:ac3|dts|lpcm|mpa|mp3                    m:video/mpeg 
Supported = f:mpegts          v:h264|vc1        a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/vnd.dlna.mpeg-tts
Supported = f:mp4|m4v         v:mp4|h264        a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/mp4
Supported = f:wmv             v:wmv|vc1         a:wma                                     m:video/mp4
######### NON-US MODELS: CHANGE THE FOLLOWING 2 MIME-TYPES TO m:video/divx
Supported = f:avi        v:mp4        a:ac3|lpcm|mpa|mp3                        m:video/mp4
Supported = f:mkv             v:mp4|h264   a:ac3|dts|dtshd|truehd|aac|lpcm|mpa|mp3   m:video/x-matroska

# Supported audio formats:
Supported = f:wma    n:2   m:audio/mpeg
Supported = f:mp3    n:2   m:audio/mpeg
Supported = f:lpcm   n:2   m:audio/L16   s:48000

# Supported image formats:
Supported = f:jpg   m:image/jpeg

Last edited by Ranger187 on Mon Apr 01, 2013 8:30 am, edited 1 time in total.
Ranger187
Posts: 73
Joined: Sun Jun 03, 2012 12:11 am
Contact:

Re: Sony BDP-S590

Post by Ranger187 »

Updated the first post. This solves the Sony BDP-S590 issues.

;)
User avatar
SubJunk
Lead Developer
Posts: 3315
Joined: Sun May 27, 2012 4:12 pm

Re: [SOLVED]Sony BDP-S590 - 2012 US Models ONLY

Post by SubJunk »

Thanks for this, I'll update it in the next release :)
tmeader
Posts: 4
Joined: Thu Mar 07, 2013 11:54 am

Re: [SOLVED]Sony BDP-S590 - 2012 US Models ONLY

Post by tmeader »

This is very close to correct, but there's still issues with AVI files with this config. It's needlessly transcoding them into MP4 when they are XVID (and the 590's can natively play xvid fine as long as the MIME is set to "video/x-divx").

I previously mentioned this in one of the release notes threads, but I guess it was totally overlooked.

Anyhow, the correct line for AVI should be:

Supported = f:avi|divx v:divx|mp4 a:ac3|lpcm|mpa|mp3 m:video/x-divx

Thanks.
User avatar
SubJunk
Lead Developer
Posts: 3315
Joined: Sun May 27, 2012 4:12 pm

Re: [SOLVED]Sony BDP-S590 - 2012 US Models ONLY

Post by SubJunk »

tmeader, if you look at the renderer config included in 2.6.1 you will see your suggestion there at the bottom, it is commented out because it causes incompatibility issues on some Sony BDPs. The options we have included are to my knowledge the best way to make it work on all Sony BDPs.
tmeader
Posts: 4
Joined: Thu Mar 07, 2013 11:54 am

Re: [SOLVED]Sony BDP-S590 - 2012 US Models ONLY

Post by tmeader »

SubJunk wrote:tmeader, if you look at the renderer config included in 2.6.1 you will see your suggestion there at the bottom, it is commented out because it causes incompatibility issues on some Sony BDPs. The options we have included are to my knowledge the best way to make it work on all Sony BDPs.
My apologies, don't know how I missed that :(

Thanks.
Post Reply