Can't run UMS

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
elscorcho
Posts: 1
Joined: Sun Mar 17, 2013 6:33 pm

Can't run UMS

Post by elscorcho » Sun Mar 17, 2013 6:35 pm

I have upgraded to Java7 but still won't run, msg:
'Java Virtual Machine Launcher
Could not find the main class: net.pms.PMS. Program will exit.'
?

orgon3
Posts: 33
Joined: Fri Jun 15, 2012 7:12 pm

Re: Can't run UMS

Post by orgon3 » Mon Mar 18, 2013 5:26 pm

Same here. This happened right after installing 2.5.2.

User avatar
Optimus_prime
Posts: 690
Joined: Fri Jun 01, 2012 6:39 pm
Location: Sydney, Australia

Re: Can't run UMS

Post by Optimus_prime » Mon Mar 18, 2013 6:10 pm

Reinstall and when you get to the screen "Advanced Settings" set the Java heap limit to 1200. I'll report this to Subjunk as he's changed the code for computers with greater than 4GB of ram to have a larger heap size.
I'm sure this will be fixed by the next release.

EDIT: If you dont wont to reinstall you can goto "Run" type "Regedit" Navigate to HKEY_CURRENT_USER\software\Univesal Media Server and change HeapMem to anything below 1200 and you'll be fine
How Ask For Support
Remember, Debug Log's Can/Will Help and Explain your issues, we're not mind reader's but here to help
OS's I Use And Can Assist With: Windows 7/8, Mac OS-X 10.8 & 10.9
Mac OS-X Java 7 Builds Mac OS-X Java 7 Forum

Silverbrain
Posts: 1
Joined: Tue Mar 19, 2013 4:28 am

Re: Can't run UMS

Post by Silverbrain » Tue Mar 19, 2013 4:30 am

Re running the setup with the heap at 1200 fixed the issue. Was about to set it back to 786, but thought I'd check here first. Thanks Optimus.

orgon3
Posts: 33
Joined: Fri Jun 15, 2012 7:12 pm

Re: Can't run UMS

Post by orgon3 » Tue Mar 19, 2013 6:52 am

Optimus_prime wrote:Reinstall and when you get to the screen "Advanced Settings" set the Java heap limit to 1200. I'll report this to Subjunk as he's changed the code for computers with greater than 4GB of ram to have a larger heap size.
I'm sure this will be fixed by the next release.

EDIT: If you dont wont to reinstall you can goto "Run" type "Regedit" Navigate to HKEY_CURRENT_USER\software\Univesal Media Server and change HeapMem to anything below 1200 and you'll be fine
Setting to 1200 still caused the crash. Setting to 1199 still caused the crash. I set it back to 786 and it worked.

User avatar
Optimus_prime
Posts: 690
Joined: Fri Jun 01, 2012 6:39 pm
Location: Sydney, Australia

Re: Can't run UMS

Post by Optimus_prime » Tue Mar 19, 2013 7:30 am

That could be releated to other programs using java as well. If another program is utilising java as well it will lower the amount of Java Memory UMS will be able to allocate itself.
How Ask For Support
Remember, Debug Log's Can/Will Help and Explain your issues, we're not mind reader's but here to help
OS's I Use And Can Assist With: Windows 7/8, Mac OS-X 10.8 & 10.9
Mac OS-X Java 7 Builds Mac OS-X Java 7 Forum

orgon3
Posts: 33
Joined: Fri Jun 15, 2012 7:12 pm

Re: Can't run UMS

Post by orgon3 » Tue Mar 19, 2013 8:41 pm

Optimus_prime wrote:That could be releated to other programs using java as well. If another program is utilising java as well it will lower the amount of Java Memory UMS will be able to allocate itself.
javaw.exe was not running at all until I started UMS. When I exit UMS, javaw.exe terminates as well. It is safe to say that it is the only program currently using Java on my machine.

User avatar
SubJunk
Lead Developer
Posts: 3201
Joined: Sun May 27, 2012 4:12 pm

Re: Can't run UMS

Post by SubJunk » Tue Mar 19, 2013 9:48 pm

Hey it's scorchy! My old friend :D
Hmm, maybe the only safe thing is to go back to using 768 by default for everyone
In the meantime like what was already said, just re-install the program and in the installer replace 1152 in the memory box with 768

Post Reply