Wrong aspect ratio with Panasonic renderer

For help and support with Universal Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Surfy
Posts: 9
Joined: Mon Jan 14, 2019 3:35 am

Wrong aspect ratio with Panasonic renderer

Post by Surfy » Mon Jan 14, 2019 4:42 am

::

Hello Team,
first post, first bug report (no debug files).

Using UMS since several years without a problem. Since 7.6.0 (I think) my Handbrake encoded mp4-files are displayed with wrong aspect ratio. My renderers are Panasonic TVs.

UMS 7.5.0 correct AR:
Image

UMS 8.0.0-b1 wrong AR:
Image


Maybe it's the absence of "FFmpeg DVR-MS Remux" causing this problem.

UMS 7.5.0 (with "FFmpeg DVR-MS Remux"):
Image

UMS 8.0.0-b1:
Image

Attached a 16 seconds clip for verifying.

Here's another post with similar problems on Mac OS. I'm using Windows 7 and Windows 10.
https://www.universalmediaserver.com/fo ... 11&t=13284

If you need more info, please tell me.

Thanks!

::
Attachments
16sClip.zip
(3.77 MiB) Downloaded 109 times
Last edited by Surfy on Tue Jun 16, 2020 10:33 pm, edited 2 times in total.

Surfy
Posts: 9
Joined: Mon Jan 14, 2019 3:35 am

Re: Wrong aspect ratio with Panasonic renderer

Post by Surfy » Mon Feb 25, 2019 12:10 am

::

@SubJunk :

Problem still persists in Version 8.0.0-RC1. :(
Debug files attached! 7.5.0 working perfect.

Come on developers. If you need more info, tell me!


Greetings, ...

::
Attachments
ums_dbg_8.0.0-RC1.zip
(72.29 KiB) Downloaded 107 times
ums_dbg_7.5.0.zip
(69.21 KiB) Downloaded 105 times

Surfy
Posts: 9
Joined: Mon Jan 14, 2019 3:35 am

Re: Wrong aspect ratio with Panasonic renderer

Post by Surfy » Mon Feb 25, 2019 12:17 am

::

... and this seems to be a similar problem:

https://www.universalmediaserver.com/fo ... =9&t=13452


Greetings, ...

::

Zeg
Posts: 1
Joined: Sun Dec 15, 2019 10:19 pm

Re: Wrong aspect ratio with Panasonic renderer

Post by Zeg » Sun Dec 15, 2019 10:25 pm

I've recently upgraded to Win 10 from 7 and am having this problem with a few but not all files.

I wanted to try a legacy version of UMS like 7.5 as suggested, but can't find a download without straying onto a dodgy non UMS site!

So a bit of back grond.

I have a Panasonic 50DX700, hard wired to my PC by powerlines. I had not problem with this sort of file until the upgraded to Win 10. In Win Explorer they seem to have the wrong aspect, and that's what is presented on the TV screen when I access them via UMS. Some files present correctly in Win 10, some do not. The ones that present correctly in 10, play correctly through UMS. If I put all the files on a memory stick and plug that directly into the TV bypassing the PC and UMS then all play at the correct aspect.

Short term solution, uses the memory stick, but I'd like to get to the bottom of the underlying issue.

UMS version is 9.1

Surfy
Posts: 9
Joined: Mon Jan 14, 2019 3:35 am

Re: Wrong aspect ratio with Panasonic renderer

Post by Surfy » Sun Dec 15, 2019 10:58 pm

::

You'll find previous versions here:

https://sourceforge.net/projects/unimed ... s/Windows/

These are official versions.

::

Surfy
Posts: 9
Joined: Mon Jan 14, 2019 3:35 am

Re: [Solved] Wrong aspect ratio with Panasonic renderer

Post by Surfy » Wed May 27, 2020 2:32 am

::

Solved with version 9.5.0 (read changelog, please).
Verified!

Thanks to the whole team, UMS rocks! 8-)

::

Surfy
Posts: 9
Joined: Mon Jan 14, 2019 3:35 am

Re: Wrong aspect ratio with Panasonic renderer

Post by Surfy » Tue Jun 16, 2020 10:47 pm

::

Oh no! :( Problem reintroduced with Version 9.6.2.

Maybe you have to undo "Fixed broken transcoding on renderers with KeepAspectRatio enabled" ... but I don't know.

9.5.0, 9.6.0 and 9.6.1 are working flawlessly.


Greetings, ...

::

User avatar
SubJunk
Lead Developer
Posts: 3157
Joined: Sun May 27, 2012 4:12 pm

Re: Wrong aspect ratio with Panasonic renderer

Post by SubJunk » Wed Jun 17, 2020 9:08 am

Hi surfy, we have a proper fix for it (hopefully) waiting to go out, I'll make a build for you to test soon

User avatar
SubJunk
Lead Developer
Posts: 3157
Joined: Sun May 27, 2012 4:12 pm

Re: Wrong aspect ratio with Panasonic renderer

Post by SubJunk » Thu Jun 18, 2020 2:30 pm

Please let us know if this works, if so we can merge it https://www.universalmediaserver.com/up ... 586fb9.exe

Surfy
Posts: 9
Joined: Mon Jan 14, 2019 3:35 am

Re: Wrong aspect ratio with Panasonic renderer

Post by Surfy » Sat Jun 20, 2020 4:18 am

::

Wow, thanks for your fast reply (and excuse my own lazyness, please). :o
Did a short test and your changes work as expected (at least for me).
Thank you very much! 8-)

::

Post Reply