Version 10.4.0 released

Announcements about Universal Media Server
User avatar
SubJunk
Lead Developer
Posts: 3320
Joined: Sun May 27, 2012 4:12 pm

Version 10.4.0 released

Post by SubJunk »

General:

This release allows renderers like Samsung TVs to disable our resume feature if they have their own one, as well as improves transcoding speed, memory use, and more!

Download:

Downloads for Windows, macOS and Linux, and commands for Docker and Homebrew are available on our download page or from our official mirrors.


Changes since 10.3.0:
  • General:
    • Added renderer config setting DisableUmsResume for renderers with their own resume support, like Samsung TVs
    • Improved speed of transcoding to H.264 by up to 3x
    • Fixed MEncoder crashing when trying to downmix 7.1 AAC to 5.1 AC-3
    • Fixed renderer SupportedVideoBitDepths setting
    • Improved memory use and speed when resume is disabled
    • Fixed renderer resolution and bitrate limiting
    • Fixed broken transcoding for some users since the previous release
  • Renderers:
    • Improved support for VC1 codec on Sony Blu-ray UBP-X800M2 (thanks, thechrisgregory!)
    • Improved support for many filetypes on Kodi (thanks, thechrisgregory!)
    • Improved support for 12-bit video on VLC
  • Translation updates via Crowdin:
    • Estonian (24%) (thanks, Tanel K!)
    • Japanese (97%) (thanks, Katsuhide.M!)
    • Russian (91%) (thanks, Dmitry Lavrentev!)
  • Dependencies:
    • Bump git-commit-id-plugin from 4.0.3 to 4.0.4
    • Rolled back FFmpeg

Operating system support:
  • Windows 7+, and limited support for Windows XP and Vista
  • macOS 10.10+
  • Docker
chickyboom
Posts: 8
Joined: Sat Apr 18, 2020 12:01 pm

Re: Version 10.4.0 released

Post by chickyboom »

On the Navigation Settings tab, I already have "Enable video resuming" turned off.
Does this new "DisableUmsResume" setting do something more? Does it go in a custom config file?
Thanks
User avatar
KONTROLMASTER
Posts: 22
Joined: Wed Aug 06, 2014 6:54 am
Location: RU
Contact:

Re: Version 10.4.0 released

Post by KONTROLMASTER »

Unfortunately, have the same result like previous version for DVDRemux for ex., "800288E1" error. Happens with transcoding or without. Can't play .mkv, .mpg & else.
Maybe it's connected not only with FFMpeg, but with some settings for the last new versions?
Last edited by KONTROLMASTER on Wed Mar 24, 2021 11:46 pm, edited 3 times in total.
User avatar
pipin
Posts: 133
Joined: Fri Dec 28, 2012 12:17 am

Re: Version 10.4.0 released

Post by pipin »

Thanks for the release.

Working fine so far for me.

Did some updates on the german language via crowdin.
Regards,
Jens
-----------
Devices used with UMS : - Windows 10 PC, Samsung UE32 F4580SS, Samsung UE48H6600
User avatar
KONTROLMASTER
Posts: 22
Joined: Wed Aug 06, 2014 6:54 am
Location: RU
Contact:

Re: Version 10.4.0 released

Post by KONTROLMASTER »

Tested it just a few times ago with clean install option and deleted the remaining files manually, the result is the same.
User avatar
SubJunk
Lead Developer
Posts: 3320
Joined: Sun May 27, 2012 4:12 pm

Re: Version 10.4.0 released

Post by SubJunk »

chickyboom wrote: Sun Mar 21, 2021 11:32 pm On the Navigation Settings tab, I already have "Enable video resuming" turned off.
Does this new "DisableUmsResume" setting do something more? Does it go in a custom config file?
Thanks
The user setting you have used is still respected, so you don't have to change anything. This is a renderer-level setting, that allows renderer configs to disable our resume feature if it is enabled.
KONTROLMASTER wrote: Wed Mar 24, 2021 4:34 am Unfortunately, have the same result like previous version for DVDRemux for ex., "800288E1" error. Happens with transcoding or without. Can't play .mkv, .mpg & else.
Maybe it's connected not only with FFMpeg, but with some settings for the last new versions?
Can you please provide logs for this? We might have already fixed it in the upcoming version but logs will let me be sure about that
pipin wrote: Wed Mar 24, 2021 7:54 pm Thanks for the release.

Working fine so far for me.

Did some updates on the german language via crowdin.
Thanks!
User avatar
KONTROLMASTER
Posts: 22
Joined: Wed Aug 06, 2014 6:54 am
Location: RU
Contact:

Re: Version 10.4.0 released

Post by KONTROLMASTER »

Last edited by KONTROLMASTER on Fri Mar 26, 2021 4:06 am, edited 1 time in total.
User avatar
SubJunk
Lead Developer
Posts: 3320
Joined: Sun May 27, 2012 4:12 pm

Re: Version 10.4.0 released

Post by SubJunk »

KONTROLMASTER wrote: Thu Mar 25, 2021 11:16 am Yeah, sure! https://mega.nz/file/5I5UmRaa#PDJwwpeF7 ... PNWqAp7DPo
I can only see an attempt to play on Edge in those logs. I thought the problem was on PS3?
User avatar
KONTROLMASTER
Posts: 22
Joined: Wed Aug 06, 2014 6:54 am
Location: RU
Contact:

Re: Version 10.4.0 released

Post by KONTROLMASTER »

Sorry, updated my post. The first link is for the "Web Interface", just looked it, the second for Ps3!
User avatar
SubJunk
Lead Developer
Posts: 3320
Joined: Sun May 27, 2012 4:12 pm

Re: Version 10.4.0 released

Post by SubJunk »

KONTROLMASTER wrote: Fri Mar 26, 2021 4:10 am Sorry, updated my post. The first link is for the "Web Interface", just looked it, the second for Ps3!
Cool, yes that is fixed in the version I'm starting to release now
Post Reply