Strange transcoding errors

General discussion about Universal Media Server (no support or requests)
Post Reply
Posts: 15
Joined: Wed Sep 11, 2013 5:30 am

Strange transcoding errors

Post by turbo78 »

Hi to all!

I have encountered a strange behavior with some video files, and there is more and more of things like this, so I assume this could be something in encoding of the files, but I can not figure out how to solve this inside UMS. This is happening for a while, and I think it is not in relationship with the version of UMS, because it is updated more times when I start to have this and I have tried to go back to earlier versions and have exactly the same problem.

So the main thing is that I use no transcoding when the video is playable on my Panasonic ST50 plasma. And there is no problem.

The problems start if I have to do a transcode because of external subtitles for example, the same video thats working with no transcode I try to play with FFMPEG or MEncoder and now after about 30-40 seconds the audio is muting, the video contiues to play for some time, then I see something like a jump in cutting, and I have audio and video again but not in sync for about 30-40 seconds again, then a jump and so on... Almost the same in FFMP{EG and Mencoder, the differenc may be in how many seconds the synced tile is played and then starts te mutin/unsync problem.

The only transoder that seems to work is VLC, but there are another two problems that I have with VLC, with this one the Video size ratio is always screwed (whatever the source is I have something streched on TV) and the other more irritating thing with VLC is that if I have 10 subtitles inside the container, or have any external subtitles the VLC is showing ALL of them in the same time, and I can not choose witch one to be readable.

In the list before I start to play I can choose witch video I would like to play, to select audio and title combination, but whatever I chosse it will play all the subtitles simultaneously over the screen.

The only workaround that I have found is to cut off all subtitles that are inside the container, to add the one I have externally inside the conteiner with a third party tool, MKVToolnix GUI and to try to play that video with only one subtitle inside the container with NO TRANSCODING, but I can do this only with supported formats from my TV, or to watch these videos with VLC stretched.

But it is pain when I start to watch a mopvie or a series and discover that I have problems with Audi sync and have convert the movie or all the episodes to be playable with NO TRANSCODE...

I would like to be able to play dem with UMS and transcoding, thats more comfortable.

Thanks in advance for your help!
Posts: 1
Joined: Tue Jul 05, 2022 5:54 am

Re: Strange transcoding errors

Post by Alan56 »

I have EXACTLY the same problems (audio muting with ffmpeg, double subtitles with VLC) with a Panasonic VT50, except for aspect ratio, that is perfect in VLC. The issue of all subtitles showing in the same time in VLC drives me nuts. I tried everithing, but no solution. The only thing to do is use makemkv or MKVtoolnix and create a simple file mkv with only one sub.
Posts: 3
Joined: Thu Dec 06, 2018 11:42 am

Re: Strange transcoding errors

Post by xyr »

And I have the same problem like Alan56 on my Panasonic ST60.

-From version 12 (and upwards) of UMS, transcoding with Mencoder is too CPU intensive for my server. Same files Mencoder transcoded play with no problem in earlier versions. All settings are unchanged (transcode quality, network bandwith, buffer, etc.)

-FFMPEG transcoding usually doesn't start playing the stream and ends with "could not open file" error on TV. BUT, I can make it work like this: I start the FFMPEG transcoded file, wait for 2-3 seconds (it still does not show the picture) then stop it with the remote, and immediately click play again. Like the FFMPEG transcoding needs more time to initialize and if I don't do this dance, something (TV or UMS?) decides it didn't start and never will, and stops it all.

-VLC transcoding was always my go to that works without stuttering, but since a lot of versions ago (maybe years) it always displayed allthe subtitles (embedded in video file) at the same time.

Server and TV are on the 100mbps wired ethernet, Panasonic TV renderer estimated network speed is around 50mbps. Server is old quad Xeon 4x3.2GHz
User avatar
Posts: 835
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: Strange transcoding errors

Post by mik_s »

I sometimes get that unplayable error on my PS4 on some videos that need to be transcoded. I have found that it happens on videos that have a lot of subtitles and it takes FFmpeg a little longer to parse all those before starting to transcode. This delay will make the PS4 time out and give an error. I have to do the same thing on these videos with clicking the video and wait a few seconds, stopping it and play again.

I don't know if this is a problem with UMS or FFmpeg and what can be done to fix it, it may have always been a problem but I have found that it happens more these days but may be due to videos having more subtitles in them now.

I have heard a few people mention that all subtitles get transcoded into the stream at the same time and I have seen only seen it happen once a few versions ago when I tried the web player, but have not seen it happen again. If you can easily repeat this then could you post logs so I see what is happening.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
Post Reply