UMS docker deploy: Cannot invoke "com.google.gson.JsonElement.isJsonObject()" because "element" is null

For help and support with Universal Media Server
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
Post Reply
Drucchi
Posts: 1
Joined: Tue Sep 13, 2022 6:44 am

UMS docker deploy: Cannot invoke "com.google.gson.JsonElement.isJsonObject()" because "element" is null

Post by Drucchi »

Dear UMS users,

Today I find myself with an issue regarding the docker-version of UMS. For some reason it will not properly initialize. This all happened yesterday, when it may have pulled in the latest version from the repository (can't be sure though). But I cannot get this working again.
After telling me the web-interface should be reachable (wich it isn't) I get this log line:
ERROR 18:27:05.625 [main] A serious error occurred during Universal Media Server initialization: Cannot invoke "com.google.gson.JsonElement.isJsonObject()" because "element" is null

Please find my config and debug log files attached.

I tried clearing the database and all files except UMS.conf, UMS.cred and WEB.conf, but that didn't change anything.

Any suggestions are welcome.
Attachments
UMS_logging&config.zip
(101.65 KiB) Downloaded 197 times
User avatar
mik_s
Moderator
Posts: 1180
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: UMS docker deploy: Cannot invoke "com.google.gson.JsonElement.isJsonObject()" because "element" is null

Post by mik_s »

I had a quick look but could not see anything obvious that could be causing that error, but I don't know anything about Docker.
It might be something the devs will know what is happening. I suggest you post an issue on GitHub so they will be able to respond quicker.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
thebrood014
Posts: 1
Joined: Fri Feb 03, 2023 7:01 pm

Re: UMS docker deploy: Cannot invoke "com.google.gson.JsonElement.isJsonObject()" because "element" is null

Post by thebrood014 »

i'm have the same problem A serious error occurred during Universal Media Server initialization: Cannot invoke "com.google.gson.JsonElement.isJsonObject()" because "element" is null and i don't know what to do. all my debug info is attached.
ums_dbg_2023-02-03-02-04.zip
(126.24 KiB) Downloaded 174 times
User avatar
mik_s
Moderator
Posts: 1180
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: UMS docker deploy: Cannot invoke "com.google.gson.JsonElement.isJsonObject()" because "element" is null

Post by mik_s »

I knew I saw this error before, but could not remember where.

This is a bug that has already been fixed for the next version. I found out that if you turn off the external network option then this will allow UMS to initialize the web settings properly. I only found this out yesterday as I was hit with this bug too. More info here.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
OldenBroken
Posts: 6
Joined: Wed Apr 17, 2019 3:09 pm

Re: UMS docker deploy: Cannot invoke "com.google.gson.JsonElement.isJsonObject()" because "element" is null

Post by OldenBroken »

I uncheck the extrernal network option but the damn thing keeps turning itself back on.
User avatar
mik_s
Moderator
Posts: 1180
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: UMS docker deploy: Cannot invoke "com.google.gson.JsonElement.isJsonObject()" because "element" is null

Post by mik_s »

I think that part of the old GUI might be broken as I could not get that option to turn off and save either. Works fine turning back on though.

You can edit the UMS.conf in C:\ProgramData\UMS to change the option "external_network =false", make sure UMS is not running when you change it.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
Post Reply