How to disable transcoding ?

General discussion about Universal Media Server (no support or requests)
Post Reply
emoxam
Posts: 10
Joined: Sat Feb 04, 2023 7:33 pm

How to disable transcoding ?

Post by emoxam »

I want to disable transcoding nd hist transcode folders, can i do it ?
Thanks
User avatar
mik_s
Moderator
Posts: 1158
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: How to disable transcoding ?

Post by mik_s »

UMS should only be transcoding when the video is not supported by the renderer you are playing it on and it allows it to be converted to a format that can be played.
This is all setup in the supported formats section of the renderer's conf file
If UMS Is not picking the right conf it might unnecessarily transcode when is not needed. Will need logs to see what it is choosing to do though.

You can totally disable all transcoding by setting "Force transcoding for the following extensions (comma separated):" to [*]* in the transcoding settings tab.
This is not recommended as you are likely to have videos not supported by your player and this will not be able to be watched any more.

To hide the #--TRANSCODE--# folder the uncheck Show the "#--TRANSCODE--#" folder in navigation settings tab in the virtual folders/files section.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
emoxam
Posts: 10
Joined: Sat Feb 04, 2023 7:33 pm

Re: How to disable transcoding ?

Post by emoxam »

I think UWS must show all of it's settings by default. Without any options!
And btw - why aren't we using config file that lies near thew executabale files ? Why main cionfig that is used is at program data ? Thats confuses a lot!
We should use then one that is near the exe, or delete this one and tell user where config file is located! It's a quest to find this out!
boss
Posts: 352
Joined: Thu Jun 30, 2016 1:07 pm

Re: How to disable transcoding ?

Post by boss »

And btw - why aren't we using config file that lies near thew executabale files ? Why main cionfig that is used is at program data ?
It is the way it is normally done in Windows.
The executables are in "Program Files" or "Program Files (x86)" and the config files are in:
"users/username/AppData/Local"
or
"users/username/AppData/LocalLow"
or
"users/username/AppData/Roaming"

Then they are redisplayed in the "ProgramData" folder.

The reason is that the program only needs to be on the computer once but different users may want their configuration differently.
User avatar
mik_s
Moderator
Posts: 1158
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: How to disable transcoding ?

Post by mik_s »

Also the "ProgramData" folder is used for all users or for programs that don't have users.

Using the installation directory is usually not possible as programs don't have access to write in system folders unless they are given admin access which is not needed.
This video explains the differences in these settings folders.

Any conf files in the main directory are copied to ProgramData on installation if they do not exist and these have all the default settings.

When first installing UMS there is an option to show all or only basic options. The options are only hidden if you chose to hide them.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
emoxam
Posts: 10
Joined: Sat Feb 04, 2023 7:33 pm

Re: How to disable transcoding ?

Post by emoxam »

If UWC won't use conf at other palces just don't create it there. It's confusing.
What is hiden options is not clear when you install the UWC for the first time. ANd in case of two configs in confusing too.
So no nedd in redudant config and hiding-options-mode.
thats it.
User avatar
mik_s
Moderator
Posts: 1158
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: How to disable transcoding ?

Post by mik_s »

It needs to be there. All other windows programs do the same thing.
Apart from a few specialised options that are not on the GUI you should have no need to edit the conf manually. All the main options are configurable in the Web interface or the old GUI.

When UMS installs is asks do you want to hide advanced options. If you want to see all the options then make sure you show them.

The option "Hide advanced options" is there in General Settings so you can change it any time.
There are a lot of settings there that can be overwhelming for some people and might not need to be changed from the default values to get UMS working well.
All that really needs setting up is the shared folders. Everything else is customisation and tweaks.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
dmitche3
Posts: 20
Joined: Thu Feb 19, 2015 12:38 pm

Re: How to disable transcoding ?

Post by dmitche3 »

I would agree with that there is no need to manually update the ums.conf file except that with the new GUI browser some options are not available, and when checked in the browser they don't keep.
My primary example is to not start a GUI browser on start. I've tried setting this using the browser but it never keeps.
User avatar
mik_s
Moderator
Posts: 1158
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: How to disable transcoding ?

Post by mik_s »

There is a bug with the settings saving in 13.7.0 but has been fixed in 13.8.0
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
Post Reply