How to disable web interface

For help and support with Universal Media Server
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply
WAusJackBauer
Posts: 23
Joined: Mon Jun 22, 2015 10:53 pm

Re: How to disable web interface

Post by WAusJackBauer »

Installed fresh install of version 13.7.0 today and went to disable the Web GUI on startup within the Web GUI and then click save. The saving settings message would just stay on screen and the settings wouldn't save. Restarted my computer and tried again but it didn't work.

Had to manually change it in config file.
boss
Posts: 352
Joined: Thu Jun 30, 2016 1:07 pm

Re: How to disable web interface

Post by boss »

In the config file (UMS.conf), you would have the setting like this:

# Web gui on start
# ----------
# Whether a browser page will load on program startup
# Default: true
web_gui_on_start =false
User avatar
mik_s
Moderator
Posts: 1170
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: How to disable web interface

Post by mik_s »

I just tried 13.7.0 and came across a problem where nothing would play, but saw in the logs it was trying to use a different transcoding engine.
I went to disable that option (Remux videos with tsMuxeR when possible instead of transcoding) but I got the constantly spinning saving logo too and nothing got saved.

I think a couple of things have broken in this version so I'll do a bit more testing later for anything else before I make an issue on Github.

Editing UMS.conf manually is the way round this for now, or use the old GUI if not running on a headless system.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
binary512
Posts: 6
Joined: Sat Sep 30, 2017 2:10 am

Re: How to disable web interface

Post by binary512 »

How do you use the "old GUI"? And where is the UMS.conf file stored?
User avatar
mik_s
Moderator
Posts: 1170
Joined: Wed Aug 23, 2017 11:03 pm
Location: UK

Re: How to disable web interface

Post by mik_s »

Right click the tray icon and choose "settings (old)".
UMS.conf is located in C:\ProgramData\UMS on windows.
Logs are important for us to help, Please follow This Link before asking for support. Just a forum cleaner, Will help if I can but no expert.
Post Reply