14.0.0-b1

Announcements about Universal Media Server
Post Reply
User avatar
SubJunk
Lead Developer
Posts: 3719
Joined: Sun May 27, 2012 4:12 pm

14.0.0-b1

Post by SubJunk »

Our first public V14 release is finally here!

The biggest changes involve the ability to control access to your content. This includes improvements to user accounts like avatars and playback status per user, as well as the ability to display different content to different devices.

There have also been many updates to the web settings and player interfaces, including adding the ability to mark sets of files (e.g. TV series) as fully played, and automatic detection of your system dark/light mode preference.

For more details and public download links, see the announcement at https://www.patreon.com/posts/14-0-0-b1-95389502
AVEE
Posts: 1
Joined: Mon Jan 08, 2024 4:26 pm

Re: 14.0.0-b1

Post by AVEE »

Green linuxer giving it a spin on my headless Ubuntu 20.4 file server to try and make it a media server to recognize in my new Denon X1800 AVR via HEOS. Wish me luck.
boss
Posts: 352
Joined: Thu Jun 30, 2016 1:07 pm

Re: 14.0.0-b1

Post by boss »

AVEE wrote: Mon Jan 08, 2024 4:36 pm Green linuxer giving it a spin on my headless Ubuntu 20.4 file server
I've been running UMS on a Gentoo Linux headless file server for many years and it works fine.
One of the renderers I use is a Yamaha AVR which also works fine so I think you should be OK with your Denon AVR. The Denon conf file may just need a bit of tweeking,
Good luck.
User avatar
KONTROLMASTER
Posts: 40
Joined: Wed Aug 06, 2014 6:54 am
Location: Rusteam
Contact:

Re: 14.0.0-b1

Post by KONTROLMASTER »

Everything is working all right for now on in terms of the playback, just about! The only problems which could be notice are (web interface): the TV Series episodes with same name, but different year add up in one folder, even if the filename has it; web ui still leaves blank folders and the built-in function for clear up the cache mismatches the images and leaves elements.
User avatar
SubJunk
Lead Developer
Posts: 3719
Joined: Sun May 27, 2012 4:12 pm

Re: 14.0.0-b1

Post by SubJunk »

Thanks for the feedback, we have fixed a lot of things since this beta including the tv series bug you mentioned, and will do another release soon. There is still a bug that we are working on fixing before doing the final release
fenwal
Posts: 5
Joined: Tue Feb 13, 2024 6:00 am

Re: 14.0.0-b1

Post by fenwal »

I'm really hopeful about the video series conflation fixes. Thanks in advance!

If time permits, consider fixing this too...

In the Player, you click on a "movie icon" to get a new window with more detailed information about the movie. OK, good. However, clicking the ".." button does not return you to the same "movie icon" spot in the main window; instead, you are positioned back at the beginning of the main movie list.
issafram
Posts: 5
Joined: Mon Dec 13, 2021 2:11 pm

Re: 14.0.0-b1

Post by issafram »

@SubJunk, your news feed isn't working on the homepage. It also shows the username for the DB.
User avatar
SubJunk
Lead Developer
Posts: 3719
Joined: Sun May 27, 2012 4:12 pm

Re: 14.0.0-b1

Post by SubJunk »

fenwal wrote: Thu Apr 25, 2024 4:48 am I'm really hopeful about the video series conflation fixes. Thanks in advance!

If time permits, consider fixing this too...

In the Player, you click on a "movie icon" to get a new window with more detailed information about the movie. OK, good. However, clicking the ".." button does not return you to the same "movie icon" spot in the main window; instead, you are positioned back at the beginning of the main movie list.
Thanks for reporting this, I have created an issue on our tracker for it https://github.com/UniversalMediaServer ... ssues/4614

issafram wrote: Sat Apr 27, 2024 7:38 am @SubJunk, your news feed isn't working on the homepage. It also shows the username for the DB.
Oof, that's embarrassing :) It's fixed now. Thanks for letting me know!
issafram
Posts: 5
Joined: Mon Dec 13, 2021 2:11 pm

Re: 14.0.0-b1

Post by issafram »

No problem. Btw I recommend you host the database on a separate server. Don't keep everything on one box
Post Reply